本文主要是介绍(NYoj 284)坦克大战--裸BFS ,优先队列,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
坦克大战
时间限制:1000 ms | 内存限制:65535 KB
难度:3
描述
Many of us had played the game “Battle city” in our childhood, and some people (like me) even often play it on computer now.
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).
Your tank can’t move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
输入
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of ‘Y’ (you), ‘T’ (target), ‘S’ (steel wall), ‘B’ (brick wall), ‘R’ (river) and ‘E’ (empty space). Both ‘Y’ and ‘T’ appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
输出
For each test case, please output the turns you take at least in a separate line. If you can’t arrive at the target, output “-1” instead.
样例输入
3 4
YBEB
EERE
SSTE
0 0
样例输出
8
分析:
裸的BFS,直接使用优先队列即可。进空格需要一步,进普通砖块需要两步。
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;struct node
{int x,y,time;friend bool operator < (node a,node b){return a.time>b.time;}
};
char maze[310][310];
int vis [310][310];
int yx,yy;
int dx[4]={0,0,-1,1};
int dy[4]={1,-1,0,0};
int m,n;int bfs()
{memset(vis,0,sizeof(vis));node now,next;now.x=yx;now.y=yy;now.time=0;priority_queue<node> pq;while(!pq.empty()) pq.pop();vis[yx][yy]=1;pq.push(now);while(!pq.empty()){now=pq.top();pq.pop();if(maze[now.x][now.y]=='T'){return now.time;}for(int i=0;i<4;i++){next.x=now.x+dx[i];next.y=now.y+dy[i];if(next.x>=0 && next.x<m && next.y>=0 && next.y<n && !vis[next.x][next.y]){if(maze[next.x][next.y]=='E' || maze[next.x][next.y]=='T'){next.time=now.time+1;vis[next.x][next.y]=1;pq.push(next);}if(maze[next.x][next.y]=='B'){next.time=now.time+2;vis[next.x][next.y]=1;pq.push(next);}}}}return -1;
}int main()
{while(scanf("%d%d",&m,&n)==2 && n && m){for(int i=0;i<m;i++){scanf("%s",maze[i]);for(int j=0;j<n;j++){if(maze[i][j]=='Y'){yx=i;yy=j;}}}printf("%d\n",bfs());}return 0;
}
这篇关于(NYoj 284)坦克大战--裸BFS ,优先队列的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!