本文主要是介绍Hdu 4565 So Easy! 矩阵快速幂+共轭数,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
So Easy!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4352 Accepted Submission(s): 1421
Problem Description
A sequence S n is defined as:
Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
You, a top coder, say: So easy!
Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
You, a top coder, say: So easy!
Input
There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
Output
For each the case, output an integer S n.
Sample Input
2 3 1 2013 2 3 2 2013 2 2 1 2013
Sample Output
4 14 4
Source
2013 ACM-ICPC长沙赛区全国邀请赛——题目重现
重要条件:(a-1)2< b < a2
由此可得0<(a-sqrt(b))^n<1
设 (a+sqrt(b))^n=xn+ynsqrt(b),则(a+sqrt(b))^n+(a-sqrt(b))^n=2*Xn是整数,而后面的部分又小于1,所以答案就是2*Xn.
(a+sqrt(b))^(n+1)=(xn+ynsqrt(b))*(a+sqrt(b))=aXn+bYn+(Xn+bYn)sqrt(b)=Xn+1 + Yn+1,可以使用矩阵快速幂求得答案。
#include <cstdio>
#include <iostream>
#include <string.h>
using namespace std;
typedef long long ll;
const int size=2;
ll m;struct Matrix {ll a[size][size];
};Matrix operator*(const Matrix &x,const Matrix &y) {int i,j,k;Matrix ans;for (i=0;i<size;i++) {for (j=0;j<size;j++) {ans.a[i][j]=0;for (k=0;k<size;k++) {ans.a[i][j]+=x.a[i][k]*y.a[k][j];ans.a[i][j]%=m;}}} return ans;
}Matrix fastpower(Matrix base,ll index) {Matrix ans,now;int i,j;for (i=0;i<size;i++) {for (j=0;j<size;j++) {if (i==j) ans.a[i][j]=1; else ans.a[i][j]=0;}}now=base;ll k=index;while (k) {if (k%2) ans=ans*now;now=now*now;k/=2;}return ans;
}int main() {ll a,b,n;while (scanf("%lld%lld%lld%lld",&a,&b,&n,&m)!=EOF) {Matrix x;x.a[0][0]=x.a[1][1]=a;x.a[0][1]=b;x.a[1][0]=1;Matrix sum=fastpower(x,n);ll ans=sum.a[0][0];ans*=2;ans%=m;printf("%lld\n",ans);}return 0;
}
这篇关于Hdu 4565 So Easy! 矩阵快速幂+共轭数的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!