本文主要是介绍POJ 2585 Window Pains(窗口的颜色显示问题,拓扑排序,经典题目),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 1980 | Accepted: 998 |
Description
|
|
| ||||||||||||||||||||||||||||||||||||||||||||||||
|
|
| ||||||||||||||||||||||||||||||||||||||||||||||||
|
|
|
| If window 4 were then brought to the foreground: |
|
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .
Input
A single data set has 3 components:
- Start line - A single line:
START
- Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space.
- End line - A single line:
END
After the last data set, there will be a single line:
ENDOFINPUT
Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.
Output
THESE WINDOWS ARE CLEAN
Otherwise, the output will be a single line with the statement:
THESE WINDOWS ARE BROKEN
Sample Input
START 1 2 3 3 4 5 6 6 7 8 9 9 7 8 9 9 END START 1 1 3 3 4 1 3 3 7 7 9 9 7 7 9 9 END ENDOFINPUT
Sample Output
THESE WINDOWS ARE CLEAN THESE WINDOWS ARE BROKEN
Source
i题意:
显示颜色的问题,一种颜色有一种显示的区域,大的可以覆盖小的。给定几个矩阵,问显示效果怎么样,好的话输出一句,否则输出另外一句。
具体参考书籍《图论》哈工大出版社。
i思路:
每个显色的数字位置如图:
这可是学姐在黑板上一点点画出来的图(这是我用EXCEL打的),讲题挺认真的,负责。
i参考代码:
实现方式:二维数组
#include<stdio.h>
#include<string.h>
const int MYDD=1103;int indegree[MYDD];
int map[113][113];
int dx[]= {0,1,0,1};
int dy[]= {0,0,1,1}; //移动的方向,注意不同于搜索
int local[10][2]= {-1,-1, 0,0, 0,1, 0,2, 1,0, 1,1, 1,2, 2,0, 2,1, 2,2};
//窗口的固定位置
bool TopoSort() {int now,flag;// now 当前选中的节点;flag 标记合法性for(int j=1; j<=9; j++) {flag=0;for(int i=1; i<=9; i++) {if(!indegree[i]) {flag=1;now=i;break;//入度为 0 即前驱}}if(!flag) return false;indegree[now]=-1;//标记前驱数量为 -1for(int i=1; i<=9; i++)//当前节点的后继节点入度 -1if(map[now][i]) indegree[i]--;}return true;
}int main() {char C[32];while(1) {scanf("%s",C);if(!strcmp(C,"ENDOFINPUT")) break;//结束测试数据memset(indegree,0,sizeof(indegree));//数组的初始化memset(map,0,sizeof(map));int screen[16][16];for(int j=0; j<4; j++)for(int k=0; k<4; k++)scanf("%d",&screen[j][k]);scanf("%s",C);for(int j=1; j<=9; j++) {for(int k=0; k<4; k++) {int gx=local[j][0]+dx[k];int gy=local[j][1]+dy[k];int now=screen[gx][gy];//当前屏幕显示的数字if(now!=j&&!map[j][now]) {map[j][now]=1;indegree[now]++;}}
// printf("**********\n");}if(TopoSort()) puts("THESE WINDOWS ARE CLEAN");else puts("THESE WINDOWS ARE BROKEN");}return 0;
}
这篇关于POJ 2585 Window Pains(窗口的颜色显示问题,拓扑排序,经典题目)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!