本文主要是介绍1091 Acute Stroke (30 分),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).
Then L slices are given. Each slice is represented by an M×N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.
Figure 1
Output Specification:
For each case, output in a line the total volume of the stroke core.
Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:
26
代码:
#include<iostream>
#include<queue>
using namespace std;
const int maxrow=1290;
const int maxcol=130;
const int maxslice=61;
int matrix[maxslice][maxrow][maxcol];
bool inq[maxslice][maxrow][maxcol];
int M,N,L,T;
int X[6]={0,0,0,0,1,-1};
int Y[6]={0,0,1,-1,0,0};
int Z[6]={1,-1,0,0,0,0};
struct Node
{int x,y,z;
};
void Init()//初始化
{for(int k=0;k<maxslice;k++)for(int i=0;i<maxrow;i++)for(int j=0;j<maxcol;j++)inq[k][i][j]=false;
}
void input(int M,int N,int L)
{for(int k=0;k<L;k++)for(int i=0;i<M;i++)for(int j=0;j<N;j++)scanf("%d",&matrix[k][i][j]);
}
bool test(int k,int i,int j)
{if(k>=L||i>=M||j>=N||k<0||i<0||j<0)return false;if(matrix[k][i][j]==0)return false;if(inq[k][i][j]==true)return false;return true;
}
int BFS(int i0,int j0,int k0)
{int Total=0;queue<Node> q;Node p;p.x=i0;p.y=j0;p.z=k0;if(test(k0,i0,j0)==false)return 0;inq[k0][i0][j0]=true;q.push(p);while(!q.empty()){Node temp=q.front();q.pop();Total++;for(int k=0;k<6;k++)if(test(temp.z+Z[k],temp.x+X[k],temp.y+Y[k])){Node a;a.z=temp.z+Z[k];a.x=temp.x+X[k];a.y=temp.y+Y[k];q.push(a);inq[a.z][a.x][a.y]=true;}}if(Total>=T)return Total;else return 0;
}
int main()
{int ans=0;Init();scanf("%d%d%d%d",&M,&N,&L,&T);input(M,N,L);for(int k=0;k<L;k++)for(int i=0;i<M;i++)for(int j=0;j<N;j++)ans+=BFS(i,j,k);printf("%d",ans);return 0;
}
这篇关于1091 Acute Stroke (30 分)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!