本文主要是介绍uva10285 Longest Run on a Snowboard(dp之记忆化搜索 ),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
10285 Longest Run on a Snowboard
Michael likes snowboarding. That’s not very surprising, since snowboarding is really great. The bad
thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when
you’ve reached the bottom of the hill you have to walk up again or wait for the ski-lift.
Michael would like to know how long the longest run in an area is. That area is given by a grid of
numbers, defining the heights at those points. Look at this example:
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
One can slide down from one point to a connected other one if and only if the height decreases. One
point is connected to another if it’s at left, at right, above or below it. In the sample map, a possible
slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-…-3-2-1, it would
be a much longer run. In fact, it’s the longest possible.
Input
The first line contains the number of test cases N . Each test case starts with a line containing the
name (it’s a single string), the number of rows R and the number of columns C. After that follow R
lines with C numbers each, defining the heights. R and C won’t be bigger than 100, N not bigger than
15 and the heights are always in the range from 0 to 100.
Output
For each test case, print a line containing the name of the area, a colon, a space and the length of the
longest run one can slide down in that area.
Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
Universidad de Valladolid OJ: 10285 – Longest Run on a Snowboard 2/2
14 23 22 21 8
13 12 11 10 9
Sample Output
Feldberg: 7
Spiral: 25
记忆化搜索
/*
Solve:
*/
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<stack>
#include<string>
#include<set>
#include<fstream>
using namespace std;
#define pb push_back
#define cl(a,b) memset(a,b,sizeof(a))
#define bug printf("===\n");
#define rep(a,b) for(int i=a;i<b;i++)
#define rep_(a,b) for(int i=a;i<=b;i++)
#define P pair<int,int>
#define X first
#define Y second
#define vi vector<int>
const int maxn=105;
const int inf=999999999;
typedef long long LL;
void Max(int&a,int b){if(a<b)a=b;}
char name[50];
int a[maxn][maxn];
int dp[maxn][maxn];//end with (i,j) you can get the max length
int n,m;
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};int dfs(int x,int y){//表示从(x,y)这个点出发,所能到达的最大长度if(dp[x][y]){return dp[x][y];}int ans=0;for(int i=0;i<4;i++){int xx=dx[i]+x;int yy=dy[i]+y;if(xx>=1&&xx<=n&&yy>=1&&yy<=m&&a[xx][yy]<a[x][y]){ans=max(ans,dfs(xx,yy));//记录下这个点出发的四个方向中最大的那个}}dp[x][y]+=ans+1;//最大值加上当前这个点return dp[x][y];
}int main(){int T;scanf("%d",&T);while(T--){scanf("%s%d%d",name,&n,&m);int mxv=0,pi,pj;for(int i=1;i<=n;i++){for(int j=1;j<=m;j++){scanf("%d",&a[i][j]);if(a[i][j]>mxv){mxv=a[i][j];pi=i;pj=j;}}}cl(dp,0);int mx=1;for(int i=1;i<=n;i++){for(int j=1;j<=m;j++){mx=max(mx,dfs(i,j));//遍历每一个点}}printf("%s: %d\n",name,mx);}return 0;
}
/*
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
*/
这篇关于uva10285 Longest Run on a Snowboard(dp之记忆化搜索 )的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!