BestCoder #47 10011002

2024-08-27 02:32
文章标签 47 bestcoder 10011002

本文主要是介绍BestCoder #47 10011002,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

【比赛链接】clikc here~~

ps:真是wuyu~~做了两小时,A出两道题,最后因为没加longlong全部被别人hack掉!,最后居然不知道hack别人不成功也会掉分,还一个劲的hack 别人的代码,昨天真是个悲催的比赛,~~~~(>_<)~~~~,下面弱弱献上代码~~

1002比1001还简单~~

1002  Senior's Gun

/*
BestCoder Round #47
1002   Senior's Gun*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>using namespace std;#define rep(i,j,k) for(int i=(int)j;i<=(int)k;i++)
#define per(i,j,k) for(int i=(int)j;i>=(int)k;i--)
typedef long long LL;
typedef unsigned long long LLU;
typedef double db;const int N =2*1e5+10;
int n,m,t,p,res,cnt;
LL ans,tmp;
int num[N];
int aa[N],bb[N];
char str[N];
bool vis[N];int main()
{scanf("%d",&t);while (t--){scanf("%d%d",&n,&m);for (int i=1; i<=n; i++) scanf("%d",&aa[i]);for (int i=1; i<=m; i++) scanf("%d",&bb[i]);sort(aa+1,aa+n+1);sort(bb+1,bb+m+1);ans=0;int j=n;for (int i=1; i<=min(n,m); i++)if(aa[j]>bb[i]){ans+=aa[j]-bb[i];j--;}else break;printf("%I64d\n",ans);}return 0;
}

Sample Input
1
2 2
2 3
2 2
Sample Output
1

1001 Senior's Array

/*
BestCoder Round #47
1001   Senior's Array*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>using namespace std;#define rep(i,j,k) for(int i=(int)j;i<=(int)k;i++)
#define per(i,j,k) for(int i=(int)j;i>=(int)k;i--)
typedef long long LL;
typedef unsigned long long LLU;
typedef double db;const int N =2*1e4+10;
int n,m,t,p;
int aa[N],bb[N];
char str[N];
bool vis[N];int main()
{scanf("%d",&t);while (t--){scanf("%d%d",&n,&p);rep(i,1,n) scanf("%d",&aa[i]);LL ans=-1e9;rep(i,1,n){int tmp=aa[i];aa[i]=p;LL now=0;rep(j,1,n){now+=(1ll)*aa[j];if(now>ans) ans=now;if(now<0) now=0;}aa[i]=tmp;}printf("%I64d\n",ans);}return 0;
}


Sample Input
2
3 5
1 -1 2
3 -2
1 -1 2
Sample Output
8
2

这篇关于BestCoder #47 10011002的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1110383

相关文章

Codeforces Beta Round #47 C凸包 (最终写法)

题意慢慢看。 typedef long long LL ;int cmp(double x){if(fabs(x) < 1e-8) return 0 ;return x > 0 ? 1 : -1 ;}struct point{double x , y ;point(){}point(double _x , double _y):x(_x) , y(_y){}point op

代码训练营 Day26 | 47.排序II | 51. N-皇后 |

47.排序II 1.跟46题一样只不过加一个树层去重 class Solution(object):def backtracking(self,nums,path,result,used):# recursion stopif len(path) == len(nums):# collect our setresult.append(path[:])return for i in range(

代码随想录刷题day25丨491.递增子序列 ,46.全排列 ,47.全排列 II

代码随想录刷题day25丨491.递增子序列 ,46.全排列 ,47.全排列 II 1.题目 1.1递增子序列 题目链接:491. 非递减子序列 - 力扣(LeetCode) 视频讲解:回溯算法精讲,树层去重与树枝去重 | LeetCode:491.递增子序列_哔哩哔哩_bilibili 文档讲解:https://programmercarl.com/0491.%E9%80%92%E

认知杂谈47

今天分享 有人说的一段争议性的话 I I 一、价值观是否契合 价值观那可是两个人能不能长久在一起的重要根基。要是价值观差得太多,在好多大事上肯定容易闹矛盾、起冲突。 I I 人生目标是否一致:就比如说,一方就想过那种安安稳稳、平平淡淡的日子,每天按部就班地朝九晚五,能有更多时间陪陪家人。可另一方呢,一门心思追求事业上的大成功,为了工作啥个人时间都舍得牺牲。要是两个人在人生目标上差这么大,

[C++11#47] (四) function包装器 | bind 函数包装器 | 结合使用

目录 一. function包装器 1. 在题解上  2.bind 绑定 1.调整参数顺序 2.对类中函数的包装方法 一. function包装器 function包装器也叫作适配器。C++中的function本质是一个类模板,也是一个包装器。 那么我们来看看,我们为什么需要function呢? ret = func(x);// 上面func可能是什么呢?那么func可能

LeetCode 46 Permutations + LeetCode 47 Permutations II

题意: 给出一串(46题)不重复or(47题)有重复的数字,要求输出所有排列。 思路: 有没有重复不影响思路 = =。 代码展示为46题提交结果,47题一样过…… 可以偷懒用next_permutation方法也可以自己实现,实现方法为从后往前找第一个出现的nums[i] < nums[i+1],从i后面找出比nums[i]稍大一点的数字nums[x],交换nums[i]和nums[

魔幻数字47

魔幻数字47 Time Limit: 1000MS Memory limit: 32768K 题目描述 数字47一向被数学界的人认为是很魔幻的一个数字,和47有关的任务被认为是魔幻任务。现在有一个简单的魔幻任务,给定a和b,打印所有在 以a,b为端点的闭区间 中最后两位为47的整数,你能一次AC吗?? 输入 第一行为一个整数n,表示有多少组测试数据。(n <=

C++入门基础知识47——【关于C++函数】之函数参数及参数默认值

成长路上不孤单😊【14后,C++爱好者,持续分享所学,如有需要欢迎收藏转发😊😊😊😊😊😊😊!!!!!!今日分享关于C++函数之函数参数及参数默认值的相关内容! (接上篇……) 四、函数参数 如果函数要使用参数,则必须声明接受参数值的变量。这些变量称为函数的形式参数。 形式参数就像函数内的其他局部变量,在进入函数时被创建,退出函数时被销毁。 当调用函数时,有两种向函数传递

day-47 子集

思路 利用深度优先遍历算法,对于每个数有选或不选两种抉择,每次遍历到ids==len时将p加入答案中 解题过程 选中当前数字,调用dfs函数之后记得还原 Code class Solution {public int len;public List<List<Integer>> list=new ArrayList<>();public List<List<Integer>> subset

day-47 组合

思路 回溯:利用个dfs方法递归调用,每个元素有选或不选两种抉择,当选中元素个数等于k时,将链表p加入答案,当ids==n且选中元素个数小于n时,直接返回 解题过程 每次选中元素调用dfs方法后记得还原 Code class Solution {public List<List<Integer>> list =new ArrayList<>();public int nn;public i