本文主要是介绍HYSBZ 3674: 可持久化并查集加强版——主席树+并查集,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Description:
自从zkysb出了可持久化并查集后……
hzwer:乱写能AC,暴力踩标程
KuribohG:我不路径压缩就过了!
ndsf:暴力就可以轻松虐!
zky:……
n个集合 m个操作
操作:
1 a b 合并a,b所在集合
2 k 回到第k次操作之后的状态(查询算作操作)
3 a b 询问a,b是否属于同一集合,是则输出1否则输出0
请注意本题采用强制在线,所给的a,b,k均经过加密,加密方法为x = x xor lastans,lastans的初始值为0
0<n,m<=2∗105 0 < n , m <= 2 ∗ 10 5
Sample Input
5 6
1 1 2
3 1 2
2 1
3 0 3
2 1
3 1 2
Sample Output
1
0
1
每个叶子结点记的是他的父亲信息,finds就和并查集差不多,dep记录的是这个数的深度,比如说,1-2-3-4就是
4,然后加上一个5-6,深度还是4,如果加上的是5-6-7-8,那么他的深度就需要加一,这个就是路径压缩,因为并不需要每次都更新深度,所以记一个flag,题目要求强制在线处理,x^lastans,所以需要异或一下。。。
还有就是一般数组大小开到maxn*25(有时候也有40),否则很容易re,浪费罚时。
#include<iostream>
#include<stdio.h>
using namespace std;
#define maxn 200005
int fa[maxn*25],ls[maxn*25],rs[maxn*25],rt[maxn*25],dep[maxn*25];
int tot,n,m;
void build(int l,int r,int &root)
{root=++tot;if(l==r){fa[root]=l;return ;}int mid=l+r>>1;build(l,mid,ls[root]);build(mid+1,r,rs[root]);
}
void update(int l,int r,int root,int last,int pre,int nex,int flag)
{fa[root]=fa[last];ls[root]=ls[last];rs[root]=rs[last];dep[root]=dep[last];if(l==r){if(flag==0)fa[root]=nex;dep[root]+=flag;return;}int mid=l+r>>1;if(mid>=pre)update(l,mid,ls[root]=++tot,ls[last],pre,nex,flag);elseupdate(mid+1,r,rs[root]=++tot,rs[last],pre,nex,flag);
}
int query(int l,int r,int root,int q)
{if(l==r)return root;int mid=l+r>>1;if(mid>=q)return query(l,mid,ls[root],q);elsereturn query(mid+1,r,rs[root],q);
}
int finds(int x,int root)
{int fax=query(1,n,root,x);if(fa[fax]!=x)return finds(fa[fax],root);return fax;
}
int main()
{scanf("%d%d",&n,&m);build(1,n,rt[0]);int cas,l,r;int last=0;for(int i=1;i<=m;i++){scanf("%d",&cas);if(cas==1){scanf("%d%d",&l,&r);l^=last,r^=last;rt[i]=rt[i-1];l=finds(l,rt[i-1]);r=finds(r,rt[i-1]);if(fa[l]==fa[r])continue;if(dep[r]<dep[l])swap(l,r);update(1,n,rt[i]=++tot,rt[i-1],fa[l],fa[r],0);if(dep[l]==dep[r]){int now=++tot;update(1,n,now,rt[i],fa[r],fa[r],1);rt[i]=now;}}else if(cas==2){int t;scanf("%d",&t);t^=last;rt[i]=rt[t];}else{scanf("%d%d",&l,&r);l^=last,r^=last;rt[i]=rt[i-1];l=finds(l,rt[i-1]);r=finds(r,rt[i-1]);if(fa[l]==fa[r])printf("1\n");elseprintf("0\n");last=fa[l]==fa[r];}}return 0;
}
这篇关于HYSBZ 3674: 可持久化并查集加强版——主席树+并查集的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!