本文主要是介绍1103 Integer Factorization (30 分) dfs 剪枝,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format:
N = n[1]^P + ... n[K]^P
where n[i]
(i
= 1, ..., K
) is the i
-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122+42+22+22+12, or 112+62+22+22+22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1,a2,⋯,aK } is said to be larger than { b1,b2,⋯,bK } if there exists 1≤L≤K such that ai=bi for i<L and aL>bL.
If there is no solution, simple output Impossible
.
Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
这道题题意很简单,给出s,n,k找一组数满足s=n个数的k次方之和
如果有多组数满足,则取底数之和最大的,且输出的时候底数从大到小输出。
深搜里记录:x-当前值,nown-当前共有n个数,nowsum-当前和
当nown==n&&nowsum==s时满足条件,比较sum和res_sum,如果更大,则替换结果res=v;
#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <queue>
#include <math.h>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
int s,n,k,res_sum;
vector<int> v,res;
void dfs(int x,int nown,int nowsum)
{if(x<=0||nown>n||nowsum>s)return;//printf("%d %d %d\n",x,nown,nowsum);if(nown==n&&nowsum==s){int sum=0;for(int i=0;i<v.size();i++)sum+=v[i];//printf("%d\n",sum);if(sum>res_sum){res_sum=sum;res=v;}return;}v.push_back(x);dfs(x,nown+1,nowsum+pow(x,k));v.pop_back();dfs(x-1,nown,nowsum);
}
int main()
{scanf("%d%d%d",&s,&n,&k);res_sum=-1;dfs(sqrt(s),0,0);if(res_sum!=-1){printf("%d = ",s);sort(res.begin(),res.end());for(int i=res.size()-1;i>0;i--)printf("%d^%d + ",res[i],k);printf("%d^%d\n",res[0],k);} elseprintf("Impossible\n");
}
这篇关于1103 Integer Factorization (30 分) dfs 剪枝的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!