本文主要是介绍POJ3522 Slim Span 解题报告【Kruskal求最小生成树+枚举】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Description
Given an undirected weighted graph G, you should find one of spanning trees specified as follows.
The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).
A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.
Figure 5: A graph G and the weights of the edges
For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).
Figure 6: Examples of the spanning trees of G
There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.
Your job is to write a program that computes the smallest slimness.
Input
The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.
n m
a1 b1 w1
⋮
am bm wm
Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).
Output
For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.
Sample Input
4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0
Sample Output
1
20
0
-1
-1
1
0
1686
50
解题报告
这道题的题意是叫我们求给出的图中的生成树中边权的最值之差的最小值。
我们先将邻接表排一次序,过后用 [low,m] (1<=low<=m)范围里的边构造最小生成树,更新最大值。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=100,M=5000,inf=0xffffff;
int n,m;
int father[N+5],rank[N+5];
bool flag,exist;
struct edge
{int u,v,w;
}ed[M+5];
bool cmp(edge a,edge b)
{return a.w<b.w;
}
int find(int a)
{return father[a]==a?a:father[a]=find(father[a]);
}
void Union(int a,int b)
{a=find(a),b=find(b);if(a==b)return ;if(rank[a]>rank[b])father[b]=a;else{father[a]=b;if(rank[a]==rank[b])rank[a]++;}
}
int kruskal(int low)
{int vmax=-1,vmin=inf,tot=0;for(int i=1;i<=n;i++)father[i]=i;memset(rank,0,sizeof(rank));for(int i=low;i<=m;i++){int u=ed[i].u,v=ed[i].v;if(find(u)!=find(v)){vmax=max(vmax,ed[i].w);vmin=min(vmin,ed[i].w);Union(u,v);++tot;}if(tot==n-1){flag=true;exist=true;break;}}return vmax-vmin;
}
int main()
{while(~scanf("%d%d",&n,&m)){exist=false;int ans=inf;if(n==0&&m==0)break;for(int i=1;i<=m;i++)scanf("%d%d%d",&ed[i].u,&ed[i].v,&ed[i].w);sort(ed+1,ed+1+m,cmp);for(int low=1;low<=m;low++){flag=false;int temp=kruskal(low);if(flag)ans=min(ans,temp);}if(!exist)printf("-1\n");else printf("%d\n",ans);}return 0;
}
这篇关于POJ3522 Slim Span 解题报告【Kruskal求最小生成树+枚举】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!