本文主要是介绍K - Treasure Exploration (最大路径覆盖),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
K - Treasure Exploration
Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?
Input
The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.
Output
For each test of the input, print a line containing the least robots needed.
Sample Input
1 0
2 1
1 2
2 0
0 0
Sample Output
1
1
2
思路:
由题 “explore all the points” 得 用路径覆盖 做。
与 最小路径覆盖 不同 ,这题是 最大路径覆盖。因为题中说 “You should notice that the roads of two different robots may contain some same point.”——(不同机器人的道路可能包含一些相同点),所以用 floyd 把间接相邻的点 连接起来。
代码:
#include<map>
#include<queue>
#include<math.h>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define MM 507
int line[MM][MM],book[MM],man[MM];
int n,m;
bool Find(int x)
{for(int i=1; i<=n; i++){if(line[x][i] && !book[i]){book[i]=1;if(!man[i] || Find(man[i])){man[i]=x;return true;}}}return false;
}
int match()
{int ans=0;for(int i=1; i<=n; i++){mem(book,0);if(Find(i))ans++;}return ans;
}
int main()
{while(~scanf("%d%d",&n,&m)&&(n||m)){mem(line,0);mem(man,0);int x,y;for(int i=1; i<=m; i++){scanf("%d%d",&x,&y);line[x][y]=1;}for(int i=1;i<=n;i++)for(int j=1;j<=n;j++)if(!line[i][j])for(int k=1;k<=n;k++)if(line[i][k]&&line[k][j])line[i][j]=1;printf("%d\n",n-match());}return 0;
}
这篇关于K - Treasure Exploration (最大路径覆盖)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!