本文主要是介绍poj 1753(位运算+BFS),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
开始看这题时,一点思路都没,上网搜了一下,看了很多,还是不太明白,今天早上起床,我突然领悟了,这题的关键在于转化成一个图:把把棋盘的每一个状态看做一个点,从一个状态如果一步可以得到另一个状态,那么这两个状态抽象成的点之间就有一条边相连,然后对其运用BFS或DFS就行了;
Flip Game
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 15158 | Accepted: 6512 |
Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Consider the following position as an example:
bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
- Choose any one of the 16 pieces.
- Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
Consider the following position as an example:
bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb bbwb bwwb bwww
Sample Output
4
#include<iostream>
using namespace std;int visited[65536]={0};
int quene[65536]={0};
int step[65536]={0};
int front=0, rear=1;int Flip(int state, int position)
{state ^=(1<<position);//(position+1)代表要翻转的棋子if(position-4>=0)//判断上方state ^=(1<<(position-4));if(position+4<=15)//判断下方state ^=(1<<(position+4));if(position%4>=1 )//判断左边state ^=(1<<(position-1));if(position%4<=2)//判断右边state ^=(1<<(position+1));return state;
}
int BFS(int state)
{int s;int i;quene[front]=state;visited[state]=1;while( front!=rear){s=quene[front];front++;for(i=0; i<16; i++){state=Flip(s, i);if( !visited[state] )//未方访问过,入队列{quene[rear]=state;visited[state]=1;step[state]=step[s]+1;if( state==0 || state==65535)return 1;rear++;}}}return 0;
}
int main()
{char map[17];//用一维数组保存int state=0;int i, j;for(i=0; i<16; i++)//黑为1白为0{cin>>map[i];if( map[i]=='b')state+=(1<<i);}if( state==0 || state==65535)//判断初始状态是否符合cout<<0<<endl;else{if( BFS(state))cout<<step[quene[rear]]<<endl;elsecout<<"Impossible"<<endl;}
}
这篇关于poj 1753(位运算+BFS)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!