05-树9 Huffman Codes (30分)

2024-03-06 09:38
文章标签 05 30 huffman codes

本文主要是介绍05-树9 Huffman Codes (30分),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

05-树9 Huffman Codes   (30分)

In 1953, David A. Huffman published his paper "A Method for the Construction of Minimum-Redundancy Codes", and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string "aaaxuaxz", we can observe that the frequencies of the characters 'a', 'x', 'u' and 'z' are 4, 2, 1 and 1, respectively. We may either encode the symbols as {'a'=0, 'x'=10, 'u'=110, 'z'=111}, or in another way as {'a'=1, 'x'=01, 'u'=001, 'z'=000}, both compress the string into 14 bits. Another set of code can be given as {'a'=0, 'x'=11, 'u'=100, 'z'=101}, but {'a'=0, 'x'=01, 'u'=011, 'z'=001} is NOT correct since "aaaxuaxz" and "aazuaxax" can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer NN (2N632N63), then followed by a line that contains all the NNdistinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where c[i] is a character chosen from {'0' - '9', 'a' - 'z', 'A' - 'Z', '_'}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer MM (10001000), then followed by MM student submissions. Each student submission consists of NN lines, each in the format:

c[i] code[i]

where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0's and '1's.

Output Specification:

For each test case, print in each line either "Yes" if the student's submission is correct, or "No" if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
No
No

主要思路:
1、通过小根堆构建Huffman树
2、通过Huffman树计算最小编码长度
3、判断输入的编码是否符合要求(1、编码长度与Huffman编码长度相同 2、前缀编码)

#include<iostream>
#include <string>
using namespace std;
#define MaxNum 64struct TreeNode//树的结点
{int Weight=0;TreeNode *Left=nullptr;TreeNode *Right=nullptr;
};struct HeapNode//堆
{TreeNode Data[MaxNum];int Size=0;
};HeapNode *CreateHeap(int N)//创建一个新的小根堆
{HeapNode *H=new(HeapNode);H->Data[0].Weight=-1;return H;
}TreeNode *DeleteMin(HeapNode *H)//从堆中删除一个结点
{int Parent=0,Child=0;TreeNode temp;TreeNode *MinItem=new(TreeNode);*MinItem=H->Data[1];temp=(H->Data[(H->Size)--]);for (Parent = 1; Parent*2 <= H->Size ; Parent=Child)//寻找删除结点前堆中最后一个结点在新堆中的插入位置{Child=Parent*2;if ((Child!=H->Size)&&((H->Data[Child].Weight)>(H->Data[Child+1].Weight))){Child++;}if ((temp.Weight)<=(H->Data[Child].Weight)){break;}else{H->Data[Parent]=H->Data[Child];}}H->Data[Parent]=temp;return MinItem;}void Insert(HeapNode *H,TreeNode *item)//插入新结点到堆中
{int i=0;i=++(H->Size);for (;H->Data[i/2].Weight>item->Weight; i/=2){H->Data[i]=H->Data[i/2];}H->Data[i]=*item;}HeapNode *ReadData(int N,HeapNode *H,int A[])//读取各个节点的权值输入数据
{char s='\0';int value=0;for (int i=0; i<N; ++i){cin>>s;cin>>value;A[i]=value;TreeNode *T=new(TreeNode);T->Weight=value;Insert(H, T);}return H;
}TreeNode *Huffman(HeapNode *H)//构建Huffman树
{TreeNode *T=nullptr;int num=H->Size;for (int i=0; i<num-1; ++i){T=new(TreeNode);T->Left=DeleteMin(H);T->Right=DeleteMin(H);T->Weight=T->Left->Weight+T->Right->Weight;Insert(H, T);}T=DeleteMin(H);return T;
}int WPL(TreeNode *T,int Depth)//计算Huffman树的编码长度
{if ((T->Left==nullptr)&&(T->Right==nullptr)){return Depth*(T->Weight);}else{return (WPL(T->Left,Depth+1)+WPL(T->Right,Depth+1));}
}
struct JNode
{int Flag=0;JNode *Left=nullptr;JNode *Right=nullptr;};
bool Judge(string S,JNode *J)//判断该次编码能否符合前缀编码的要求
{int i=0;for (; i<S.length(); ++i){if (S[i]=='0'){if (J->Left==nullptr){JNode *J_1=new(JNode);J->Left=J_1;}else{if (J->Left->Flag==1){return false;}}J=J->Left;}else{if (J->Right==nullptr){JNode *J_1=new(JNode);J->Right=J_1;}else{if (J->Right->Flag==1){return false;}}J=J->Right;}}J->Flag=1;if (J->Left==nullptr&&J->Right==nullptr){return true;}else{return false;}
}int main(int argc, char const *argv[])
{int N=0,n=0;cin>>N;HeapNode *H=CreateHeap(N);int Value[MaxNum]={};H=ReadData(N,H,Value);TreeNode *T=Huffman(H);int CodeLen=WPL(T,0);cin>>n;string temp="\0";char c='\0';bool result=false;for (int i=0; i<n; ++i){int count=0,flag=0;JNode *J=new(JNode);for (int k=0; k<N; ++k){cin>>c>>temp;count+=temp.length()*Value[k];if (!flag){result=Judge(temp,J);if (!result){flag=1;}}}delete J;if (result&&(count==CodeLen))//前缀编码且编码长度之和与Huffman编码相同{cout<<"Yes"<<endl;}else{cout<<"No"<<endl;}}return 0;
}

这篇关于05-树9 Huffman Codes (30分)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/779617

相关文章

TP-Link PDDNS服将于务6月30日正式停运:用户需转向第三方DDNS服务

《TP-LinkPDDNS服将于务6月30日正式停运:用户需转向第三方DDNS服务》近期,路由器制造巨头普联(TP-Link)在用户群体中引发了一系列重要变动,上个月,公司发出了一则通知,明确要求所... 路由器厂商普联(TP-Link)上个月发布公告要求所有用户必须完成实名认证后才能继续使用普联提供的 D

mysql-8.0.30压缩包版安装和配置MySQL环境过程

《mysql-8.0.30压缩包版安装和配置MySQL环境过程》该文章介绍了如何在Windows系统中下载、安装和配置MySQL数据库,包括下载地址、解压文件、创建和配置my.ini文件、设置环境变量... 目录压缩包安装配置下载配置环境变量下载和初始化总结压缩包安装配置下载下载地址:https://d

30常用 Maven 命令

Maven 是一个强大的项目管理和构建工具,它广泛用于 Java 项目的依赖管理、构建流程和插件集成。Maven 的命令行工具提供了大量的命令来帮助开发人员管理项目的生命周期、依赖和插件。以下是 常用 Maven 命令的使用场景及其详细解释。 1. mvn clean 使用场景:清理项目的生成目录,通常用于删除项目中自动生成的文件(如 target/ 目录)。共性规律:清理操作

2024网安周今日开幕,亚信安全亮相30城

2024年国家网络安全宣传周今天在广州拉开帷幕。今年网安周继续以“网络安全为人民,网络安全靠人民”为主题。2024年国家网络安全宣传周涵盖了1场开幕式、1场高峰论坛、5个重要活动、15场分论坛/座谈会/闭门会、6个主题日活动和网络安全“六进”活动。亚信安全出席2024年国家网络安全宣传周开幕式和主论坛,并将通过线下宣讲、创意科普、成果展示等多种形式,让广大民众看得懂、记得住安全知识,同时还

忽略某些文件 —— Git 学习笔记 05

忽略某些文件 忽略某些文件 通过.gitignore文件其他规则源如何选择规则源参考资料 对于某些文件,我们不希望把它们纳入 Git 的管理,也不希望它们总出现在未跟踪文件列表。通常它们都是些自动生成的文件,比如日志文件、编译过程中创建的临时文件等。 通过.gitignore文件 假设我们要忽略 lib.a 文件,那我们可以在 lib.a 所在目录下创建一个名为 .gi

c++习题30-求10000以内N的阶乘

目录 一,题目  二,思路 三,代码    一,题目  描述 求10000以内n的阶乘。 输入描述 只有一行输入,整数n(0≤n≤10000)。 输出描述 一行,即n!的值。 用例输入 1  4 用例输出 1  24   二,思路 n    n!           0    1 1    1*1=1 2    1*2=2 3    2*3=6 4

嵌入式面试经典30问:二

1. 嵌入式系统中,如何选择合适的微控制器或微处理器? 在嵌入式系统中选择合适的微控制器(MCU)或微处理器(MPU)时,需要考虑多个因素以确保所选组件能够满足项目的具体需求。以下是一些关键步骤和考虑因素: 1.1 确定项目需求 性能要求:根据项目的复杂度、处理速度和数据吞吐量等要求,确定所需的处理器性能。功耗:评估系统的功耗需求,选择低功耗的MCU或MPU以延长电池寿命或减少能源消耗。成本

C++入门(05-2)从命令行执行C++编译器_GCC

文章目录 GCC编译器1. 下载MinGW-w64,安装(不推荐)2. 使用MSYS2安装MinGW-w64(推荐)2.1 安装MSYS22.2 初始化和更新2.3 安装MinGW-w64编译器2.3 在MSYS2 Shell中导航到代码目录2.4 使用 g++ 编译2.5 运行可执行文件 GCC编译器 GCC(GNU Compiler Collection)是一个开源编译器集

【全网最全】2024年数学建模国赛A题30页完整建模文档+17页成品论文+保奖matla代码+可视化图表等(后续会更新)

您的点赞收藏是我继续更新的最大动力! 一定要点击如下的卡片,那是获取资料的入口! 【全网最全】2024年数学建模国赛A题30页完整建模文档+17页成品论文+保奖matla代码+可视化图表等(后续会更新)「首先来看看目前已有的资料,还会不断更新哦~一次购买,后续不会再被收费哦,保证是全网最全资源,随着后续内容更新,价格会上涨,越早购买,价格越低,让大家再也不需要到处买断片资料啦~💰💸👋」�

C++入门(05)从命令行执行C++编译器_MSVC

文章目录 1.C++ 编译器2. 常用 C++ 编译器MSVC(Microsoft Visual C++)GCC(GNU Compiler Collection)Clang 3. MSVC 编译器3.1 开发者命令提示符3.2 编译 C++ 代码 1.C++ 编译器 将C++源代码(扩展名为 .cpp )转换成计算机可以运行的可执行程序 编译器会检查代码的语法和语义,生成相应