本文主要是介绍(POJ3414)Pots BFS, 记录路径,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Pots
Description
You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:
FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.
Input
On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).
Output
The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.
Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)
Source
Northeastern Europe 2002, Western Subregion
题意:
有两个锅1和2,容量分别为A,B,开始时都是空的。你可以做以下操作:
装满1或2
倒空1或2
将1倒进2(可能有剩余),将2倒进1
问最少多少步,可以使1或2中的容量为C
分析:
是一道BFS的题,不过要记录路径,所有这样定义状态:
struct node
{
int id,pre;//编号,上一个状态的编号
int a,b,step;
int op;//由上一状态到达这一状态操作的种类
}nodes[10010];
然后找到结果后输出即可。
没有1AC,将drop1写错了,当时样例过了。。
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;int A,B,C;
struct node
{int id,pre;int a,b,step;int op;
}nodes[10010];bool v[110][110];
int ans[10010];void output(int x)
{int num=0;for(int i=nodes[x].id;i!=-1;i=nodes[i].pre){//cout<<nodes[i].a<<" "<<nodes[i].b<<nodes[i].op<<endl;ans[num++] = nodes[i].op;}num-=2;for(int i=num;i>=0;i--){if(ans[i]==1) printf("FILL(2)\n");else if(ans[i]==2) printf("FILL(1)\n");else if(ans[i]==3) printf("DROP(1)\n");else if(ans[i]==4) printf("DROP(2)\n");else if(ans[i]==5) printf("POUR(1,2)\n");else if(ans[i]==6) printf("POUR(2,1)\n");}
}int main()
{while(scanf("%d%d%d",&A,&B,&C)!=EOF){int num=0;bool f = false;node now;nodes[0].a=0; nodes[0].b=0; nodes[0].step=0;nodes[0].pre=-1; nodes[0].id=0; nodes[0].op=-1;num++;memset(v,0,sizeof(v));queue<node> q;while(!q.empty()) q.pop();v[0][0]=1;q.push(nodes[0]);while(!q.empty()){now = q.front(); q.pop();//cout<<now.a<<" "<<now.b<<" "<<now.step<<endl;if(now.a==C || now.b==C){f = true;printf("%d\n",now.step);output(now.id);break;}//full 2nodes[num].a = now.a; nodes[num].b = B;if(!v[nodes[num].a][nodes[num].b]){nodes[num].id = num;nodes[num].pre = now.id;nodes[num].step = now.step + 1;nodes[num].op = 1;q.push(nodes[num]);v[nodes[num].a][nodes[num].b]=1;num++;}//full 1nodes[num].a = A; nodes[num].b = now.b;if(!v[nodes[num].a][nodes[num].b]){nodes[num].id = num;nodes[num].pre = now.id;nodes[num].step = now.step + 1;nodes[num].op = 2;q.push(nodes[num]);v[nodes[num].a][nodes[num].b]=1;num++;}//drop 1nodes[num].a = 0; nodes[num].b = now.b;if(!v[nodes[num].a][nodes[num].b]){nodes[num].id = num;nodes[num].pre = now.id;nodes[num].step = now.step + 1;nodes[num].op = 3;q.push(nodes[num]);v[nodes[num].a][nodes[num].b]=1;num++;}//drop 2nodes[num].a = now.a; nodes[num].b = 0;if(!v[nodes[num].a][nodes[num].b]){nodes[num].id = num;nodes[num].pre = now.id;nodes[num].step = now.step + 1;nodes[num].op = 4;q.push(nodes[num]);v[nodes[num].a][nodes[num].b]=1;num++;}// pour 1 2int tmp = B - now.b;if(now.a <= tmp){nodes[num].a = 0;nodes[num].b = now.b + now.a;}else{nodes[num].b = B;nodes[num].a = now.a - tmp;}if(!v[nodes[num].a][nodes[num].b]){nodes[num].id = num;nodes[num].pre = now.id;nodes[num].step = now.step + 1;nodes[num].op = 5;q.push(nodes[num]);v[nodes[num].a][nodes[num].b]=1;num++;}//pour 2 1tmp = A - now.a;if(now.b <= tmp){nodes[num].b = 0;nodes[num].a = now.a + now.b;}else{nodes[num].a = A;nodes[num].b = now.b - tmp;}if(!v[nodes[num].a][nodes[num].b]){nodes[num].id = num;nodes[num].pre = now.id;nodes[num].step = now.step + 1;nodes[num].op = 6;q.push(nodes[num]);v[nodes[num].a][nodes[num].b]=1;num++;}}if(!f) printf("impossible\n");}return 0;
}
这篇关于(POJ3414)Pots BFS, 记录路径的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!