No Pain No Game HDU - 4630(gcd+线段树+离线处理)

2024-02-01 15:18

本文主要是介绍No Pain No Game HDU - 4630(gcd+线段树+离线处理),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Life is a game,and you lose it,so you suicide.
But you can not kill yourself before you solve this problem:
Given you a sequence of number a 1, a 2, …, a n.They are also a permutation of 1…n.
You need to answer some queries,each with the following format:
If we chose two number a,b (shouldn’t be the same) from interval [l, r],what is the maximum gcd(a, b)? If there’s no way to choose two distinct number(l=r) then the answer is zero.
Input
First line contains a number T(T <= 5),denote the number of test cases.
Then follow T test cases.
For each test cases,the first line contains a number n(1 <= n <= 50000).
The second line contains n number a 1, a 2, …, a n.
The third line contains a number Q(1 <= Q <= 50000) denoting the number of queries.
Then Q lines follows,each lines contains two integer l, r(1 <= l <= r <= n),denote a query.
Output
For each test cases,for each query print the answer in one line.
Sample Input
1
10
8 2 4 9 5 7 10 6 1 3
5
2 10
2 4
6 9
1 4
7 10
Sample Output
5
2
2
4
3
求区间任意两个数的最大gcd。做了几个gcd的题目,貌似都是离线处理的。
对于两个数的gcd,是因为这两个数都有相同的约数x,这样这两个数的gcd才有可能是x。这样我们用O(nsqrt n)的时间复杂度处理处所有的数约数。假如a[k]的一个约数是x,x上一次出现的位置是i。那么在i~k这一段的gcd有可能就会变成x。按着这个思路去更新,线段树去求gcd最大值。询问离线处理,当现在处理的位置恰好是某一次询问的右端点的话,就可以直接通过线段树求出最大值gcd来了。
代码如下:

#include<bits/stdc++.h>
#define ll long long
using namespace std;const int maxx=5e4+100;
struct node{int l;int r;int sum;
}p[maxx<<2];
struct Node{int l;int r;int id;bool operator<(const Node &a)const{return a.r>r;}
}b[maxx];
vector<int> g[maxx];
int a[maxx],ans[maxx];
int n,m;
/*------------预处理出所有数的约数-------------*/ 
inline void init()
{for(int i=1;i<=maxx;i++)for(int j=i;j<=maxx;j+=i)g[j].push_back(i);
}
/*---------------线段树----------------*/
inline void pushup(int cur)
{p[cur].sum=max(p[cur<<1].sum,p[cur<<1|1].sum);
}
inline void build(int l,int r,int cur)
{p[cur].l=l;p[cur].r=r;p[cur].sum=0;if(l==r) return ;int mid=l+r>>1;build(l,mid,cur<<1);build(mid+1,r,cur<<1|1);
}
inline void update(int pos,int v,int cur)
{int L=p[cur].l;int R=p[cur].r;if(L==R){p[cur].sum=max(p[cur].sum,v);return ;}int mid=L+R>>1;if(pos<=mid) update(pos,v,cur<<1);else update(pos,v,cur<<1|1);pushup(cur);
}
inline int query(int l,int r,int cur)
{int L=p[cur].l;int R=p[cur].r;if(l<=L&&R<=r) return p[cur].sum;int mid=L+R>>1;if(r<=mid) return query(l,r,cur<<1);else if(l>mid) return query(l,r,cur<<1|1);else return max(query(l,mid,cur<<1),query(mid+1,r,cur<<1|1));
}
int main()
{init();int t,x;scanf("%d",&t);while(t--){map<int,int> mpp;scanf("%d",&n);for(int i=1;i<=n;i++) scanf("%d",&a[i]);scanf("%d",&m);for(int i=1;i<=m;i++) scanf("%d%d",&b[i].l,&b[i].r),b[i].id=i;sort(b+1,b+1+m);build(1,n,1);for(int i=1,j=1;i<=m&&j<=n;j++){for(int k=0;k<g[a[j]].size();k++){x=g[a[j]][k];if(mpp[x]!=0) update(mpp[x],x,1);mpp[x]=j;}for(i;i<=m&&j==b[i].r;i++) ans[b[i].id]=query(b[i].l,b[i].r,1);}for(int i=1;i<=m;i++) printf("%d\n",ans[i]);}return 0;
}

努力加油a啊,(o)/~

这篇关于No Pain No Game HDU - 4630(gcd+线段树+离线处理)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/667648

相关文章

无人叉车3d激光slam多房间建图定位异常处理方案-墙体画线地图切分方案

墙体画线地图切分方案 针对问题:墙体两侧特征混淆误匹配,导致建图和定位偏差,表现为过门跳变、外月台走歪等 ·解决思路:预期的根治方案IGICP需要较长时间完成上线,先使用切分地图的工程化方案,即墙体两侧切分为不同地图,在某一侧只使用该侧地图进行定位 方案思路 切分原理:切分地图基于关键帧位置,而非点云。 理论基础:光照是直线的,一帧点云必定只能照射到墙的一侧,无法同时照到两侧实践考虑:关

poj3468(线段树成段更新模板题)

题意:包括两个操作:1、将[a.b]上的数字加上v;2、查询区间[a,b]上的和 下面的介绍是下解题思路: 首先介绍  lazy-tag思想:用一个变量记录每一个线段树节点的变化值,当这部分线段的一致性被破坏我们就将这个变化值传递给子区间,大大增加了线段树的效率。 比如现在需要对[a,b]区间值进行加c操作,那么就从根节点[1,n]开始调用update函数进行操作,如果刚好执行到一个子节点,

hdu1394(线段树点更新的应用)

题意:求一个序列经过一定的操作得到的序列的最小逆序数 这题会用到逆序数的一个性质,在0到n-1这些数字组成的乱序排列,将第一个数字A移到最后一位,得到的逆序数为res-a+(n-a-1) 知道上面的知识点后,可以用暴力来解 代码如下: #include<iostream>#include<algorithm>#include<cstring>#include<stack>#in

hdu1689(线段树成段更新)

两种操作:1、set区间[a,b]上数字为v;2、查询[ 1 , n ]上的sum 代码如下: #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<queue>#include<set>#include<map>#include<stdio.h>#include<stdl

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while