本文主要是介绍【HDU5569 BestCoder Round 63 (div1)B】【DP】matrix 向右走向下走最大乘积和,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
matrix
Accepts: 124
Submissions: 171
Time Limit: 6000/3000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
问题描述
给定n∗m(n+m为奇数)的矩阵,从(1,1)走到(n,m)且只能往右往下走,设经过的数为a1,a2...a2k,贡献为a1∗a2+a3∗a4+...+a2k−1∗a2k,求最小贡献。
输入描述
若干组数据(大概5组)。 每组数据第一行两个数n,m(1≤n,m≤1000且n+m为奇数)。 接下来n行每行m个数ai,j(1≤ai,j≤100)描述这个矩阵。
输出描述
对于每组数据,输出一行表示答案。
输入样例
2 3 1 2 3 2 2 1 2 3 2 2 1 1 2 4
输出样例
4 8
#include<stdio.h>
#include<string.h>
#include<ctype.h>
#include<math.h>
#include<iostream>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<bitset>
#include<algorithm>
#include<time.h>
using namespace std;
void fre(){freopen("c://test//input.in","r",stdin);freopen("c://test//output.out","w",stdout);}
#define MS(x,y) memset(x,y,sizeof(x))
#define MC(x,y) memcpy(x,y,sizeof(x))
#define MP(x,y) make_pair(x,y)
#define ls o<<1
#define rs o<<1|1
typedef long long LL;
typedef unsigned long long UL;
typedef unsigned int UI;
template <class T1,class T2>inline void gmax(T1 &a,T2 b){if(b>a)a=b;}
template <class T1,class T2>inline void gmin(T1 &a,T2 b){if(b<a)a=b;}
const int N=1005,M=0,Z=1e9+7,ms63=1061109567;
int casenum,casei;
int n,m;
int a[N][N];
int f[N][N];
int main()
{while(~scanf("%d%d",&n,&m)){for(int i=1;i<=n;i++){for(int j=1;j<=m;j++)scanf("%d",&a[i][j]);}MS(f,63);f[1][1]=0;for(int i=1;i<=n;i++){for(int j=1;j<=m;j++){if((i+j)&1){gmin(f[i][j],min(f[i-1][j]+a[i-1][j]*a[i][j],f[i][j-1]+a[i][j-1]*a[i][j]));}else gmin(f[i][j],min(f[i-1][j],f[i][j-1]));}}printf("%d\n",f[n][m]);}return 0;
}
/*
【trick&&吐槽】
一开始我只考虑偶点,然后需要走两步,会加不少特判。
后来同时考虑偶点和奇点,速度就能大大提高了哦。【题意】
给你一个n(1000)*m(1000)的矩阵,且n+m为奇数。
我们要从(1,1)走到(n,m),每次只能向右走或者向下走。
这样对于每条路线,都会恰好走过n+m-1个数,恰好是偶数个。
让你求a[1]*a[2]+a[3]*a[4]+...+...的和,并使得这个和尽可能大,并输出。【类型】
DP【分析】
这道题,我们定义i+j为偶数的点叫做偶点,i+j为奇数的点叫做奇点。
那么,我们对于每个偶点,和它配对的奇点是上或者左,积累当步贡献,并从上一步积累最大值。
我们对于每个奇点,则只需要从上一步积累一个最大值即可。【时间复杂度&&优化】
O(nm)*/
这篇关于【HDU5569 BestCoder Round 63 (div1)B】【DP】matrix 向右走向下走最大乘积和的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!