本文主要是介绍浙大数据结构:拯救007,06-图2 Saving James Bond - Easy Version (25 分),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
06-图2 Saving James Bond - Easy Version (25 分)
This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).
Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.
Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.
Sample Input 1:
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:
Yes
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
No
代码
#include<iostream>
#include<math.h>
#define Maxsize 100
#define Rcenter 7.5
using namespace std;
struct Point {int x;int y;int vst;
}Points[Maxsize];
typedef Point* PtrToPoint;
typedef PtrToPoint PointArr;void GetData(PointArr P_Arr,int N){for (int i = 0; i < N; i++) {cin >> P_Arr[i].x >> P_Arr[i].y;P_Arr[i].vst = 0;}
}
int IsSave(const Point& P1, int D) {int x = P1.x;int y = P1.y;int res = (x + D >= 50 || x - D <= -50 || y + D >= 50 || y - D <= -50);return res;
}int FirstJump(Point& P,double r_center, int D) {int x = P.x;int y = P.y;double dist = sqrt(x*x + y*y);return dist <= (r_center + D) ? 1 : 0;
}int Jump(Point& P1, Point& P2, int D) {int dx = P1.x- P2.x;int dy = P1.y- P2.y;double res = sqrt(dx*dx + dy*dy);return res <= D ? 1 : 0;
}int DFS(PointArr P_Arr,Point& P, int N, int D) {/*在P_Arr的所有点中,从P点开始跳,P_Arr的size为N,跳跃距离为D*/int res = 0;if (P.vst == 0) {P.vst = 1;if (IsSave(P, D) == 1) {res = 1;return res;//如果当前节点就是安全的,那么就直接返回安全}}for (int i = 0; i < N; i++) {if(P_Arr[i].vst!=1&&Jump(P,P_Arr[i],D)==1){res=DFS(P_Arr, P_Arr[i], N, D);if (res == 1)break;}}return res;
}void Save007(PointArr P_Arr,int N,int D) {int res = 0;for (int i = 0; i < N; i++) {if (P_Arr[i].vst != 1 && FirstJump(P_Arr[i], Rcenter, D)) {/*从中心开始遍历所有点,如果这个点没有被访问过,而且第一跳可以跳上去,就对这个点做DFS*/res = DFS(P_Arr,P_Arr[i], N, D);if (res == 1)break;}}if (res == 1)cout << "Yes";if (res == 0)cout << "No";}int main() {int N, D;cin >> N >> D;GetData(Points, N);Save007(Points, N, D);return 0;
}
测试结果
这篇关于浙大数据结构:拯救007,06-图2 Saving James Bond - Easy Version (25 分)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!