poj-1155 TELE (树形分组背包)

2024-01-08 14:08
文章标签 分组 背包 poj 树形 tele 1155

本文主要是介绍poj-1155 TELE (树形分组背包),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目:

A TV-network plans to broadcast an important football match. Their network of transmitters and users can be represented as a tree. The root of the tree is a transmitter that emits the football match, the leaves of the tree are the potential users and other vertices in the tree are relays (transmitters). 
The price of transmission of a signal from one transmitter to another or to the user is given. A price of the entire broadcast is the sum of prices of all individual signal transmissions. 
Every user is ready to pay a certain amount of money to watch the match and the TV-network then decides whether or not to provide the user with the signal. 
Write a program that will find the maximal number of users able to watch the match so that the TV-network's doesn't lose money from broadcasting the match.

Input

The first line of the input file contains two integers N and M, 2 <= N <= 3000, 1 <= M <= N-1, the number of vertices in the tree and the number of potential users. 
The root of the tree is marked with the number 1, while other transmitters are numbered 2 to N-M and potential users are numbered N-M+1 to N. 
The following N-M lines contain data about the transmitters in the following form: 
K A1 C1 A2 C2 ... AK CK 
Means that a transmitter transmits the signal to K transmitters or users, every one of them described by the pair of numbers A and C, the transmitter or user's number and the cost of transmitting the signal to them. 
The last line contains the data about users, containing M integers representing respectively the price every one of them is willing to pay to watch the match.

Output

The first and the only line of the output file should contain the maximal number of users described in the above text.

Sample Input
9 6
3 2 2 3 2 9 3
2 4 2 5 2
3 6 2 7 2 8 2
4 3 3 3 1 1
Sample Output
5

题目大意:

一个广播电视台打算广播球赛,这个广播的连接关系是一个树关系,根节点是一电视台,叶子节点是客户,其余节点是中转站,电视台也算是中转站,每一个中转站都连接着一些其他中转站或者叶子,连接的路线有一个权值,代表通过这条道路的花费。而每一个叶子节点,也就是客户,有会对于转播的节目有一定数额的付款。问电视台在不亏损的情况下,最多能够让多少个客户看到球赛。

 

解题思路:

我们定义dp[u][j]是以u为结点,子树中支持j个客户的最大收益,(这个收益可以是一个负数)。

如果该结点是叶子节点,dp[u][1] = val[u];

如果该结点是中转站,dp[u][j] = dp[u][j-k]+dp[v][k]-Weight_u_v.    

其中u,代表目前结点编号,v代表儿子结点的编号,j和k都代表客户个数。

 

通过对每个中转站做背包,就能得到每个节点支持j个客户的最大收益。

最后再遍历dp[1][i],找到最大的i满足dp[1][i]>=0就可以了

 

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<map>
#include<queue>using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 3005;struct Edge
{int to,nxt;int w;
} edges[maxn<<2];
int head[maxn<<2];
int tot;void addEdge(int u, int v, long long w)
{edges[tot] = Edge{v,head[u],w};head[u] = tot++;
}int dp[maxn][maxn]; //第u个结点,有k个子结点的最大收益。
int sum[maxn];
int val[maxn];
int n, m;void dfs(int u, int fa)
{if(u>n-m){sum[u] = 1;dp[u][1] = val[u];return ;}for(int i = head[u]; ~i; i = edges[i].nxt){int v = edges[i].to;int w = edges[i].w;if(v == fa)continue;dfs(v,u);sum[u]+=sum[v];for(int j = sum[u]; j >= 0; j--){for(int k = 1; k <= sum[v]; k++){if(j-k>=0)dp[u][j] = max(dp[u][j],dp[u][j-k]+dp[v][k]-w);}}}
}int main()
{int k, a;int c;scanf("%d%d", &n, &m);tot = 1;memset(head,-1,sizeof(head));memset(dp,-inf,sizeof(dp));
//    cout << dp[1][1]<<endl;for(int i = 1; i <= n-m; i++){scanf("%d", &k);for(int j = 1; j <= k; j++){scanf("%d%d", &a, &c);addEdge(i,a,c);}dp[i][0] = 0;}for(int i = n-m+1; i <= n; i++){scanf("%d", &val[i]);dp[i][0] = 0;}dfs(1,-1);for(int i = sum[1]; i >=0; i--){if(dp[1][i]>=0){printf("%d\n", i);break;}}return 0;
}

 

 

 

这篇关于poj-1155 TELE (树形分组背包)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/583709

相关文章

【前端学习】AntV G6-08 深入图形与图形分组、自定义节点、节点动画(下)

【课程链接】 AntV G6:深入图形与图形分组、自定义节点、节点动画(下)_哔哩哔哩_bilibili 本章十吾老师讲解了一个复杂的自定义节点中,应该怎样去计算和绘制图形,如何给一个图形制作不间断的动画,以及在鼠标事件之后产生动画。(有点难,需要好好理解) <!DOCTYPE html><html><head><meta charset="UTF-8"><title>06

poj2576(二维背包)

题意:n个人分成两组,两组人数只差小于1 , 并且体重只差最小 对于人数要求恰好装满,对于体重要求尽量多,一开始没做出来,看了下解题,按照自己的感觉写,然后a了 状态转移方程:dp[i][j] = max(dp[i][j],dp[i-1][j-c[k]]+c[k]);其中i表示人数,j表示背包容量,k表示输入的体重的 代码如下: #include<iostream>#include<

hdu2159(二维背包)

这是我的第一道二维背包题,没想到自己一下子就A了,但是代码写的比较乱,下面的代码是我有重新修改的 状态转移:dp[i][j] = max(dp[i][j], dp[i-1][j-c[z]]+v[z]); 其中dp[i][j]表示,打了i个怪物,消耗j的耐力值,所得到的最大经验值 代码如下: #include<iostream>#include<algorithm>#include<

csu(背包的变形题)

题目链接 这是一道背包的变形题目。好题呀 题意:给n个怪物,m个人,每个人的魔法消耗和魔法伤害不同,求打死所有怪物所需的魔法 #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<queue>#include<set>//#include<u>#include<map

hdu1011(背包树形DP)

没有完全理解这题, m个人,攻打一个map,map的入口是1,在攻打某个结点之前要先攻打其他一个结点 dp[i][j]表示m个人攻打以第i个结点为根节点的子树得到的最优解 状态转移dp[i][ j ] = max(dp[i][j], dp[i][k]+dp[t][j-k]),其中t是i结点的子节点 代码如下: #include<iostream>#include<algorithm

hdu1171(母函数或多重背包)

题意:把物品分成两份,使得价值最接近 可以用背包,或者是母函数来解,母函数(1 + x^v+x^2v+.....+x^num*v)(1 + x^v+x^2v+.....+x^num*v)(1 + x^v+x^2v+.....+x^num*v) 其中指数为价值,每一项的数目为(该物品数+1)个 代码如下: #include<iostream>#include<algorithm>

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int