@2017-2018 ACM-ICPC, Asia Daejeon Regional Contest H; How Many to Be Happy? ( 最小割 dinic算法)

本文主要是介绍@2017-2018 ACM-ICPC, Asia Daejeon Regional Contest H; How Many to Be Happy? ( 最小割 dinic算法),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

O(n^2*m) 时间限制: 1 Sec  内存限制: 128 MB
提交: 80  解决: 32
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Let G be a connected simple undirected graph where each edge has an associated weight. Let’s consider the popular MST (Minimum Spanning Tree) problem. Today, we will see, for each edge e, how much modification on G is needed to make e part of an MST for G. For an edge e in G, there may already exist an MST for G that includes e. In that case, we say that e is happy in G and we define H(e) to be 0. However, it may happen that there is no MST for G that includes e. In such a case, we say that e is unhappy in G. We may remove a few of the edges in G to make a connected graph G′ in which e is happy. We define H(e) to be the minimum number of edges to remove from G such that e is happy in the resulting graph G′.

Figure E.1. A complete graph with 3 nodes.

Consider the graph in Figure E.1. There are 3 nodes and 3 edges connecting the nodes. One can easily see that the MST for this graph includes the 2 edges with weights 1 and 2, so the 2 edges are happy in the graph. How to make the edge with weight 3 happy? It is obvious that one can remove any one of the two happy edges to achieve that.
Given a connected simple undirected graph G, your task is to compute H(e) for each edge e in G and print the total sum.

 

输入

Your program is to read from standard input. The first line contains two positive integers n and m, respectively, representing the numbers of vertices and edges of the input graph, where n ≤ 100 and m ≤ 500. It is assumed that the graph G has n vertices that are indexed from 1 to n. It is followed by m lines, each contains 3 positive integers u, v, and w that represent an edge of the input graph between vertex u and vertex v with weight w. The weights are given as integers between 1 and 500, inclusive.

 

输出

Your program is to write to standard output. The only line should contain an integer S, which is the sum of H(e) where e ranges over all edges in G.

 

样例输入

3 3
1 2 1
3 1 2
3 2 3

 

样例输出

1

 

来源/分类

ICPC 2017 Daejeon 

 

题意:

N个点 M个边的无向图.  边权 不相同.,

求  成为最小生成树的每条边,   最少需要删去边的数量之和.

也就是说,  对每条边跑最小割. 

Dinc 复杂度O(n^2*m)   加上 每条边  ,  复杂度为: O(n^2*m^2)

 

 

[代码]

#include <bits/stdc++.h>
#include <stdio.h>
#define rep(i,a,n) for(int i=a;i<=n;i++)
#define per(i,a,n) for(int i=n;i>=a;i--)
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;
const int maxn = 1e5+10;
const int mod =1e9+7;
const int inf = 0x3f3f3f3f;
const int INF = 0x3f3f3f3f;
using namespace std;
int n,m;struct node{int v,w,next; //u  v 从 u-v 权值为w
}edge[maxn];
struct Nn
{int u,v,w;
}a[maxn];
int head[maxn],num[maxn],start,END,cnt,sum;
void init()
{cnt=0;memset(head,-1,sizeof(head));memset(edge,0,sizeof(edge));
}void add(int u,int v,int w)
{edge[cnt].v=v;edge[cnt].w=w;edge[cnt].next=head[u];head[u]=cnt++;edge[cnt].v=u;edge[cnt].w=w;edge[cnt].next=head[v];head[v]=cnt++;
}
int bfs()
{queue<int>Q;mem(num,0);num[start]=1;Q.push(start);while(!Q.empty()){int t=Q.front();Q.pop();if(t==END)return 1;for(int i=head[t];i!=-1;i=edge[i].next)// 链式前向星访问找增广路{int t1= edge[i].v;//下一个节点int t2= edge[i].w;// 当前点 权值if(t2&&num[t1]==0)// 当前点存在 并且下一个点没有访问{num[t1]=num[t]+1;// 点=1if(t1==END)//  结束return 1;Q.push(t1);}}}return 0;
}
int dfs(int u,int maxflow)
{if(u==END)return maxflow;int res=0;for(int i=head[u];i!=-1;i=edge[i].next){int t1=edge[i].v;// 下一个节点int t2=edge[i].w;// 当前节点if(t2&&num[t1]==num[u]+1){int temp=dfs(t1,min(maxflow-res,t2));// 选择流 小的一部分edge[i].w-=temp;// 正向减少edge[i^1].w+=temp;//反向增加res+=temp;if(res==maxflow)return res;}}if(!res)num[u]=-1;return res;
}
ll Dinic()
{ll ans=0;while(bfs()){ans+=dfs(start,INF);}return ans;
}int cmp(Nn a,Nn b)
{return a.w < b.w;
}
ll solve(int x)
{init();rep(i,1,m){if( a[i].w < a[x].w){add(a[i].u,a[i].v,1);}}start = a[x].u,END = a[x].v;return Dinic();
}
int main(int argc, char const *argv[])
{scanf("%d %d",&n,&m);rep(i,1,m){scanf("%d %d %d",&a[i].u,&a[i].v,&a[i].w);}sort(a+1,a+m+1,cmp);ll ans  = 0 ;rep(i,1,m)ans += solve(i);printf("%lld\n",ans );return 0;
}

 

这篇关于@2017-2018 ACM-ICPC, Asia Daejeon Regional Contest H; How Many to Be Happy? ( 最小割 dinic算法)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/565761

相关文章

SpringBoot实现MD5加盐算法的示例代码

《SpringBoot实现MD5加盐算法的示例代码》加盐算法是一种用于增强密码安全性的技术,本文主要介绍了SpringBoot实现MD5加盐算法的示例代码,文中通过示例代码介绍的非常详细,对大家的学习... 目录一、什么是加盐算法二、如何实现加盐算法2.1 加盐算法代码实现2.2 注册页面中进行密码加盐2.

Java时间轮调度算法的代码实现

《Java时间轮调度算法的代码实现》时间轮是一种高效的定时调度算法,主要用于管理延时任务或周期性任务,它通过一个环形数组(时间轮)和指针来实现,将大量定时任务分摊到固定的时间槽中,极大地降低了时间复杂... 目录1、简述2、时间轮的原理3. 时间轮的实现步骤3.1 定义时间槽3.2 定义时间轮3.3 使用时

如何通过Golang的container/list实现LRU缓存算法

《如何通过Golang的container/list实现LRU缓存算法》文章介绍了Go语言中container/list包实现的双向链表,并探讨了如何使用链表实现LRU缓存,LRU缓存通过维护一个双向... 目录力扣:146. LRU 缓存主要结构 List 和 Element常用方法1. 初始化链表2.

golang字符串匹配算法解读

《golang字符串匹配算法解读》文章介绍了字符串匹配算法的原理,特别是Knuth-Morris-Pratt(KMP)算法,该算法通过构建模式串的前缀表来减少匹配时的不必要的字符比较,从而提高效率,在... 目录简介KMP实现代码总结简介字符串匹配算法主要用于在一个较长的文本串中查找一个较短的字符串(称为

通俗易懂的Java常见限流算法具体实现

《通俗易懂的Java常见限流算法具体实现》:本文主要介绍Java常见限流算法具体实现的相关资料,包括漏桶算法、令牌桶算法、Nginx限流和Redis+Lua限流的实现原理和具体步骤,并比较了它们的... 目录一、漏桶算法1.漏桶算法的思想和原理2.具体实现二、令牌桶算法1.令牌桶算法流程:2.具体实现2.1

Python中的随机森林算法与实战

《Python中的随机森林算法与实战》本文详细介绍了随机森林算法,包括其原理、实现步骤、分类和回归案例,并讨论了其优点和缺点,通过面向对象编程实现了一个简单的随机森林模型,并应用于鸢尾花分类和波士顿房... 目录1、随机森林算法概述2、随机森林的原理3、实现步骤4、分类案例:使用随机森林预测鸢尾花品种4.1

不懂推荐算法也能设计推荐系统

本文以商业化应用推荐为例,告诉我们不懂推荐算法的产品,也能从产品侧出发, 设计出一款不错的推荐系统。 相信很多新手产品,看到算法二字,多是懵圈的。 什么排序算法、最短路径等都是相对传统的算法(注:传统是指科班出身的产品都会接触过)。但对于推荐算法,多数产品对着网上搜到的资源,都会无从下手。特别当某些推荐算法 和 “AI”扯上关系后,更是加大了理解的难度。 但,不了解推荐算法,就无法做推荐系

康拓展开(hash算法中会用到)

康拓展开是一个全排列到一个自然数的双射(也就是某个全排列与某个自然数一一对应) 公式: X=a[n]*(n-1)!+a[n-1]*(n-2)!+...+a[i]*(i-1)!+...+a[1]*0! 其中,a[i]为整数,并且0<=a[i]<i,1<=i<=n。(a[i]在不同应用中的含义不同); 典型应用: 计算当前排列在所有由小到大全排列中的顺序,也就是说求当前排列是第

认识、理解、分类——acm之搜索

普通搜索方法有两种:1、广度优先搜索;2、深度优先搜索; 更多搜索方法: 3、双向广度优先搜索; 4、启发式搜索(包括A*算法等); 搜索通常会用到的知识点:状态压缩(位压缩,利用hash思想压缩)。

csu 1446 Problem J Modified LCS (扩展欧几里得算法的简单应用)

这是一道扩展欧几里得算法的简单应用题,这题是在湖南多校训练赛中队友ac的一道题,在比赛之后请教了队友,然后自己把它a掉 这也是自己独自做扩展欧几里得算法的题目 题意:把题意转变下就变成了:求d1*x - d2*y = f2 - f1的解,很明显用exgcd来解 下面介绍一下exgcd的一些知识点:求ax + by = c的解 一、首先求ax + by = gcd(a,b)的解 这个