LA4670 Dominating Patterns[AC自动机]

2024-01-01 08:08

本文主要是介绍LA4670 Dominating Patterns[AC自动机],希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

The archaeologists are going to decipher a very mysterious “language”. Now, they know many language patterns; each pattern can be treated as a string on English letters (only lower case). As a sub string,these patterns may appear more than one times in a large text string (also only lower case English letters).
What matters most is that which patterns are the dominating patterns. Dominating pattern is the pattern whose appearing times is not less than other patterns.
It is your job to find the dominating pattern(s) and their appearing times.
Input
The entire input contains multi cases. The first line of each case is an integer, which is the number of patterns N, 1 ≤ N ≤ 150. Each of the following N lines contains one pattern, whose length is in range[1, 70]. The rest of the case is one line contains a large string as the text to lookup, whose length is up to 1E6
.
At the end of the input file, number ‘0’ indicates the end of input file.
Output
For each of the input cases, output the appearing times of the dominating pattern(s). If there are more than one dominating pattern, output them in separate lines; and keep their input order to the output.
Sample Input
2
aba
bab
ababababac
6
beta
alpha
haha
delta
dede
tata
dedeltalphahahahototatalpha
0
Sample Output
4
aba
2
alpha
haha

题意:对于给定的字典和句子,输出出现次数最多的单词的出现次数并且按输入顺序顺出在句子中出现次数最多的单词。
分析:就是AC加上离散一下(是离散?不清楚,汝佳用的map,某大神用的hash,我就直接存下来了每次输入的所有单词并且存下来了这个单词对应的叶子节点,到时候直接访问对比tot,两次分开的n的循环就可以了。这里的重复出现的单词我个人认为就用出现的顺序来区分很方便,因为在tot上覆盖就覆盖啊,反正最后得到的tot两个相同的单词都一样的……
第一次完全脱离模板写AC,还有一点不熟练,把有的细节忘了写了,要多熟练一下。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define clr(x) memset(x,0,sizeof(x))
using namespace std;
const int maxn=150*70+5;
char s[155][75],ov[1000005];
int n,ch[maxn][30],len,inde,sig[maxn],last[maxn],mapy[155],ans,tot[maxn],nxt[maxn];
int calc(char c)
{return c-'a';
}
void insert(int cur)
{len=strlen(s[cur]);int u=0;for(int i=0;i<len;i++){if(!ch[u][calc(s[cur][i])])ch[u][calc(s[cur][i])]=++inde;u=ch[u][calc(s[cur][i])];}sig[u]++;mapy[cur]=u;
}
void getfail()
{queue<int>q;nxt[0]=0;for(int i=0;i<26;i++)if(ch[0][i])//0不处理...因为好像本来跑回0也没有问题?q.push(ch[0][i]);while(!q.empty()){int cur=q.front();q.pop();for(int i=0;i<26;i++)if(ch[cur][i]){int u=ch[cur][i];q.push(u);int j=nxt[cur];while(j&&!ch[j][i])j=nxt[j];nxt[u]=ch[j][i];last[u]=sig[nxt[u]]?nxt[u]:last[nxt[u]];}else ch[cur][i]=ch[nxt[cur]][i];}
}
void init()
{clr(ch);clr(nxt);clr(last);clr(tot);inde=0;ans=0;for(int i=1;i<=n;i++){scanf("%s",s[i]);insert(i);}scanf("%s",ov);getfail();
}
void print(int j)
{if(j){tot[j]++;print(last[j]);}
}
void mat()
{int j=0;len=strlen(ov);for(int i=0;i<len;i++){j=ch[j][calc(ov[i])];if(sig[j])print(j);else print(last[j]);}for(int i=1;i<=n;i++)ans=max(ans,tot[mapy[i]]);printf("%d\n",ans);for(int i=1;i<=n;i++)if(tot[mapy[i]]==ans)printf("%s\n",s[i]);
}
int main()
{freopen("LA4670.in","r",stdin);freopen("LA4670.out","w",stdout);scanf("%d",&n);//for(scanf("%d",&n);n;scanf("%d",&n))while(n){init();mat();scanf("%d",&n);}return 0;
}

这篇关于LA4670 Dominating Patterns[AC自动机]的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/558617

相关文章

hdu 3065 AC自动机 匹配串编号以及出现次数

题意: 仍旧是天朝语题。 Input 第一行,一个整数N(1<=N<=1000),表示病毒特征码的个数。 接下来N行,每行表示一个病毒特征码,特征码字符串长度在1—50之间,并且只包含“英文大写字符”。任意两个病毒特征码,不会完全相同。 在这之后一行,表示“万恶之源”网站源码,源码字符串长度在2000000之内。字符串中字符都是ASCII码可见字符(不包括回车)。

POJ 1625 自动机

给出包含n个可见字符的字符集,以下所提字符串均由该字符集中的字符构成。给出p个长度不超过10的字符串,求长为m且不包含上述p个字符串的字符串有多少个。 g++提交 int mat[108][108] ;int matn ;int N ;map<char ,int> to ;//ACconst int maxm = 108 ;const int kin

zoj 3228 ac自动机

给出一个字符串和若干个单词,问这些单词在字符串里面出现了多少次。单词前面为0表示这个单词可重叠出现,1为不可重叠出现。 Sample Input ab 2 0 ab 1 ab abababac 2 0 aba 1 aba abcdefghijklmnopqrstuvwxyz 3 0 abc 1 def 1 jmn Sample Output Case 1 1 1 Case 2

D4代码AC集

贪心问题解决的步骤: (局部贪心能导致全局贪心)    1.确定贪心策略    2.验证贪心策略是否正确 排队接水 #include<bits/stdc++.h>using namespace std;int main(){int w,n,a[32000];cin>>w>>n;for(int i=1;i<=n;i++){cin>>a[i];}sort(a+1,a+n+1);int i=1

正规式与有限自动机例题

答案:D 知识点: 正规式 正规集 举例 ab 字符串ab构成的集合 {ab} a|b 字符串a,b构成的集合 {a,b} a^* 由0或者多个a构成的字符串集合 {空,a,aa,aaa,aaaa····} (a|b)^* 所有字符a和b构成的串的集合 {空,a,b,ab,aab,aba,aaab····} a(a|b)^* 以a为首字符的a,b字符串的集

HDU 3037 今年暑假不AC

题目: http://acm.hdu.edu.cn/showproblem.php?pid=2037 题解: 对结束时间排序,然后进行一次遍历,寻找开始时间不小于上一个结束时间的节目。 代码: #include<stdio.h>#include<iostream>using namespace std;struct program{int start,end;}p[101

基于 AC 驱动的电容结构 GaN LED 模型开发和应用

随着芯片尺寸减小,微小尺寸GaN 基 Micro LED 显示面临着显示与驱动高密度集成的难题,传统直流(DC)驱动技术会导致结温上升,降低器件寿命。南京大学团队创新提出交流(AC)驱动的单电极 LED(SC-LED)结构【见图1】,利用隧穿结(TJ)降低器件的交流工作电压。为了深入理解该器件的工作原理,我司技术团队开发了基于 AC 驱动的物理解析模型,揭示了隧穿结降低器件工作电压的

c++ error: redefinition of ‘struct ac::bd’ struct ac::bd:fg

#include <iostream> #include <stdio.h> class ac {     public:         class bd; }; class ac::bd {     public:         struct fg; }; struct ac::bd:fg {     int a = 1; }; int main() {     return 0;

AC自动机 - 多模式串的匹配运用 --- HDU 3065

病毒侵袭持续中  Problem's Link:http://acm.hdu.edu.cn/showproblem.php?pid=3065   Mean:  略 analyse:  AC自动机的运用. 这一题需要将模式串都存储下来,还有就是base的取值一定要弄清楚,由于这题的模式串都是大写字母所以我们可以通过剪枝来加速。 Time complexity:o(n)+o(m

AC自动机 - 多模式串的匹配运用 --- HDU 2896

病毒侵袭 Problem's Link:http://acm.hdu.edu.cn/showproblem.php?pid=2896   Mean:   略 analyse: AC自动机的运用,多模式串匹配。就是有几个细节要注意,在这些细节上卡了半天了。 1)输出的网站编号和最终的病毒网站数不是一样的; 2)next指针要设128,不然会爆栈; 3)同理,char转换为i