本文主要是介绍HDU 1556 Color the ball(树状数组,基础,气球染色问题),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
http://acm.split.hdu.edu.cn/showproblem.php?pid=1556
Color the ball
Problem Description
Input
当N = 0,输入结束。
Output
Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
Sample Output
1 1 1 3 2 1
题意:
看得懂就行。
思路:
最初采用的是向上更新,向下统计的方法(宇神讲的方法)。----Code 1
树状数组中的每个节点都代表了一段线段区间,
每次更新,根据其特性可以把 a 以前包含的区间找出来,然后把 a 以前的区间全部加一次染色次数;
再把 b 以前的区间全部减一次染色次数,这样就修改了树状数组中的[a,b]的区间染色次数。
后来就试试向下更新,向上统计的代码。-----Code 2
Code 1:(时间较快)
655MS 1808K
#include<stdio.h>
#include<cstring>
const int MYDD=1103+1e5;int Balloon[MYDD];
int LowBit(int x) {return (-x)&x;
}void UpDate(int node,int value,int n) {while(node<=n) {//向上进行节点的更新 Balloon[node]+=value;node+=LowBit(node);}
}int GetSum(int node) {int ans=0;//向下统计 while(node>0) { ans+=Balloon[node];node-=LowBit(node);}return ans;
}int main() {int N;while(1) {scanf("%d",&N);if(!N) break;memset(Balloon,0,sizeof(Balloon));for(int j=0; j<N; j++) {int a,b;scanf("%d%d",&a,&b);UpDate(a,1,N); // a以下区间加 +1 UpDate(b+1,-1,N);// b 以下区间 -1 }for(int j=1; j<N; j++)printf("%d ",GetSum(j));printf("%d\n",GetSum(N));}return 0;
}
Code 2:
702MS 1812K
#include<stdio.h>
#include<cstring>
const int MYDD=1103+1e5;int Balloon[MYDD];
int LowBit(int x) {return (-x)&x;
}void UpDate(int node,int value) {while(node>0) {//向下进行节点的更新 Balloon[node]+=value;node-=LowBit(node);}
}int GetSum(int node,int n) {int ans=0;//向上统计 while(node<=n) { ans+=Balloon[node];node+=LowBit(node);}return ans;
}int main() {int N;while(1) {scanf("%d",&N);if(!N) break;memset(Balloon,0,sizeof(Balloon));for(int j=0; j<N; j++) {int a,b;scanf("%d%d",&a,&b);UpDate(a-1,-1); // a 以下区间 -1UpDate(b,1); // b以下区间加 +1}for(int j=1; j<N; j++)printf("%d ",GetSum(j,N));printf("%d\n",GetSum(N,N));}return 0;
}
这篇关于HDU 1556 Color the ball(树状数组,基础,气球染色问题)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!