HLG 1159 MAGI System

2023-12-12 10:50
文章标签 system 1159 magi hlg

本文主要是介绍HLG 1159 MAGI System,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

MAGI System
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 236(105 users)Total Accepted: 120(98 users)Rating:Special Judge: No
Description

    《Neon Genesis Evangelion》(中文译名:新世纪福音战士,简称EVA)。《EVA》是表面上是一部机器人动画,但是在剧情的展开手法,内容的深度上,使得一经播出就在日本引发“社会现象”程度的回应。其中涉及大量宗家和哲学的内容,复杂的人物精神分析。让《EVA》超出简单动画作品的高度。成为日本动画史上无法超越的动画之一。
    “MAGI System”出自《EVA》,是作品中Nerv组织所使用的大型中央电脑系统。MAGI一词源于圣经,似乎意为东方三贤人,由东方而来朝拜耶稣的三人。该系统由三台分别以东方三贤人命名的独立电脑MELCHIOR 1、BALTHASAR 2、CASPER 3组成,3个独立电脑会独自仲裁事件,最终采用多数通过制决定。Nerv的组织的数据计算和事件决策都是通过MAGI system来负责计算和仲裁的。
    在大型数据计算时,经常涉及高精度运算,比如巨大整数的计算或者高精度的浮点计算。大整数的计算可以通过模拟普通计算的方法来实现。例如:
  123
*  45
-----
  615
 492
-----
 5535
   这里我们用模拟法来实现大整数的乘法运算。

Input

存在多组数据。每行有两个非负整数n,m,以空格隔开,n和m的位数不会超过1000。

Output

给出每一组数据的乘积值,每一组结果为一行。

Sample Input

123 321
123456789 987654321
1 0

Sample Output

39483
121932631112635269
0

Author

孔繁阳

ACcode:

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define ll long long int
#define maxn 100005
#define mod 1000000007
#define INF 0x3f3f3f3f //int×î´óÖµ
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
#define MAXN 9999
#define MAXSIZE 1010
#define DLEN 4
using namespace std;
class BigNum{
private:int a[500];int len;
public:BigNum(){len=1;MT(a,0);}BigNum(const int);///int 转大数BigNum(const char*);///字符转大数BigNum(const BigNum&);///拷贝BigNum &operator=(const BigNum&);///重载赋值friend istream& operator>>(istream&,BigNum&);///重载输入friend ostream& operator<<(ostream&,BigNum&);///输出BigNum operator+(const BigNum&)const;BigNum operator-(const BigNum&)const;BigNum operator*(const BigNum&)const;BigNum operator/(const int &)const;BigNum operator^(const int &)const;///n次方int operator%(const int &)const;///大数对Int数取modbool operator>(const BigNum &T)const;///比大小bool operator>(const int &t)const;void print();
};
BigNum ::BigNum(const int b){int c,d=b;len=0;MT(a,0);while(d>MAXN){c=d-((d/MAXN+1))*(MAXN+1);d=d/(MAXN+1);a[len++]=c;}a[len++]=d;
}
BigNum::BigNum(const char *s){int t,k,myindex,L,i;MT(a,0);L=strlen(s);len=L/DLEN;if(L%DLEN)len++;myindex=0;for(i=L-1;i>=0;i-=DLEN){t=0;k=i-DLEN+1;if(k<0)k=0;for(int j=k;j<=i;++j)t=t*10+s[j]-'0';a[myindex++]=t;}
}
BigNum::BigNum(const BigNum &T):len(T.len){MT(a,0);for(int i=0;i<len;i++)a[i]=T.a[i];
}
BigNum&BigNum::operator=(const BigNum &n){len=n.len;MT(a,0);for(int i=0;i<len;i++)a[i]=n.a[i];return *this;
}
istream& operator>>(istream &in,BigNum &b){char ch[MAXSIZE*4];int i=-1;in>>ch;int L=strlen(ch);int count=0,sum=0;for(i=L-1;i>=0;){sum=0;int t=1;for(int j=0;j<4&&i>=0;j++,i--,t*=10)sum+=(ch[i]-'0')*t;b.a[count]=sum;count++;}b.len=count++;return in;
}
ostream& operator<<(ostream& out,BigNum& b){int i;cout<<b.a[b.len-1];for(i=b.len-2;i>=0;i--)printf("%04d",b.a[i]);return out;
}
BigNum BigNum::operator+(const BigNum &T)const{BigNum t(*this);int i,big;big=T.len>len?T.len:len;for(i=0;i<big;++i){t.a[i]+=T.a[i];;if(t.a[i]>MAXN){t.a[i+1]++;t.a[i]-=MAXN+1;}}if(t.a[big]!=0)t.len=big+1;else t.len=big;return t;
}
BigNum BigNum::operator-(const BigNum &T)const{int j,big;bool flag;BigNum t1,t2;if(*this>T){t1=*this;t2=T;flag=0;}else {t1=T;t2=*this;flag=1;}big=t1.len;for(int i=0;i<big;i++){if(t1.a[i]<t2.a[i]){j=i+1;while(t1.a[j]==0)j++;t1.a[j--]--;while(j>i)t1.a[j--]+=MAXN;t1.a[i]+=MAXN+1-t2.a[i];}else t1.a[i]-=t2.a[i];}t1.len=big;while(t1.a[len-1]==0&&t1.len>1){t1.len--;big--;}if(flag)t1.a[big-1]=0-t1.a[big-1];return t1;
}
BigNum BigNum::operator*(const BigNum &T)const{BigNum ret;int i,j,up;int temp,temp1;for(i=0;i<len;i++){up=0;for(j=0;j<T.len;j++){temp=a[i]*T.a[j]+ret.a[i+j]+up;if(temp>MAXN){temp1=temp-temp/(MAXN+1)*(MAXN+1);up=temp/(MAXN+1);ret.a[i+j]=temp1;}else {up=0;ret.a[i+j]=temp;}}if(up!=0)ret.a[i+j]=up;}ret.len=i+j;while(ret.a[ret.len-1]==0&&ret.len>1)ret.len--;return ret;
}
BigNum BigNum::operator/(const int &b)const{BigNum ret;int i,down=0;for(i=len-1;i>=0;i--){ret.a[i]=(a[i]+down*(MAXN+1))/b;down=a[i]+down*(MAXN+1)-ret.a[i]*b;}ret.len=len;while(ret.a[ret.len-1]==0&&ret.len>1)ret.len--;return ret;
}
int BigNum::operator%(const int &b)const{int i,d=0;for(i=len-1;i>=0;i--)d=((d*(MAXN+1))%b+a[i])%b;return d;
}
BigNum BigNum::operator^(const int &n)const{BigNum t,ret(1);int i;if(n<0)exit(-1);if(n==0)return 1;if(n==1)return *this;int m=n;while(m>1){t=*this;for(i=1;(i<<1)<=m;i<<=1)t=t*t;m-=i;ret=ret*t;if(m==1)ret=ret*(*this);}return ret;
}
bool BigNum::operator>(const BigNum &T)const{int ln;if(len>T.len)return true;else if(len==T.len){ln=len-1;while(a[ln]==T.a[ln]&&ln>=0)ln--;if(ln>=0&&a[ln]>T.a[ln])return true;elsereturn false;}elsereturn false;
}
bool BigNum::operator>(const int &t)const{BigNum b(t);return *this>b;
}
void BigNum::print(){int i;printf("%d",a[len-1]);for(i=len-2;i>=0;i--)printf("%04d",a[i]);printf("\n");
}
int main(){BigNum a,b;while(cin>>a>>b){a=a*b;cout<<a<<'\12';}return 0;
}


这篇关于HLG 1159 MAGI System的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/484346

相关文章

Partical System

创建"粒子系统物体"(点击菜单GameObject -> Create Other -> Particle System) 添加"粒子系统组件"(点击Component -> Effects  ->Particle System) 粒子系统检视面板  点击粒子系统检视面板的右上角的"+"来增加新的模块。(Show All Modules:显示全部) 初始化模块: •

小技巧绕过Sina Visitor System(新浪访客系统)

0x00 前言 一直以来,爬虫与反爬虫技术都时刻进行着博弈,而新浪微博作为一个数据大户更是在反爬虫上不遗余力。常规手段如验证码、封IP等等相信很多人都见识过…… 当然确实有需要的话可以通过新浪开放平台提供的API进行数据采集,但是普通开发者的权限比较低,限制也比较多。所以如果只是做一些简单的功能还是爬虫比较方便~ 应该是今年的早些时候,新浪引入了一个Sina Visitor Syst

System.getProperties().

Java.version Java 运行时环境版本 java.vendor Java 运行时环境供应商 java.vendor.url Java 供应商的 URL java.home Java 安装目录 java.vm.specification.version Java 虚拟机规范版本 java.vm.specification.vendor

12C 新特性,MOVE DATAFILE 在线移动 包括system, 附带改名 NID ,cdb_data_files视图坏了

ALTER DATABASE MOVE DATAFILE  可以改名 可以move file,全部一个命令。 resue 可以重用,keep好像不生效!!! system照移动不误-------- SQL> select file_name, status, online_status from dba_data_files where tablespace_name='SYSTEM'

android6/7 system打包脚本

1.android5打包system就是网站上常见的制作ROM必备的解包打包system脚本 指令如下:mkuserimg.sh -s out/target/product/$TARGET_PRODUCT/system out/target/product/$TARGET_PRODUCT/obj/PACKAGING/systemimage_intermediates/system.img

android打包解包boot.img,system.img

原帖地址:http://www.52pojie.cn/thread-488025-1-1.html 转载Mark一下,日后研究 最近工作需要对boot.img,system.img进行破解。顺便将心得分享一下。 我的工作环境是在linux下的。所以工具都是针对linux的。 boot.img破解相关工具: 1、split_boot    perl脚本 2、boot_i

MTK Android P/Q system/vendor/super快速打包

一、Android 新版本默认开启了动态分区,把system vendor  product等分区打包成一个super分区。这对于我们使用替换分区的方法来排查问题不是很方便,直接替换一个super也不知道到底是哪个部分导致的。所以我们需要自己制作super.img来缩小范围。下面讲讲如何快速生成system、vendor、super,以及vbmeta(校验image,不匹配可能会导致不开机) 二

Linux函数fcntl/system学习

本文针对项目中用到的几个函数进行详细分析,并尽可能的添加示例进行验证学习。比如fcntl/ioctl函数、system/exec函数、popen/pclose函数、mmap函数等。 重点参考了《UNP》和《Linux程序设计》第四版。 一、fcntl函数 fcntl函数可以改变或者查看已打开文件的性质。该函数的定义如下: #include <fcntl.h> int fcntl(

【UVA】11400-Lighting System Design(动态规划)

这道题感觉状态式不是很好推。。。 WA了好几次是因为排序的时候出问题了。 这道题出在线性结构里了,先说一下最长上升子序列吧。 dp[i]代表了以array[i]结尾的时候,最长子序列长度。 推导的时候,以起点递增的顺序进行推导。 #include<cstdio>#include<cstring>#include<iostream>#include<algorithm>#i

解决PHP Warning: strftime(): It is not safe to rely on the system's timezone set

当运行一些程序时,在httpd日志中会有如下警告日志: PHP Warning:  strftime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set(