UVa 141 The Spot Game

2023-12-10 04:59
文章标签 spot 141 game uva

本文主要是介绍UVa 141 The Spot Game,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=77


类型: 哈希判重 + 模拟


原题:

The game of Spot is played on an NxN board as shown below for N = 4. During the game, alternate players may either place a black counter (spot) in an empty square or remove one from the board, thus producing a variety of patterns. If a board pattern (or its rotation by 90 degrees or 180 degrees) is repeated during a game, the player producing that pattern loses and the other player wins. The game terminates in a draw after 2N moves if no duplicate pattern is produced before then.

Consider the following patterns:

picture23

If the first pattern had been produced earlier, then any of the following three patterns (plus one other not shown) would terminate the game, whereas the last one would not.

Input and Output

Input will consist of a series of games, each consisting of the size of the board, N (2 tex2html_wrap_inline180 N tex2html_wrap_inline180 50) followed, on separate lines, by 2N moves, whether they are all necessary or not. Each move will consist of the coordinates of a square (integers in the range 1..N) followed by a blank and a character `+' or `-' indicating the addition or removal of a spot respectively. You may assume that all moves are legal, that is there will never be an attempt to place a spot on an occupied square, nor to remove a non-existent spot. Input will be terminated by a zero (0).

Output will consist of one line for each game indicating which player won and on which move, or that the game ended in a draw.

Sample input

2
1 1 +
2 2 +
2 2 -
1 2 +
2
1 1 +
2 2 +
1 2 +
2 2 -
0

Sample output

Player 2 wins on move 3
Draw


题目大意:

有一个在N*N棋盘上玩的游戏叫做Spot,  它由两个玩家轮流在棋盘上放置棋子或移除棋子, 一旦其中一个玩家放置或者移除棋子之后,那个棋盘的摆放状态或者这个转台旋转90度,180度是之前是出现过的,那么他就输了。 


分析与总结:

看了下我做这题的提交记录, 一共WA了17次大哭

到底是什么原因使得这并不难题的一题让我WA得彻底恶心了?让我们走近科学。

让我WA的原因:

1.  棋盘并不是4*4的,而是N*N的。  WA了n次。

2.  旋转问题。 题目其实说得有点含糊,只是说旋转90度和180度。 我就以为共有4种状态要判断之前是否出现过,但是题目上又说了 (plus one other not shown)  ,也就是说其实还有一个状态没有给出图像。 还有一个是什么呢? 于是把题目给的图像通过旋转函数打印了出来, 发现最后一副图是不一样的,通过旋转方向根本就得不到。 这幅图实际上是第一个的镜面反射的图。 所以题目说的还有一个没有显示出来的,是旋转180度的那个图像。 因为这个原因又WA了n次。


这样的错误说明我读题还是太浮躁了,沉不下心来好好读懂题意,看了个大概知道了原理和思路就直接做了,以后一定要改掉这个习惯。


纠正了这两个错误后, 成功AC。

/**  UVa  141 - The Spot Game *  Time: 0.044s (UVa)*  Author: D_Double**/
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;typedef int State[52][52];
State board, que[105];
const int HashSize = (1<<16);
int N, nState, flag, head[HashSize], next[HashSize];// 模拟得出旋转后的状态
inline void rotate(State &next, State &s, int dir){if(!dir) return;if(dir==1){ // 顺时针90度for(int i=0, x=0; i<N; ++i, ++x){for(int j=N-1, y=0; j>=0; --j, ++y)next[x][y] = s[j][i];}}else if(dir==2){ // 逆时针90度for(int i=N-1, x=0; i>=0; --i, ++x){for(int j=0, y=0; j<N; ++j, ++y)next[x][y] = s[j][i];}}else if(dir==3){ // 180度for(int i=N-1, x=0; i>=0; --i, ++x){for(int j=N-1, y=0; j>=0; --j, ++y )next[x][y] = s[i][j];} }else if(dir==4){ // 镜面反射for(int i=0, x=0; i<N; ++i, ++x){for(int j=N-1, y=0; j>=0; --j, ++y)next[x][y] = s[i][j];}  }
}inline int hash(State &s){int v=0;for(int i=0; i<N; ++i)for(int j=0; j<N; ++j)v = ((v<<1)+s[i][j]) % HashSize;return v%HashSize;
}
int search(State &s){int h=hash(s);int u=head[h];while(u){if(memcmp(que[u], s, sizeof(s))==0) return 1;u = next[u];}return 0;
}
inline void insert(int s){int h=hash(que[s]);int u=head[h];while(u){u = next[u];}next[s] = head[h] ;head[h] = s;
} bool add_hash(int s){State state[5];memcpy(state[0], que[s], sizeof(que[s]));for(int i=0; i<=4; ++i){rotate(state[i], que[s], i);if(search(state[i])) return false; }insert(s); return true;
}inline void init(){nState = 2;memset(head, 0, sizeof(head));memset(board, 0, sizeof(board));memcpy(que[1], board, sizeof(board));insert(1);flag=0;
}int main(){int a, b, winner, step;char ch;while(scanf("%d", &N), N){init();for(int i=0; i<2*N; ++i){scanf("%d %d %c",&a,&b,&ch);if(ch=='+') board[a-1][b-1] = 1;else board[a-1][b-1] = 0;memcpy(que[nState], board, sizeof(board));if(!flag && !add_hash(nState)){winner = !(i&1);  step = i+1; flag=1;}++nState;}if(flag) printf("Player %d wins on move %d\n", winner+1, step);else printf("Draw\n");}   return 0;
}

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)


这篇关于UVa 141 The Spot Game的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/476075

相关文章

uva 10055 uva 10071 uva 10300(水题两三道)

情歌两三首,水题两三道。 好久没敲代码了为暑假大作战热热身。 uva 10055 Hashmat the Brave Warrior 求俩数相减。 两个debug的地方,一个是longlong,一个是输入顺序。 代码: #include<stdio.h>int main(){long long a, b;//debugwhile(scanf("%lld%lld", &

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

uva 10387 Billiard(简单几何)

题意是一个球从矩形的中点出发,告诉你小球与矩形两条边的碰撞次数与小球回到原点的时间,求小球出发时的角度和小球的速度。 简单的几何问题,小球每与竖边碰撞一次,向右扩展一个相同的矩形;每与横边碰撞一次,向上扩展一个相同的矩形。 可以发现,扩展矩形的路径和在当前矩形中的每一段路径相同,当小球回到出发点时,一条直线的路径刚好经过最后一个扩展矩形的中心点。 最后扩展的路径和横边竖边恰好组成一个直

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一

uva 568 Just the Facts(n!打表递推)

题意是求n!的末尾第一个不为0的数字。 不用大数,特别的处理。 代码: #include <stdio.h>const int maxn = 10000 + 1;int f[maxn];int main(){#ifdef LOCALfreopen("in.txt", "r", stdin);#endif // LOCALf[0] = 1;for (int i = 1; i <=

uva 575 Skew Binary(位运算)

求第一个以(2^(k+1)-1)为进制的数。 数据不大,可以直接搞。 代码: #include <stdio.h>#include <string.h>const int maxn = 100 + 5;int main(){char num[maxn];while (scanf("%s", num) == 1){if (num[0] == '0')break;int len =

uva 10014 Simple calculations(数学推导)

直接按照题意来推导最后的结果就行了。 开始的时候只做到了第一个推导,第二次没有继续下去。 代码: #include<stdio.h>int main(){int T, n, i;double a, aa, sum, temp, ans;scanf("%d", &T);while(T--){scanf("%d", &n);scanf("%lf", &first);scanf

uva 10916 Factstone Benchmark(打表)

题意是求 k ! <= 2 ^ n ,的最小k。 由于n比较大,大到 2 ^ 20 次方,所以 2 ^ 2 ^ 20比较难算,所以做一些基础的数学变换。 对不等式两边同时取log2,得: log2(k ! ) <=  log2(2 ^ n)= n,即:log2(1) + log2(2) + log2 (3) + log2(4) + ... + log2(k) <= n ,其中 n 为 2 ^

uva 10025 The ? 1 ? 2 ? ... ? n = k problem(数学)

题意是    ?  1  ?  2  ?  ...  ?  n = k 式子中给k,? 处可以填 + 也可以填 - ,问最小满足条件的n。 e.g k = 12  - 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 with n = 7。 先给证明,令 S(n) = 1 + 2 + 3 + 4 + 5 + .... + n 暴搜n,搜出当 S(n) >=