05-树9 Huffman Codes (30分)

2023-12-09 12:08
文章标签 05 30 huffman codes

本文主要是介绍05-树9 Huffman Codes (30分),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

05-树9 Huffman Codes (30分)

In 1953, David A. Huffman published his paper “A Method for the Construction of Minimum-Redundancy Codes”, and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string “aaaxuaxz”, we can observe that the frequencies of the characters ‘a’, ‘x’, ‘u’ and ‘z’ are 4, 2, 1 and 1, respectively. We may either encode the symbols as {‘a’=0, ‘x’=10, ‘u’=110, ‘z’=111}, or in another way as {‘a’=1, ‘x’=01, ‘u’=001, ‘z’=000}, both compress the string into 14 bits. Another set of code can be given as {‘a’=0, ‘x’=11, ‘u’=100, ‘z’=101}, but {‘a’=0, ‘x’=01, ‘u’=011, ‘z’=001} is NOT correct since “aaaxuaxz” and “aazuaxax” can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] … c[N] f[N]
where c[i] is a character chosen from {‘0’ - ‘9’, ‘a’ - ‘z’, ‘A’ - ‘Z’, ‘_’}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (≤1000), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]
where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0’s and '1’s.

Output Specification:

For each test case, print in each line either “Yes” if the student’s submission is correct, or “No” if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
No
No

#include<bits/stdc++.h>
using namespace std;
int Check(string ss[],int N);
int main(){map<char,int>m;priority_queue<int, vector<int>,greater<int> >q;int N,V,num,val,len;char c;cin>>N;for(int i=0;i<N;i++){cin>>c>>num;m[c]=num;q.push(num);}while(1){num=q.top();q.pop();if(q.empty())break;num+=q.top();q.pop();q.push(num);val+=num;}cin>>V;for(int i=0;i<V;i++){len=0;char t;string ss[N];for(int i=0;i<N;i++){cin>>t>>ss[i];int l=ss[i].size();len+=l*m[t];}if(len!=val||!Check(ss,N))printf("No\n");else printf("Yes\n");}
}
int Check(string ss[],int N){sort(ss,ss+N);for(int i=0;i<N-1;i++)for(int j=i+1;j<N;j++)if(ss[j].find(ss[i])==0)return 0;return 1;
}
#include<bits/stdc++.h>
using namespace std;typedef struct TNode* Ptr;
struct TNode {char c;int f;
};int N, Size;
Ptr Heap[100];
map<char, int> codeMap;void Insert();
Ptr Delete();
void Pre(int root);int main() {cin >> N;char c;int fre, sum = 0;Size  = 0;for (int i = 1; i<= N; i++) {cin >> c >> fre;codeMap[c] = fre;getchar();Heap[i] = (Ptr)malloc(sizeof(struct TNode));Heap[i]->c = c;Heap[i]->f = fre;Size++;Insert();}for (int i = 1; i < N; i++) {Ptr root1 = Delete();Ptr root2 = Delete();root1->f += root2->f;sum += root1->f;Heap[++Size] = root1;free(root2);}int number;cin>>number;while (number--) {char C1;map<string, bool> fuck;string code[N], s1, s2;int judge = 0, flag = 0;for (int i = 0; i < N; i++) {cin >> C1 >> code[i];if (flag == 1) continue;if (fuck[code[i]] == true) flag = 1;fuck[code[i]] = true;getchar();judge += (codeMap[C1] * code[i].length());}for (int i = 0; i < N; i++) {code[i] = code[i].substr(0, code[i].length()-1);if (fuck[code[i]] == true) flag = 1;}if (judge == sum && !flag) printf("Yes\n");else printf("No\n");}
}void Insert() {Ptr Temp = Heap[Size];int X = Heap[Size]->f, i = Size;for (; i > 1 && Heap[i / 2]->f > X; i /= 2)Heap[i] = Heap[i / 2];Heap[i] = Temp; 
}Ptr Delete() {if (!Heap[1]) return nullptr;Ptr Temp = Heap[1];Heap[1] = Heap[Size--];Pre(1);return Temp; 
}void Pre(int root) {Ptr Temp = Heap[root];int X = Heap[root]->f, Parent = root, Child;for (; Parent * 2 <= Size; Parent = Child) {Child = Parent * 2;if (Child != Size && Heap[Child]->f > Heap[Child + 1]->f)Child++;if (X <= Heap[Child]->f)break;else Heap[Parent] = Heap[Child]; }Heap[Parent] = Temp;
}

这篇关于05-树9 Huffman Codes (30分)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/473700

相关文章

30常用 Maven 命令

Maven 是一个强大的项目管理和构建工具,它广泛用于 Java 项目的依赖管理、构建流程和插件集成。Maven 的命令行工具提供了大量的命令来帮助开发人员管理项目的生命周期、依赖和插件。以下是 常用 Maven 命令的使用场景及其详细解释。 1. mvn clean 使用场景:清理项目的生成目录,通常用于删除项目中自动生成的文件(如 target/ 目录)。共性规律:清理操作

2024网安周今日开幕,亚信安全亮相30城

2024年国家网络安全宣传周今天在广州拉开帷幕。今年网安周继续以“网络安全为人民,网络安全靠人民”为主题。2024年国家网络安全宣传周涵盖了1场开幕式、1场高峰论坛、5个重要活动、15场分论坛/座谈会/闭门会、6个主题日活动和网络安全“六进”活动。亚信安全出席2024年国家网络安全宣传周开幕式和主论坛,并将通过线下宣讲、创意科普、成果展示等多种形式,让广大民众看得懂、记得住安全知识,同时还

忽略某些文件 —— Git 学习笔记 05

忽略某些文件 忽略某些文件 通过.gitignore文件其他规则源如何选择规则源参考资料 对于某些文件,我们不希望把它们纳入 Git 的管理,也不希望它们总出现在未跟踪文件列表。通常它们都是些自动生成的文件,比如日志文件、编译过程中创建的临时文件等。 通过.gitignore文件 假设我们要忽略 lib.a 文件,那我们可以在 lib.a 所在目录下创建一个名为 .gi

c++习题30-求10000以内N的阶乘

目录 一,题目  二,思路 三,代码    一,题目  描述 求10000以内n的阶乘。 输入描述 只有一行输入,整数n(0≤n≤10000)。 输出描述 一行,即n!的值。 用例输入 1  4 用例输出 1  24   二,思路 n    n!           0    1 1    1*1=1 2    1*2=2 3    2*3=6 4

嵌入式面试经典30问:二

1. 嵌入式系统中,如何选择合适的微控制器或微处理器? 在嵌入式系统中选择合适的微控制器(MCU)或微处理器(MPU)时,需要考虑多个因素以确保所选组件能够满足项目的具体需求。以下是一些关键步骤和考虑因素: 1.1 确定项目需求 性能要求:根据项目的复杂度、处理速度和数据吞吐量等要求,确定所需的处理器性能。功耗:评估系统的功耗需求,选择低功耗的MCU或MPU以延长电池寿命或减少能源消耗。成本

C++入门(05-2)从命令行执行C++编译器_GCC

文章目录 GCC编译器1. 下载MinGW-w64,安装(不推荐)2. 使用MSYS2安装MinGW-w64(推荐)2.1 安装MSYS22.2 初始化和更新2.3 安装MinGW-w64编译器2.3 在MSYS2 Shell中导航到代码目录2.4 使用 g++ 编译2.5 运行可执行文件 GCC编译器 GCC(GNU Compiler Collection)是一个开源编译器集

【全网最全】2024年数学建模国赛A题30页完整建模文档+17页成品论文+保奖matla代码+可视化图表等(后续会更新)

您的点赞收藏是我继续更新的最大动力! 一定要点击如下的卡片,那是获取资料的入口! 【全网最全】2024年数学建模国赛A题30页完整建模文档+17页成品论文+保奖matla代码+可视化图表等(后续会更新)「首先来看看目前已有的资料,还会不断更新哦~一次购买,后续不会再被收费哦,保证是全网最全资源,随着后续内容更新,价格会上涨,越早购买,价格越低,让大家再也不需要到处买断片资料啦~💰💸👋」�

C++入门(05)从命令行执行C++编译器_MSVC

文章目录 1.C++ 编译器2. 常用 C++ 编译器MSVC(Microsoft Visual C++)GCC(GNU Compiler Collection)Clang 3. MSVC 编译器3.1 开发者命令提示符3.2 编译 C++ 代码 1.C++ 编译器 将C++源代码(扩展名为 .cpp )转换成计算机可以运行的可执行程序 编译器会检查代码的语法和语义,生成相应

龙芯+FreeRTOS+LVGL实战笔记(新)——05部署主按钮

本专栏是笔者另一个专栏《龙芯+RT-Thread+LVGL实战笔记》的姊妹篇,主要的区别在于实时操作系统的不同,章节的安排和任务的推进保持一致,并对源码做了改进和优化,各位可以先到本人主页下去浏览另一专栏的博客列表(目前已撰写36篇,图1所示),再决定是否订阅。此外,也可以前往本人在B站的视频合集(图2所示)观看所有演示视频,合集首个视频链接为: 借助RT-Thread和LVGL

JobScheduler 调用导致的运行时长30分钟的功耗问题

一、SDK 的使用情况与功耗影响 案例是否导致功耗变大onStartJob return true 且子线程没有调用jobFinished()告知系统功耗变大,最长带来30分钟的partial wakelock 长持锁onStartJob return true 且子线程调用jobFinished()告知系统功耗有影响,主要线程执行时长,标准是30秒内onStartJob return fals