本文主要是介绍07-图5 Saving James Bond - Hard Version (30分)(数据结构)(c语言),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).
Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him a shortest path to reach one of the banks. The length of a path is the number of jumps that James has to make.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.
Output Specification:
For each test case, if James can escape, output in one line the minimum number of jumps he must make. Then starting from the next line, output the position (x,y) of each crocodile on the path, each pair in one line, from the island to the bank. If it is impossible for James to escape that way, simply give him 0 as the number of jumps. If there are many shortest paths, just output the one with the minimum first jump, which is guaranteed to be unique.
Sample Input 1:
17 15
10 -21
10 21
-40 10
30 -50
20 40
35 10
0 -10
-25 22
40 -40
-30 30
-10 22
0 11
25 21
25 10
10 10
10 35
-30 10
Sample Output 1:
4
0 11
10 21
10 35
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
0
这道题目挺难的,我当时做这道题目的时候想了好久,比较复杂。
我们在做这道题目的时候,不仅要考虑007能否上岸,还要考虑007所走的路径,我的大概思路是这样的,首先进行筛选,对不在湖中的和坐标小于岛上的,我们进行过滤掉,也就是不做研究,然后对鳄鱼进行排列,从小到大,坐标小的放前面,坐标大的放后面,然后我们还需要进行判断,哪些是能第一次跳到的鳄鱼,然后对其进行递归,我们还需要定义一个路径,跳的下一个鳄鱼的前面一个鳄鱼我们需要存起来,然后定义走的鳄鱼数,然后第一次能跳上去的鳄鱼我们递归都会得到从这只鳄鱼我们需要跳几次才能跳到岸,最后我们还需要进行筛选,得到最小的路径并将其打印。
首先我们给出相关的定义:
#include<stdio.h>
#include<math.h>
typedef struct {int x,y;
}crocodile;
typedef struct {int pre;int total;
}crocodile2;
typedef struct {int data[105];int head,rear;
}Quene;
crocodile data[105];//存储鳄鱼的坐标
crocodile2 path[105];//里面含有上一个节点的坐标,以及到这一步最少的步数
int visit[105];
int n,d;
int first;//第一步能跳的鳄鱼个数
Quene q;
关于队列的操作
void init(Quene &q) {q.head=q.rear=-1;
}
bool isempty(Quene q) {return q.head==q.rear;
}
void push(Quene &q,int i) {q.data[++q.rear]=i;
}
int pop(Quene& q) {return q.data[++q.head];
}
然后是一些小函数
bool isok(crocodile a) {if(50-abs(a.x)<=d||50-abs(a.y)<=d) return true;return false;
}
void swapcrocodile(crocodile &a,crocodile &b) {crocodile temp=a;a=b;b=temp;
}
bool cmp(crocodile a,crocodile b) {return pow(a.x,2)+pow(a.y,2)>pow(b.x,2)+pow(b.y,2);
}
bool canjump(crocodile a,crocodile b) {return d*d>=pow(a.x-b.x,2)+pow(a.y-b.y,2);
}
void start() {init(q);for(int i=0; i<n; i++) {path[i].pre=-1;path[i].total=10000;}
}
程序主函数
int main() {scanf("%d%d",&n,&d);//输入鳄鱼个数和步长getxy();if(d>42.5) printf("1\n");else getpath();return 0;
}
输入坐标
void getxy() {int actn=0;for(int i=0; i<n; i++) {int x,y;scanf("%d%d",&x,&y);if(x*x+y*y>7.5*7.5&&50>abs(x)&&50>abs(y)) //鳄鱼在湖中且不在岛上{data[actn].x=x;data[actn++].y=y;}}n=actn;//删掉无用的鳄鱼for(int i=0; i<n; i++) {for(int j=i+1; j<n; j++) if(cmp(data[i],data[j])) //对鳄鱼坐标进行排列swapcrocodile(data[i],data[j]);if(pow(data[i].x,2)+pow(data[i].y,2)>(7.5+d)*(7.5+d)) {first=i;//first最终指向第一次能跳到的鳄鱼的最后一个break;}}
}
获得路径
void getpath() {if(first==0) //一只鳄鱼都跳不上去{printf("0\n");return;}start();//初始化for(int i=0; i<first; i++) visit[i]=BFS(i);//进行遍历int count=100,tempv=1000;for(int i=0; i<first; i++) {if(visit[i]!=-1) {if(path[visit[i]].total<count) //是有效的,记录了跳上岸的步数,找到最小的路径{count=path[visit[i]].total;tempv=visit[i];//指向跳到岸的最后那只鳄鱼}}}if(tempv==1000) printf("0\n");else {printf("%d\n",path[tempv].total+1);//那一层再加上1print(tempv);//打印}
}
遍历
int BFS(int f) {visit[f]=1;//先访问push(q,f);//入队path[f].total=1;//步数记为1if(isok(data[f]))//直接跳上去了 {return f;}while(!isempty(q)) {int v=pop(q);//出队for(int i=first; i<n; i++) {if(canjump(data[v],data[i])&&path[i].total>path[v].total+1) {visit[i]=1;push(q,i);path[i].pre=v;//是从v跳过来的path[i].total=path[v].total+1;//记录步数if(isok(data[i])) return i;}}}return -1;
}
打印
void print(int tempv) {if(tempv==-1) return;print(path[tempv].pre);//递归到最后一层,逆序打印printf("%d %d\n",data[tempv].x,data[tempv].y);
}
总代码如下
#include<stdio.h>
#include<math.h>
typedef struct {int x,y;
}crocodile;
typedef struct {int pre;int total;
}crocodile2;
typedef struct {int data[105];int head,rear;
}Quene;
crocodile data[105];//存储鳄鱼的坐标
crocodile2 path[105];//里面含有上一个节点的坐标,以及到这一步最少的步数
int visit[105];
int n,d;
int first;//第一步能跳的鳄鱼个数
Quene q;
void init(Quene &q) {q.head=q.rear=-1;
}
bool isempty(Quene q) {return q.head==q.rear;
}
void push(Quene &q,int i) {q.data[++q.rear]=i;
}
int pop(Quene& q) {return q.data[++q.head];
}
bool isok(crocodile a) {if(50-abs(a.x)<=d||50-abs(a.y)<=d) return true;return false;
}
void swapcrocodile(crocodile &a,crocodile &b) {crocodile temp=a;a=b;b=temp;
}
bool cmp(crocodile a,crocodile b) {return pow(a.x,2)+pow(a.y,2)>pow(b.x,2)+pow(b.y,2);
}
bool canjump(crocodile a,crocodile b) {return d*d>=pow(a.x-b.x,2)+pow(a.y-b.y,2);
}
void start() {init(q);for(int i=0; i<n; i++) {path[i].pre=-1;path[i].total=10000;}
}
int BFS(int f) {visit[f]=1;push(q,f);path[f].total=1;if(isok(data[f])) {return f;}while(!isempty(q)) {int v=pop(q);for(int i=first; i<n; i++) {if(canjump(data[v],data[i])&&path[i].total>path[v].total+1) {visit[i]=1;push(q,i);path[i].pre=v;path[i].total=path[v].total+1;if(isok(data[i])) return i;}}}return -1;
}
void print(int tempv) {if(tempv==-1) return;print(path[tempv].pre);printf("%d %d\n",data[tempv].x,data[tempv].y);
}
void getpath() {if(first==0) {printf("0\n");return;}start();for(int i=0; i<first; i++) visit[i]=BFS(i);int count=100,tempv=1000;for(int i=0; i<first; i++) {if(visit[i]!=-1) {if(path[visit[i]].total<count) {count=path[visit[i]].total;tempv=visit[i];}}}if(tempv==1000) printf("0\n");else {printf("%d\n",path[tempv].total+1);print(tempv);}
}
void getxy() {int actn=0;for(int i=0; i<n; i++) {int x,y;scanf("%d%d",&x,&y);if(x*x+y*y>7.5*7.5&&50>abs(x)&&50>abs(y)) {data[actn].x=x;data[actn++].y=y;}}n=actn;//录入并删掉无用节点for(int i=0; i<n; i++) {for(int j=i+1; j<n; j++) if(cmp(data[i],data[j])) swapcrocodile(data[i],data[j]);if(pow(data[i].x,2)+pow(data[i].y,2)>(7.5+d)*(7.5+d)) {first=i;break;}}//将能跳的鳄鱼由近到远排序
}
int main() {scanf("%d%d",&n,&d);getxy();if(d>42.5) printf("1\n");else getpath();return 0;
}
如果在PTA编译不成功的话,建议换一下c++的那个模式。
这篇关于07-图5 Saving James Bond - Hard Version (30分)(数据结构)(c语言)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!