本文主要是介绍Rebuilding Roads (树形dp+背包),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目:Rebuilding Roads
The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree.
Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.
Input
* Line 1: Two integers, N and P
* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads.
Output
A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated.
Sample Input
11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11
Sample Output
2
Hint
[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.]
题意:在一个n个结点的树上,问最少删除几条边可以得到结点的个数为m的树。
思路:树形dp+背包
设置二维dp数组,dp[i][j]表示以i为结点生成j个结点的子树需要减掉的最小次数。
状态转移方程见代码。
背包问题……
源代码:
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <stdio.h>
#define maxn 1005
using namespace std;
int dp[maxn][maxn];
vector <int> tree[maxn];
int n,p;
void tree_dp(int x){for (int i = 0; i < tree[x].size(); i++){tree_dp(tree[x][i]);for (int j = p; j >= 1; j--){for (int k = 1; k < j; k++){dp[x][j] = min(dp[x][j],dp[tree[x][i]][k]+dp[x][j-k]-1);}}}
}
int main(){while (scanf("%d%d",&n,&p)!=EOF){int x,y;for (int i = 0; i <= n; i++)tree[i].clear();memset(dp,-99999999,sizeof(dp));for (int i = 0; i < n-1; i++){scanf("%d%d",&x,&y);tree[x].push_back(y);}for (int i = 1; i <= n; i++)dp[i][1] = tree[i].size();tree_dp(1);int ans = dp[1][p];for (int i = 2; i <= n; i++){ans = min(ans,dp[i][p] + 1);}printf("%d\n",ans);}return 0;
}
这篇关于Rebuilding Roads (树形dp+背包)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!