HDU2602(01背包复习)

2023-10-27 23:38
文章标签 01 背包 复习 hdu2602

本文主要是介绍HDU2602(01背包复习),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

 

Sample Output

14

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602 

突然想到自己虽然复习了dp,但是01背包和完全背包问题,居然没有做点OJ题,有点说不过去啊。

这个就是01背包模板题,就是体积V的包去装骨头,每个骨头有价值value和体积volume。 

先来个二维的01背包

dp[i][j]:表示从0到i-1这i个物品中选出总重量不超过j的物品时总价值的最大值。

递推公式如下:

内层j循环反过来也是一样的。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;       
#define mem(a,b) memset(a,b,sizeof(a))    
#define N 1005
int Value[N],Volume[N],dp[N][N];
int main(){int t,n,v;cin>>t;while(t--){cin>>n>>v;mem(dp,0);for(int i=0;i<n;i++){cin>>Value[i];}for(int i=0;i<n;i++){cin>>Volume[i];}for(int i=0;i<n;i++){for(int j=0;j<=v;j++){if(j<Volume[i]){dp[i+1][j]=dp[i][j];}else{dp[i+1][j]=max(dp[i][j],dp[i][j-Volume[i]]+Value[i]);}}}cout<<dp[n][v]<<endl;}return 0;
}

一维背包

记住内层循环是从j=V开始的,因为那是从二维dp简化而来的,如果从volume[i]开始,那样同一样东西就会拿重复了。

 

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;       
#define mem(a,b) memset(a,b,sizeof(a))    
#define N 1005
int Value[N],Volume[N],dp[N];
int main(){int t,n,v;cin>>t;while(t--){cin>>n>>v;mem(dp,0);for(int i=0;i<n;i++){cin>>Value[i];}for(int i=0;i<n;i++){cin>>Volume[i];}for(int i=0;i<n;i++){for(int j=v;j>=Volume[i];j--){dp[j]=max(dp[j],dp[j-Volume[i]]+Value[i]);}}cout<<dp[v]<<endl;}return 0;
}

 

这篇关于HDU2602(01背包复习)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/289186

相关文章

poj2576(二维背包)

题意:n个人分成两组,两组人数只差小于1 , 并且体重只差最小 对于人数要求恰好装满,对于体重要求尽量多,一开始没做出来,看了下解题,按照自己的感觉写,然后a了 状态转移方程:dp[i][j] = max(dp[i][j],dp[i-1][j-c[k]]+c[k]);其中i表示人数,j表示背包容量,k表示输入的体重的 代码如下: #include<iostream>#include<

hdu2159(二维背包)

这是我的第一道二维背包题,没想到自己一下子就A了,但是代码写的比较乱,下面的代码是我有重新修改的 状态转移:dp[i][j] = max(dp[i][j], dp[i-1][j-c[z]]+v[z]); 其中dp[i][j]表示,打了i个怪物,消耗j的耐力值,所得到的最大经验值 代码如下: #include<iostream>#include<algorithm>#include<

csu(背包的变形题)

题目链接 这是一道背包的变形题目。好题呀 题意:给n个怪物,m个人,每个人的魔法消耗和魔法伤害不同,求打死所有怪物所需的魔法 #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<queue>#include<set>//#include<u>#include<map

hdu1011(背包树形DP)

没有完全理解这题, m个人,攻打一个map,map的入口是1,在攻打某个结点之前要先攻打其他一个结点 dp[i][j]表示m个人攻打以第i个结点为根节点的子树得到的最优解 状态转移dp[i][ j ] = max(dp[i][j], dp[i][k]+dp[t][j-k]),其中t是i结点的子节点 代码如下: #include<iostream>#include<algorithm

hdu1171(母函数或多重背包)

题意:把物品分成两份,使得价值最接近 可以用背包,或者是母函数来解,母函数(1 + x^v+x^2v+.....+x^num*v)(1 + x^v+x^2v+.....+x^num*v)(1 + x^v+x^2v+.....+x^num*v) 其中指数为价值,每一项的数目为(该物品数+1)个 代码如下: #include<iostream>#include<algorithm>

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

uva 10130 简单背包

题意: 背包和 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstring>#include <cmath>#include <stack>#include <vector>#include <queue>#include <map>

HDU 2159 二维完全背包

FATE 最近xhd正在玩一款叫做FATE的游戏,为了得到极品装备,xhd在不停的杀怪做任务。久而久之xhd开始对杀怪产生的厌恶感,但又不得不通过杀怪来升完这最后一级。现在的问题是,xhd升掉最后一级还需n的经验值,xhd还留有m的忍耐度,每杀一个怪xhd会得到相应的经验,并减掉相应的忍耐度。当忍耐度降到0或者0以下时,xhd就不会玩这游戏。xhd还说了他最多只杀s只怪。请问他能

多重背包转换成0-1背包

http://acm.hdu.edu.cn/showproblem.php?pid=2191 多重背包特点: 一种物品有C个(既不是固定的1个,也不是无数个) 优化的方法: 运用神奇的二进制,进行物品拆分,转化成01背包 物品拆分,把13个相同的物品分成4组(1,2,4,6) 用这4组可以组成任意一个1~13之间的数! 原理:一个数总可以用2^

POJ1384背包

体积V的包包 n种硬币,体积weight价值value 求把包包恰好装满最小的价值 import java.io.BufferedReader;import java.io.InputStream;import java.io.InputStreamReader;import java.io.PrintWriter;import java.math.BigInteger;imp