1143. Lowest Common Ancestor (30) 最近公共祖先

2023-10-22 11:58

本文主要是介绍1143. Lowest Common Ancestor (30) 最近公共祖先,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

1143. Lowest Common Ancestor (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line "LCA of U and V is A." if the LCA is found and A is the key. But if A is one of U and V, print "X is an ancestor of Y." where X is A and Y is the other node. If U or V is not found in the BST, print in a line "ERROR: U is not found." or "ERROR: V is not found." or "ERROR: U and V are not found.".

Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

        给出一个搜索二叉树的前序遍历序列,给出两个数字,试图找出这两个数字在二叉树中的最近公共祖先(LCA)结点。

        首先建立二叉树比较简单。然后通过findd函数去寻找最近公共祖先。findd函数有两个作用,f为1时是为了寻找a,找到了返回true,此时参数b用不到;f为0时是还在寻找两个点a和b的LCA,此时返回值用不到。当a和b一个比tree->data大另一个比tree->data小时,则当前节点的data就是a和b的LCA(如果a和b都在树中的话),所以接下来把f改为1继续调用findd函数来检查a和b是否都在二叉树中。


#include <cstdio>
#include <cstdlib>using namespace std;typedef struct node *NODE;
typedef struct node {int da;NODE l, r;
}node;NODE T;
int M, N;
int pre[10001];NODE buildtree(int s, int e) {if (e < s) return NULL;if (s == e) {NODE tnode = (NODE)malloc(sizeof(node));tnode->da = pre[s];tnode->l = NULL;tnode->r = NULL;return tnode;}int i = s + 1;while (i <= e && pre[i] < pre[s]) i++;NODE tnode = (NODE)malloc(sizeof(node));tnode->da = pre[s];tnode->l = buildtree(s + 1, i - 1);tnode->r = buildtree(i, e);return tnode;
}bool findd(NODE tree, int a, int b,int f) {if (f == 1) {if (tree == NULL) return false;if (tree->da == a) return true;return findd(a < tree->da ? tree->l : tree->r, a, 0, 1);}else {if (tree == NULL) {printf("ERROR: %d and %d are not found.\n", a, b);return true;}if (a < tree->da&&b < tree->da) findd(tree->l, a, b, 0);else if (a > tree->da&&b > tree->da) findd(tree->r, a, b, 0);else {bool fda = tree->da == a || findd(tree->l, a, 0, 1) || findd(tree->r, a, 0, 1);bool fdb = tree->da == b || findd(tree->l, b, 0, 1) || findd(tree->r, b, 0, 1);if (fda&&fdb) {if (tree->da == a || tree->da == b) printf("%d is an ancestor of %d.\n", tree->da == a ? a : b, tree->da == b ? a : b);elseprintf("LCA of %d and %d is %d.\n", a, b, tree->da);}else if (fda == false && fdb == false) {printf("ERROR: %d and %d are not found.\n", a, b);}else {printf("ERROR: %d is not found.\n", fda ? b : a);}return true;}}
}int main() {scanf("%d %d", &M, &N);int a, b;for (int i = 0; i < N; i++) {scanf("%d", &pre[i]);}T = buildtree(0, N - 1);for (int i = 0; i < M; i++) {scanf("%d %d", &a, &b);findd(T, a, b, 0);}return 0;
}

这篇关于1143. Lowest Common Ancestor (30) 最近公共祖先的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/261292

相关文章

SpringBoot自定义注解如何解决公共字段填充问题

《SpringBoot自定义注解如何解决公共字段填充问题》本文介绍了在系统开发中,如何使用AOP切面编程实现公共字段自动填充的功能,从而简化代码,通过自定义注解和切面类,可以统一处理创建时间和修改时间... 目录1.1 问题分析1.2 实现思路1.3 代码开发1.3.1 步骤一1.3.2 步骤二1.3.3

shell脚本自动删除30天以前的文件(最新推荐)

《shell脚本自动删除30天以前的文件(最新推荐)》该文章介绍了如何使用Shell脚本自动删除指定目录下30天以前的文件,并通过crontab设置定时任务,此外,还提供了如何使用Shell脚本删除E... 目录shell脚本自动删除30天以前的文件linux按照日期定时删除elasticsearch索引s

TP-Link PDDNS服将于务6月30日正式停运:用户需转向第三方DDNS服务

《TP-LinkPDDNS服将于务6月30日正式停运:用户需转向第三方DDNS服务》近期,路由器制造巨头普联(TP-Link)在用户群体中引发了一系列重要变动,上个月,公司发出了一则通知,明确要求所... 路由器厂商普联(TP-Link)上个月发布公告要求所有用户必须完成实名认证后才能继续使用普联提供的 D

最长公共子序列问题的深度分析与Java实现方式

《最长公共子序列问题的深度分析与Java实现方式》本文详细介绍了最长公共子序列(LCS)问题,包括其概念、暴力解法、动态规划解法,并提供了Java代码实现,暴力解法虽然简单,但在大数据处理中效率较低,... 目录最长公共子序列问题概述问题理解与示例分析暴力解法思路与示例代码动态规划解法DP 表的构建与意义动

mysql-8.0.30压缩包版安装和配置MySQL环境过程

《mysql-8.0.30压缩包版安装和配置MySQL环境过程》该文章介绍了如何在Windows系统中下载、安装和配置MySQL数据库,包括下载地址、解压文件、创建和配置my.ini文件、设置环境变量... 目录压缩包安装配置下载配置环境变量下载和初始化总结压缩包安装配置下载下载地址:https://d

poj1330(LCA最近公共祖先)

题意:求最近公共祖先 思路:之前学习了树链剖分,然后我就用树链剖分的一小部分知识就可以解这个题目了,记录每个结点的fa和depth。然后查找时,每次将depth大的结点往上走直到x = y。 代码如下: #include<iostream>#include<algorithm>#include<stdio.h>#include<math.h>#include<cstring>

30常用 Maven 命令

Maven 是一个强大的项目管理和构建工具,它广泛用于 Java 项目的依赖管理、构建流程和插件集成。Maven 的命令行工具提供了大量的命令来帮助开发人员管理项目的生命周期、依赖和插件。以下是 常用 Maven 命令的使用场景及其详细解释。 1. mvn clean 使用场景:清理项目的生成目录,通常用于删除项目中自动生成的文件(如 target/ 目录)。共性规律:清理操作

2024网安周今日开幕,亚信安全亮相30城

2024年国家网络安全宣传周今天在广州拉开帷幕。今年网安周继续以“网络安全为人民,网络安全靠人民”为主题。2024年国家网络安全宣传周涵盖了1场开幕式、1场高峰论坛、5个重要活动、15场分论坛/座谈会/闭门会、6个主题日活动和网络安全“六进”活动。亚信安全出席2024年国家网络安全宣传周开幕式和主论坛,并将通过线下宣讲、创意科普、成果展示等多种形式,让广大民众看得懂、记得住安全知识,同时还

最近心情有点复杂:论心态

一月一次的彷徨又占据了整个身心;彷徨源至不自信;而不自信则是感觉自己的价值没有很好的实现亦或者说是自己不认可自己的目前的生活和状态吧。 我始终相信一句话:任何人的生活形态完全是由自己决定的;外在的总归不能直达一个人的内心深处。所以少年 为了自己想要的生活 多坚持努力吧、不为别人只为自己心中的那一丝执着。 由此我看到了一个故事: 一个心情烦躁的人去拜访禅师。他问禅师:我这辈子就这么注定了吗?您

c++习题30-求10000以内N的阶乘

目录 一,题目  二,思路 三,代码    一,题目  描述 求10000以内n的阶乘。 输入描述 只有一行输入,整数n(0≤n≤10000)。 输出描述 一行,即n!的值。 用例输入 1  4 用例输出 1  24   二,思路 n    n!           0    1 1    1*1=1 2    1*2=2 3    2*3=6 4