本文主要是介绍ZZULI_SUMMER_PRACTICE(7)nbsp;1177nbsp;nbsp;quot;…,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
"Accepted today?"
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1443 Accepted Submission(s): 631
Problem Description
Do you remember a sentence "Accepted today?" Yes, the sentence is mentioned frequently in lcy's course "ACM Programming"!
The contest is still in progress this moment. How excited it is! You, smart programmer, must have AC some problems today. "Can I get copper medal, silver medal, or even golden medal?" Oh, ha-ha! You must be considering this question. And now, the last problem of this contest comes.
Give you all submitting data in the contest, and tell you the number of golden medals, silver medals and copper medals; your task is to output someone's contest result.
Easy? Of course! I t is the reason that I designed the problem.
When you have completed this contest, please remember that sentence〃 Accepted today?〃兒
Input
Input contains multiple test cases. Each test case starts with five numbers N (4 =< N <= 130 -- the total number of attendees), G, S, C (1<=G<=S<=C<N --G, S, C denoting the number of golden medals, silver medals and copper medals respectively) and M (0<M<=N). The next N lines contain an integer P (1<=P<=8 --number of problems that have been solved by someone) and a time T(for example,"02:45:17", meaning 2 hours and 45 minutes and 17 seconds consumed according to contest rules) each. You can assume that all submit data are different.
A test case starting with 0 0 0 0 0 terminates input and this test case should not to be processed.
Output
For each case, print a sentence in a line, and it must be one of these sentences:
Accepted today? I've got a golden medal :)
Accepted today? I've got a silver medal :)
Accepted today? I've got a copper medal :)
Accepted today? I've got an honor mentioned :)
Note:
You will get an honor mentioned if you can't get copper medal, silver medal or golden medal.
Sample Input
10 1 2 3 6
2 02:45:17
2 02:49:01
2 03:17:58
2 03:21:29
4 07:55:48
3 04:25:42
3 06:57:39
2 02:05:02
2 02:16:45
2 02:41:37
0 0 0 0 0
Sample Output
Accepted today? I've got a silver medal :)
Author
lcy
简单题就是求序号为m的那个得了什么奖牌,
代码:
#include<stdio.h>
#include<stdlib.h>
struct point{
int problem,time,index;
}map[150];
int cmp(const void *a,const void *b)
{
struct point *c,*d;
c=(struct point *)a;
d=(struct point *)b;
if(c->problem!=d->problem)
return d->problem-c->problem;
else return c->time-d->time;
}
int main()
{
int hour,minute,second,i,n,g,s,c,m;
while(scanf("%d%d%d%d%d",&n,&g,&s,&c,&m),n||g||s||c)
{
for(i=0;i<n;i++)
{
scanf("%d %d:%d:%d",&map[i].problem,&hour,&minute,&second);
map[i].time=hour*3600+minute*60+second;
map[i].index=i+1;
}
qsort(map,n,sizeof(map[0]),cmp);
for(i=0;i<n;i++)
if(map[i].index==m)break;
if(i>=0&&i<g)printf("Accepted today? I've got a golden medal :)\n");
else if(i>=g&&i<g+s)printf("Accepted today? I've got a silver medal :)\n");
else if(i>=g+s&&i<g+s+c)printf("Accepted today? I've got a copper medal :)\n");
else printf("Accepted today? I've got an honor mentioned :)\n");
}
return 0;
}
这篇关于ZZULI_SUMMER_PRACTICE(7)nbsp;1177nbsp;nbsp;quot;…的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!