本文主要是介绍折线分割平面 2050,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Problem Description
我们看到过很多直线分割平面的题目,今天的这个题目稍微有些变化,我们要求的是n条折线分割平面的最大数目。比如,一条折线可以将平面分成两部分,两条折线最多可以将平面分成7部分,具体如下所示。
Input
输入数据的第一行是一个整数C,表示测试实例的个数,然后是C 行数据,每行包含一个整数n(0<n<=10000),表示折线的数量。
Output
对于每个测试实例,请输出平面的最大分割数,每个实例的输出占一行。
Sample Input
2
1
2
Sample Output
2
7
#include <iostream>
int main(int argc, const char *argv[])
{
__int64 result[10000] = {2};
for(int i = 1;i < 10000;++ i)
{
result[i] = result[i - 1] + 4 * (i + 1) - 3;
}
int c = 0;
std::cin >> c;
while(c --)
{
int n = 0;
std::cin >> n;
std::cout << result[n - 1] << std::endl;
}
//system("pause");
return 0;
}
这篇关于折线分割平面 2050的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!