本文主要是介绍AcWing 829:模拟队列 ← 三种代码,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
【题目来源】
https://www.acwing.com/problem/content/831/
【题目描述】
实现一个队列,队列初始为空,支持四种操作:
1. push x – 向队尾插入一个数 x;
2. pop – 从队头弹出一个数;
3. empty – 判断队列是否为空;
4. query – 查询队头元素。
现在要对队列进行 M 个操作,其中的每个操作 3 和操作 4 都要输出相应的结果。
【输入格式】
第一行包含整数 M,表示操作次数。
接下来 M 行,每行包含一个操作命令,操作命令为 push x,pop,empty,query 中的一种。
【输出格式】
对于每个 empty 和 query 操作都要输出一个查询结果,每个结果占一行。
其中,empty 操作的查询结果为 YES 或 NO,query 操作的查询结果为一个整数,表示队头元素的值。
【数据范围】
1≤M≤100000,
1≤x≤10^9,
所有操作保证合法。
【输入样例】
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
【输出样例】
NO
6
YES
4
【利用 STL queue 实现队列的代码】
之前,在文章 https://blog.csdn.net/hnjzsyjyj/article/details/130522133 中介绍了利用多种方式模拟实现栈的相关操作。特别提到在算法竞赛中,会常用 STL stack 实现栈。相应地,在算法竞赛中,会常用 STL queue 实现队列,简洁且易理解。
STL queue的官方帮助文档详见:https://cplusplus.com/reference/queue/queue/
下面,给出一个利用 STL queue 实现本例中队列相应的代码。如下所示:
#include <bits/stdc++.h>
using namespace std;int main() {queue<int> q;int n;cin>>n;while(n--) {string op;int x;cin>>op;if(op=="push") {cin>>x;q.push(x);} else if(op=="pop") {q.pop();} else if(op=="empty") {if(!q.empty()) cout<<"NO"<<endl;else cout<<"YES"<<endl;} else {cout<<q.front()<<endl;}}return 0;
}/*
in:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6out:
NO
6
YES
4
*/
针对本文实例,在实践中,也常有利用数组模拟实现队列的需求。据此,根据队列的特点,引入整型变量 head 表示队首指针,tail 表示队尾指针,引入数组 q[] 表示顺序队列(假定本例中数组中的元素个数最多不超过100000个,也即用数组模拟的队列中的元素个数不超过100000个)。根据head=0、tail=0 及 head=0、tail=-1 的不同,下面分别给出了利用数组模拟实现队列的代码。
【head=0、tail=0 时,用数组模拟实现队列的代码】
简洁起见,下面代码中用 hh 代替 head,用 tt 代替 tail。
#include<bits/stdc++.h>
using namespace std;const int maxn=1e5+5;
int q[maxn];int main() {int n;cin>>n;int hh=0,tt=0;while(n--) {string op;int x;cin>>op;if(op=="push") {cin>>x;q[tt++]=x;} else if(op=="pop") {hh++;} else if(op=="empty") {if(hh<tt) cout<<"NO"<<endl;else cout<<"YES"<<endl;} else {cout<<q[hh]<<endl;}}return 0;
}/*
in:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6out:
NO
6
YES
4
*/
【head=0、tail=-1 时,用数组模拟实现队列的代码】
简洁起见,下面代码中用 hh 代替 head,用 tt 代替 tail。
#include<bits/stdc++.h>
using namespace std;const int maxn=1e5+5;
int q[maxn];int main() {int n;cin>>n;int hh=0,tt=-1;while(n--) {string op;int x;cin>>op;if(op=="push") {cin>>x;q[++tt]=x;} else if(op=="pop") {hh++;} else if(op=="empty") {if(hh<=tt) cout<<"NO"<<endl;else cout<<"YES"<<endl;} else {cout<<q[hh]<<endl;}}return 0;
}/*
in:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6out:
NO
6
YES
4
*/
【参考文献】
https://www.acwing.com/solution/content/19039/
https://blog.csdn.net/hnjzsyjyj/article/details/130522133
这篇关于AcWing 829:模拟队列 ← 三种代码的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!