哈希—— POJ 3349 Snowflake Snow Snowflakes

2024-09-05 04:08

本文主要是介绍哈希—— POJ 3349 Snowflake Snow Snowflakes,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

对应POJ题目:点击打开链接

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 33595 Accepted: 8811

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

题意:

一片雪花有6片叶子,给出n片雪花,以下每行6个数字,分别代表每片叶子长度,问是否存在有2片雪花形态是相同的。

形态相同的定义:如下图,2 3 4 5 6 1 和 4 5 6 1 2 3 和 3 2 1 6 5 4 都是形态相同的雪花,即是同一片雪花。

即是一片雪花可以从某一个数开始顺时针或逆时针数。


思路:

把一片雪花的所有长度相加 mod 一个大质数(100w左右)作为键值key,那就只有key相同的雪花才有可能是形态相同的。而key相同的雪花会映射到哈希表的同一个槽,那我们用链表把key值相同的在同一个槽连起来;只有key相等的时候就一个个比较key值那条链的雪花是否存在形态相同的,如果有就标记,以后就只是读入数据不比较;如果没有就把雪花加入链表。也可以采用开方性寻址的方法,思路是一样的。比较雪花形态是否相等要分顺时针和逆时针


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <map>
#include <iostream>
using namespace std;
#define N 100007
const int prime = 999983;typedef struct
{int key;int arm[7];
}Point;Point *slot[prime+10];bool Check(Point *p, Point *q) //p是新的,q是旧的
{int i, j;//顺时针for(j = 0; j < 6; j++){for(i = 0; i < 6; i++)if(q->arm[i] != p->arm[(i+j)%6]) break;if(6 == i) return true;}//逆时针for(j = 0; j < 6; j++){for(i = 0; i < 6; i++){if(q->arm[i] != p->arm[(12-i-j)%6]) break;}if(6 == i) return true;}return false;
}int Hash(int k)
{/*char s[20];sprintf(s, "%d", k);int i, h = 0, a = 232;for(i = 0; i < strlen(s); i++)h = (a * h + s[i] - '0') % prime;*/return (k<<2);
}bool Try_to_insert(Point *p)
{int k = p->key;if(NULL == slot[k]){ //有空槽slot[k] = p;return true;}while(slot[k]){if(Check(p, slot[k])) return false;k = (k + Hash(k)) % prime;}slot[k] = p;return true;
}int main()
{//freopen("in.txt","r",stdin);int i, j, n, flag = 0;Point *p;scanf("%d", &n);for(i = 0; i < n; i++){p = (Point *)malloc(sizeof(Point));p->key = 0;for(j = 0; j < 6; j++){scanf("%d", &p->arm[j]);p->key = (p->key + p->arm[j]) % prime;}if(flag) continue;if(!Try_to_insert(p)) flag = 1;}if(flag) printf("Twin snowflakes found.\n");else printf("No two snowflakes are alike.\n");return 0;
}





















这篇关于哈希—— POJ 3349 Snowflake Snow Snowflakes的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1137906

相关文章

哈希leetcode-1

目录 1前言 2.例题  2.1两数之和 2.2判断是否互为字符重排 2.3存在重复元素1 2.4存在重复元素2 2.5字母异位词分组 1前言 哈希表主要是适合于快速查找某个元素(O(1)) 当我们要频繁的查找某个元素,第一哈希表O(1),第二,二分O(log n) 一般可以分为语言自带的容器哈希和用数组模拟的简易哈希。 最简单的比如数组模拟字符存储,只要开26个c

usaco 1.3 Prime Cryptarithm(简单哈希表暴搜剪枝)

思路: 1. 用一个 hash[ ] 数组存放输入的数字,令 hash[ tmp ]=1 。 2. 一个自定义函数 check( ) ,检查各位是否为输入的数字。 3. 暴搜。第一行数从 100到999,第二行数从 10到99。 4. 剪枝。 代码: /*ID: who jayLANG: C++TASK: crypt1*/#include<stdio.h>bool h

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问