NEUOJ 1117: Ready to declare(单调队列)

2024-09-02 18:32

本文主要是介绍NEUOJ 1117: Ready to declare(单调队列),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

1117: Ready to declare

时间限制: 1 Sec   内存限制: 128 MB
提交: 358   解决: 41
[ 提交][ 状态][ 讨论版]

题目描述

Finally, you find the most good-looking girl...
You are going to write a letter to her. But you are not convident to be better than other boys. So you think you need a good chance...
You have known that these days, she will meet N boys at all(N<=100000). The ith boy has a handsome value V[i](0<V[i]<10000). She will meet K(K<=N) boys at the same time, and when the first boy leave, the next boy join them. It is to say that she will meet first K boys in the list at first, then the first boy leave ,the k+1-th boy join. So she will meet boys N-K+1 times.
You must want to join she and them when these boys are not handsome, so you need to calculate each meet's the least handsome value and the most.
here is a sample when N=8,K=3
boys                least     most
[5 3 2] 1 1 10 2 3 2 5
5 [3 2 1] 1 10 2 3 1 3
5 3 [2 1 1] 10 2 3 1 2
5 3 2 [1 1 10] 2 3 1 10
5 3 2 1 [1 10 2] 3 1 10
5 3 2 1 1 [10 2 3] 2 10

输入

There are several test cases, each case contains two lines.
The first line is two number ,N K.
The second line has N number, the handsome value.

输出

Each case output two lines.The first line is each meet's min handsome value, the second line is each meet's max handsome value.

样例输入

8 3
5 3 2 1 1 10 2 3

样例输出

2 1 1 1 1 2
5 3 2 10 10 10

提示

来源

2011.12



虽然正解是单调队列,可是我用的是两个栈实现的队列水过的,存下代码

/*************************************************************************> File Name: Euler.cpp> Author: acvcla> QQ: > Mail: acvcla@gmail.com > Created Time: 2014年10月30日 星期四 11时19分11秒************************************************************************/
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=1e5+5;
int stack1[maxn],stack2[maxn],max2[maxn],max1,min2[maxn],min1;
int top1,top2;
void init(){top1=top2=0;max1=max2[top2]=0;min1=min2[top2]=maxn;
}
int ans1[maxn],ans2[maxn];
void deque(){if(top2>0){stack2[--top2];return ;}while(top1>0){stack2[top2]=stack1[--top1];max2[top2]=max(top2>0?max2[top2-1]:0,stack2[top2]);min2[top2]=min(top2>0?min2[top2-1]:maxn,stack2[top2]);top2++;}max1=0;min1=maxn;--top2;
} 
int get_max_min(int x){if(x)return max(max1,top2>0?max2[top2-1]:0);return min(min1,top2>0?min2[top2-1]:maxn);
}
void push(int x){max1=max(x,max1);min1=min(x,min1);stack1[top1++]=x;
}
int main()
{int n,k,x;while(~scanf("%d%d",&n,&k)){init();int t=0,cnt=0;for(int i=1;i<=n;i++){scanf("%d",&x);push(x);++cnt;if(cnt==k){ans1[t]=get_max_min(0);//cout<<"sldl"<<endl;ans2[t++]=get_max_min(1);deque();cnt--;}}for(int i=0;i<t;i++)printf("%d%c",ans1[i],i==t-1?'\n':' ');for(int i=0;i<t;i++)printf("%d%c",ans2[i],i==t-1?'\n':' ');}return 0;
}



补上单调队列版

#include <cstdio>
#include <iostream>
using namespace std;
const int maxn =1e5 + 10;
struct Queue
{int value;int index;
};
Queue min_que[maxn],max_que[maxn];
int n,k,num[maxn],front,rear;
int delete_rear_inc(int f,int r,int d) 
{int mid;while(f<=r){mid=(f+r)/2;if(min_que[mid].value==d) return mid;if(min_que[mid].value>d) r=mid-1;else f=mid+1;}return f;
}
int delete_rear_dec(int f,int r,int d) 
{int mid;while(f<=r){mid=(f+r)/2;if(max_que[mid].value==d) return mid;if(max_que[mid].value>d) f=mid+1;else r=mid-1;}return f;
}
int main()
{while(~scanf("%d%d",&n,&k)){for(int i=1;i<=n;i++)scanf("%d",&num[i]);min_que[1].value=num[1];front=rear=min_que[1].index=1;for(int i=2;i<=k;i++) {rear=delete_rear_inc(front,rear,num[i]);min_que[rear].value=num[i];min_que[rear].index=i;}printf("%d",min_que[1].value);for(int i=k+1;i<=n;i++) {rear=delete_rear_inc(front,rear,num[i]);min_que[rear].value=num[i];min_que[rear].index=i;if(i-min_que[front].index>=k) front++;printf(" %d",min_que[front].value);if(i==n)puts("");}max_que[1].value=num[1];front=rear=max_que[1].index=1;for(int i=2;i<=k;i++) {rear=delete_rear_dec(front,rear,num[i]);max_que[rear].value=num[i];max_que[rear].index=i;}printf("%d",max_que[1].value);for(int i=k+1;i<=n;i++) {rear=delete_rear_dec(front,rear,num[i]);max_que[rear].value=num[i];max_que[rear].index=i;if(i-max_que[front].index>=k) front++;printf(" %d",max_que[front].value);if(i==n)puts("");}}return 0;
}


这篇关于NEUOJ 1117: Ready to declare(单调队列)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1130737

相关文章

hdu1180(广搜+优先队列)

此题要求最少到达目标点T的最短时间,所以我选择了广度优先搜索,并且要用到优先队列。 另外此题注意点较多,比如说可以在某个点停留,我wa了好多两次,就是因为忽略了这一点,然后参考了大神的思想,然后经过反复修改才AC的 这是我的代码 #include<iostream>#include<algorithm>#include<string>#include<stack>#include<

poj 3190 优先队列+贪心

题意: 有n头牛,分别给他们挤奶的时间。 然后每头牛挤奶的时候都要在一个stall里面,并且每个stall每次只能占用一头牛。 问最少需要多少个stall,并输出每头牛所在的stall。 e.g 样例: INPUT: 51 102 43 65 84 7 OUTPUT: 412324 HINT: Explanation of the s

poj 2431 poj 3253 优先队列的运用

poj 2431: 题意: 一条路起点为0, 终点为l。 卡车初始时在0点,并且有p升油,假设油箱无限大。 给n个加油站,每个加油站距离终点 l 距离为 x[i],可以加的油量为fuel[i]。 问最少加几次油可以到达终点,若不能到达,输出-1。 解析: 《挑战程序设计竞赛》: “在卡车开往终点的途中,只有在加油站才可以加油。但是,如果认为“在到达加油站i时,就获得了一

poj3750约瑟夫环,循环队列

Description 有N个小孩围成一圈,给他们从1开始依次编号,现指定从第W个开始报数,报到第S个时,该小孩出列,然后从下一个小孩开始报数,仍是报到S个出列,如此重复下去,直到所有的小孩都出列(总人数不足S个时将循环报数),求小孩出列的顺序。 Input 第一行输入小孩的人数N(N<=64) 接下来每行输入一个小孩的名字(人名不超过15个字符) 最后一行输入W,S (W < N),用

POJ2010 贪心优先队列

c头牛,需要选n头(奇数);学校总共有f的资金, 每头牛分数score和学费cost,问合法招生方案中,中间分数(即排名第(n+1)/2)最高的是多少。 n头牛按照先score后cost从小到大排序; 枚举中间score的牛,  预处理左边与右边的最小花费和。 预处理直接优先队列贪心 public class Main {public static voi

POJ1631最长单调递增子序列

最长单调递增子序列 import java.io.BufferedReader;import java.io.InputStream;import java.io.InputStreamReader;import java.io.PrintWriter;import java.math.BigInteger;import java.util.StringTokenizer;publ

Java并发编程之——BlockingQueue(队列)

一、什么是BlockingQueue BlockingQueue即阻塞队列,从阻塞这个词可以看出,在某些情况下对阻塞队列的访问可能会造成阻塞。被阻塞的情况主要有如下两种: 1. 当队列满了的时候进行入队列操作2. 当队列空了的时候进行出队列操作123 因此,当一个线程试图对一个已经满了的队列进行入队列操作时,它将会被阻塞,除非有另一个线程做了出队列操作;同样,当一个线程试图对一个空

FreeRTOS学习笔记(六)队列

提示:文章写完后,目录可以自动生成,如何生成可参考右边的帮助文档 文章目录 前言一、队列的基本内容1.1 队列的引入1.2 FreeRTOS 队列的功能与作用1.3 队列的结构体1.4 队列的使用流程 二、相关API详解2.1 xQueueCreate2.2 xQueueSend2.3 xQueueReceive2.4 xQueueSendFromISR2.5 xQueueRecei

多线程篇(阻塞队列- LinkedBlockingDeque)(持续更新迭代)

目录 一、LinkedBlockingDeque是什么 二、核心属性详解 三、核心方法详解 addFirst(E e) offerFirst(E e) putFirst(E e) removeFirst() pollFirst() takeFirst() 其他 四、总结 一、LinkedBlockingDeque是什么 首先queue是一种数据结构,一个集合中

Java消息队列:RabbitMQ与Kafka的集成与应用

Java消息队列:RabbitMQ与Kafka的集成与应用 大家好,我是微赚淘客返利系统3.0的小编,是个冬天不穿秋裤,天冷也要风度的程序猿! 在现代的分布式系统中,消息队列是实现系统间通信、解耦和提高可扩展性的重要组件。RabbitMQ和Kafka是两个广泛使用的消息队列系统,它们各有特点和优势。本文将介绍如何在Java应用中集成RabbitMQ和Kafka,并展示它们的应用场景。 消息队