2034人见人爱A-B

2024-09-02 11:58
文章标签 人见人爱 2034

本文主要是介绍2034人见人爱A-B,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

人见人爱A-B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41041    Accepted Submission(s): 11464


Problem Description
参加过上个月月赛的同学一定还记得其中的一个最简单的题目,就是{A}+{B},那个题目求的是两个集合的并集,今天我们这个A-B求的是两个集合的差,就是做集合的减法运算。(当然,大家都知道集合的定义,就是同一个集合中不会有两个相同的元素,这里还是提醒大家一下)

呵呵,很简单吧?

Input
每组输入数据占1行,每行数据的开始是2个整数n(0<=n<=100)和m(0<=m<=100),分别表示集合A和集合B的元素个数,然后紧跟着n+m个元素,前面n个元素属于集合A,其余的属于集合B. 每个元素为不超出int范围的整数,元素之间有一个空格隔开.
如果n=0并且m=0表示输入的结束,不做处理。

Output
针对每组数据输出一行数据,表示A-B的结果,如果结果为空集合,则输出“NULL”,否则从小到大输出结果,为了简化问题,每个元素后面跟一个空格.

Sample Input
    
3 3 1 2 3 1 4 7 3 7 2 5 8 2 3 4 5 6 7 8 0 0

Sample Output
    
2 3 NULL
#include<stdio.h>
#include<stdlib.h>
int cmp(const void *a,const void *b)
{
return *(int *)a-*(int *)b;
}
main()
{
int i,j,k,t,n,m,a[102],b[102],c[102],w;
while(scanf("%d%d",&n,&m)&&!(n==0&&m==0))
{
t=0;
w=0;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(j=0;j<m;j++)
scanf("%d",&b[j]);
i=0;
while(i<n)
{
k=0;
for(j=0;j<m;j++)
{
if(b[j]!=a[i])
k++;
else
t++;
}
if(k==m)
{
 c[w]=a[i];
 w++;
}
i++;
}
if(t==n)
printf("NULL\n");
else
{
qsort(c,w,sizeof(c[0]),cmp);
for(j=0;j<w;j++)
{
printf("%d ",c[j]);
}
printf("\n");
}
}
}

这篇关于2034人见人爱A-B的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1129887

相关文章

hdu2035--人见人爱A^B(快速幂函数)

B - 人见人爱A^B Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 2035   Description 求A^B的最后三位数表示的整数。 说明:A^B的含义是“A的B次方” Input 输入

hdu2034 人见人爱A-B(差集)

人见人爱A-B Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 39142    Accepted Submission(s): 10935 Problem Description 参加过上个月月赛的同学一定还记得其中

航电ACM [hdu 2035] 人见人爱A^B

人见人爱A^B Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20961    Accepted Submission(s): 14596 Problem Description 求A^B的最后三位数表示的整数。 说明:A^B

航电ACM [hdu 2033] 人见人爱A+B

人见人爱A+B Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23073    Accepted Submission(s): 15275 Problem Description HDOJ上面已经有10来道A+B的题目了,相信这

2035 ——人见人爱A^B

#include <iostream>using namespace std;int main(){int n,m; while(cin>>n>>m){ int c=1; if(n==0&&m==0)return 0;for(int i=0;i<m;i++){c=(n%1000*(c%1000))%1000;}cout<<c<<endl;}return 0;}

人见人爱A^BmodC的二分思想

人见人爱A^BmodC   计算A的B次幂对c取模(A^BmodC)并且1<=A,B,C<=32768. 输入三个整数A,B,C,输入文件每一行依次三个整数a,b,c用空格隔开 每行输出一个运算结果   Sample:   Input: 3 4 5 10 10 100 45 67 89 1 1 1   Output: 1 0 45 0 分析:主要用到乘方取模的

HDOJnbsp;nbsp;2034nbsp;nbsp;nbsp;人见人爱A-B

题目:http://acm.hdu.edu.cn/showproblem.php?pid=2034 #include<iostream> #include<algorithm> using namespace std; int main() {  int n,m;  while(cin>>n>>m&&!(n==0&&m==0))  {   int i,j,k=0,a[101],b[101],c[

HDOJnbsp;nbsp;2033nbsp;nbsp;nbsp;nbsp;人见人爱A+B

题目:http://acm.hdu.edu.cn/showproblem.php?pid=2033 时分秒相加,只要控制好进位就好,,,, #include <stdio.h> int main() {     int n,ah,am,as,bh,bm,bs,h,m,s;     scanf("%d",&n);     while(n--)     {         h=m=s=0;

poj 2034 Anti-prime Sequences

题意要求给定一个范围,然后指定一个区间d,使(2到d)的任意区间之和为合数即可。深搜枚举#include<stdio.h>#include<string.h>#include<iostream>using namespace std;int use[1001],prime[10001],vis[1001];int n,m,d,flag;bool dfs(int d,int th)

题目1076: 人见人爱 A ^ B

题目描述 求A^B的最后三位数表示的整数。说明:A^B的含义是“A的B次方” 输入 输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。 输出 对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。