本文主要是介绍poj 2594 Treasure Exploration(最小路径覆盖(可重点)+floyd),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Time Limit: 6000MS | Memory Limit: 65536K | |
Total Submissions: 6987 | Accepted: 2840 |
Description
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?
Input
Output
Sample Input
1 0
2 1
1 2
2 0
0 0
Sample Output
1
1
2
之前做的最小路径覆盖 两个人走的路径 不能有重复的点 而本题可以重复
如果一个人需要经过另一个人走过的点的时候 让他直接约过该点 直接到下一个点(通过floyd处理)
从而转化为无重点的最小路径覆盖 然后直接求结果就可以了
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)using namespace std;void read(int &x)
{char ch;x=0;while(ch=getchar(),ch!=' '&&ch!='\n'){x=x*10+ch-'0';}
}int n,m;
int mp[550][550];
int link[550];
int vis[550];
int ans;bool dfs(int u)
{for(int i=1;i<=n;i++){if(mp[u][i]&&!vis[i]){vis[i]=1;if(link[i]==-1||dfs(link[i])){link[i]=u;return 1;}}}return 0;
}void hungary()
{MEM(link,-1);for(int i=1;i<=n;i++){MEM(vis,0);if(dfs(i))ans++;}
}void floyd()
{for(int k=1;k<=n;k++){for(int i=1;i<=n;i++){for(int j=1;j<=n;j++){if(mp[i][k]&&mp[k][j])mp[i][j]=1;}}}
}int main()
{
// fread;while(scanf("%d%d",&n,&m)!=EOF){if(!n&&!m) break;MEM(mp,0);for(int i=0;i<m;i++){int u,v;scanf("%d%d",&u,&v);mp[u][v]=1;}floyd();ans=0;hungary();printf("%d\n",n-ans);}return 0;
}
这篇关于poj 2594 Treasure Exploration(最小路径覆盖(可重点)+floyd)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!