CUGB图论专场:D - Command Network(最小树形图:朱刘算法)

2024-06-08 23:58

本文主要是介绍CUGB图论专场:D - Command Network(最小树形图:朱刘算法),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

D - Command Network
Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy

参考芳哥和魏神的博客:http://blog.csdn.net/wsniyufang/article/details/6747392   和  http://blog.csdn.net/sdj222555/article/details/7459738。

思路:最小树形图,就是给有向带权图中指定一个特殊的点root,求一棵以root为根的有向生成树T,并且T中所有边的总权值最小。最小树形图的第一个算法是 1965年朱永津和刘振宏提出的复杂度为O(VE)的算法。

因为刚开始接触有向图的代码,所以看了一下午,理解了一下午才理解……不过收获也挺大的,继续默默努力吧……

自己的理解:刚开始自己并未理解最小树形图的概念,感觉和平常的生成树也没多大差别。不过深入研究以后确实差别挺大的。我们以前做的生成树是无向图,求的树是无环的,而这个最小树形图可以有环,解决的办法就是把环变成结点。但是如果把环变成结点的话,那边的权值就得改变了,不然求的树就不是原先的树了。设这个环中指向u的边权是in[u],那么对于每条从u出发的边(u, i, w),在新图中连接(new, i, w)的边,其中new为新加的人工顶点; 对于每条进入u的边(i, u, w),在新图中建立边(i, new, w-in[u])的边,即用w-in[u]更新边权值。还有一些理解有代码中会有注释!感觉如果把所有的环都变成结点以后,所求的最小树形图其实就是一条线把这些结点联结起来,求的就是这条线的最小值。

用到的思想及算法等:有向图的强连通分量,缩点法。

#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <deque>
#include <vector>
#include <list>
#include <queue>
#include <string>
#include <cstring>
#include <map>
#define PI acos(-1.0)
#define mem(a,b) memset(a,b,sizeof(a))
#define sca(a) scanf("%d",&a)
#define M 102
#define INF 10000000
using namespace std;
typedef long long ll;
struct Point
{double x,y;
}p[M];
struct node
{int u,v;   //边的两端结点double value;  //边权值
}e[M*M];
int pre[M],newnode[M],visit[M],n,m,i; //前向结点数组,新结点指向数组,访问数组
double in[M];   //边权值数组
double dist(Point a,Point b)  //坐标两点之间的距离
{return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double zhuliu(int root,int n1,int m1)
{double ans=0;   //因为把环删除后其边权值是当前和与原先和之和,所以得在循环外定义int u,v;while(1){//(1).找最小边放入集合for(i=0;i<n1;i++)in[i]=INF;for(i=0;i<m1;i++){u=e[i].u; v=e[i].v;if(e[i].value<in[v]&&u!=v){pre[v]=u;  //每次都找最小边进入集合,以达最优解in[v]=e[i].value;}}for(i=0;i<n1;i++)if(in[i]==INF&&i!=root) return -1; //除了根以外还有别的结点没有入边,则说明没有连通,无最小树形图//(2).找环,若有环,则生成新结点,强连通分量,即环int New=0; //新结点还是从0开始mem(newnode,-1);mem(visit,-1);in[root]=0;for(i=0;i<n1;i++)  //寻找每个结点是否有环{ans+=in[i]; v=i;while(visit[v]!=i&&newnode[v]==-1&&v!=root) //每个点寻找其前向点,要么最终寻找至根部,要么找到一个环{visit[v]=i;v=pre[v];}if(v!=root&&newnode[v]==-1)  //把环缩成一个点,缩点法{for(u=pre[v];u!=v;u=pre[u])newnode[u]=New;newnode[v]=New++;}}if(New==0) break;  //如果New无变化,当然就无环啦for(i=0;i<n1;i++)if(newnode[i]==-1) newnode[i]=New++;//(3).建立新图,即把环缩成点,然后指向和边权值也随之改变for(i=0;i<m1;i++){u=e[i].u; v=e[i].v;e[i].u=newnode[u];e[i].v=newnode[v];if(newnode[u]!=newnode[v]) e[i].value-=in[v]; //两个不同的结点之间的边权值改变}n1=New;root=newnode[root];  //结点更新之后,根结点可能有环而改变,所以根结点也要更新}return ans;
}
int main()
{double ans;while(~scanf("%d%d",&n,&m)){for(i=0;i<n;i++)scanf("%lf%lf",&p[i].x,&p[i].y);for(i=0;i<m;i++){scanf("%d%d", &e[i].u, &e[i].v);e[i].u--; e[i].v--; //结点从0开始if(e[i].u != e[i].v)e[i].value=dist(p[e[i].u],p[e[i].v]);else e[i].value=INF; //结点相同就是自环,则要去除自环}ans=zhuliu(0,n,m);if(ans==-1) printf("poor snoopy\n");else printf("%.2f\n", ans);}return 0;
}




这篇关于CUGB图论专场:D - Command Network(最小树形图:朱刘算法)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1043682

相关文章

不懂推荐算法也能设计推荐系统

本文以商业化应用推荐为例,告诉我们不懂推荐算法的产品,也能从产品侧出发, 设计出一款不错的推荐系统。 相信很多新手产品,看到算法二字,多是懵圈的。 什么排序算法、最短路径等都是相对传统的算法(注:传统是指科班出身的产品都会接触过)。但对于推荐算法,多数产品对着网上搜到的资源,都会无从下手。特别当某些推荐算法 和 “AI”扯上关系后,更是加大了理解的难度。 但,不了解推荐算法,就无法做推荐系

康拓展开(hash算法中会用到)

康拓展开是一个全排列到一个自然数的双射(也就是某个全排列与某个自然数一一对应) 公式: X=a[n]*(n-1)!+a[n-1]*(n-2)!+...+a[i]*(i-1)!+...+a[1]*0! 其中,a[i]为整数,并且0<=a[i]<i,1<=i<=n。(a[i]在不同应用中的含义不同); 典型应用: 计算当前排列在所有由小到大全排列中的顺序,也就是说求当前排列是第

csu 1446 Problem J Modified LCS (扩展欧几里得算法的简单应用)

这是一道扩展欧几里得算法的简单应用题,这题是在湖南多校训练赛中队友ac的一道题,在比赛之后请教了队友,然后自己把它a掉 这也是自己独自做扩展欧几里得算法的题目 题意:把题意转变下就变成了:求d1*x - d2*y = f2 - f1的解,很明显用exgcd来解 下面介绍一下exgcd的一些知识点:求ax + by = c的解 一、首先求ax + by = gcd(a,b)的解 这个

综合安防管理平台LntonAIServer视频监控汇聚抖动检测算法优势

LntonAIServer视频质量诊断功能中的抖动检测是一个专门针对视频稳定性进行分析的功能。抖动通常是指视频帧之间的不必要运动,这种运动可能是由于摄像机的移动、传输中的错误或编解码问题导致的。抖动检测对于确保视频内容的平滑性和观看体验至关重要。 优势 1. 提高图像质量 - 清晰度提升:减少抖动,提高图像的清晰度和细节表现力,使得监控画面更加真实可信。 - 细节增强:在低光条件下,抖

【数据结构】——原来排序算法搞懂这些就行,轻松拿捏

前言:快速排序的实现最重要的是找基准值,下面让我们来了解如何实现找基准值 基准值的注释:在快排的过程中,每一次我们要取一个元素作为枢纽值,以这个数字来将序列划分为两部分。 在此我们采用三数取中法,也就是取左端、中间、右端三个数,然后进行排序,将中间数作为枢纽值。 快速排序实现主框架: //快速排序 void QuickSort(int* arr, int left, int rig

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

秋招最新大模型算法面试,熬夜都要肝完它

💥大家在面试大模型LLM这个板块的时候,不知道面试完会不会复盘、总结,做笔记的习惯,这份大模型算法岗面试八股笔记也帮助不少人拿到过offer ✨对于面试大模型算法工程师会有一定的帮助,都附有完整答案,熬夜也要看完,祝大家一臂之力 这份《大模型算法工程师面试题》已经上传CSDN,还有完整版的大模型 AI 学习资料,朋友们如果需要可以微信扫描下方CSDN官方认证二维码免费领取【保证100%免费