HDU 1242 Rescue营救 BFS算法

2024-06-08 10:48
文章标签 算法 bfs hdu 1242 rescue 营救

本文主要是介绍HDU 1242 Rescue营救 BFS算法,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目链接:HDU 1242 Rescue营救

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16524    Accepted Submission(s): 5997


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

Sample Input
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........

Sample Output
  
13

Author
CHEN, Xue

Source
ZOJ Monthly, October 2003

题意:

Angel被关在一个监狱中,监狱可有N*M的矩阵表示,每个方格中可能有墙壁(#)、道路(.)、警卫(x)、Angel(a)和Angel的朋友(r)。Angel的朋友想到达Angel处,要么走道路,需要1的时间,要么走到警卫的格子,还需要多1的时间杀死警卫才能通行。现在需要求到达Angel处的最短时间。

分析:

求最短时间一般都用BFS搜索,但是这道题条件较多,需要酌情考虑。并不是步数最少就最好,因为杀死警卫还需要额外的时间。可以新建一个结构体point,表示当前位置和已经使用的时间。再申请一个数组mintime[][],表示走到某一格的最短时间。将可行的当前位置压入队列并持续更新mintime数组。找到Angel所在位置的mintime。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;#define INF 0xffffff
char mp[202][202];
int n, m, mintime[202][202];
int dir[4][2] = {{-1, 0},{0, 1},{1, 0},{0, -1}};struct point
{int x, y, time;
};
void bfs(point s)
{queue<point> q;q.push(s);while(!q.empty()){point cp = q.front();q.pop();for(int i = 0; i < 4; i++){int tx = cp.x + dir[i][0];int ty = cp.y + dir[i][1];if(tx >= 1 && tx <= n && ty >= 1 && ty <= m && mp[tx][ty] != '#'){point t;t.x = tx;t.y = ty;t.time = cp.time+1;if(mp[tx][ty] == 'x')t.time++;if(t.time < mintime[tx][ty]){mintime[tx][ty] = t.time;q.push(t);}}}}
}
int main()
{char c;int ax, ay;point st;while(~scanf("%d%d", &n, &m)){scanf("%c", &c);for(int i = 1; i <= n; i++){for(int j = 1; j <= m; j++){scanf("%c", &mp[i][j]);mintime[i][j] = INF;if(mp[i][j] == 'a'){ax = i;ay = j;}else if(mp[i][j] == 'r'){st.x = i;st.y = j;st.time = 0;}}scanf("%c", &c);}mintime[st.x][st.y] = 0;bfs(st);if(mintime[ax][ay] < INF)printf("%d\n", mintime[ax][ay]);elseprintf("Poor ANGEL has to stay in the prison all his life.\n");}return 0;
}






这篇关于HDU 1242 Rescue营救 BFS算法的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1041974

相关文章

不懂推荐算法也能设计推荐系统

本文以商业化应用推荐为例,告诉我们不懂推荐算法的产品,也能从产品侧出发, 设计出一款不错的推荐系统。 相信很多新手产品,看到算法二字,多是懵圈的。 什么排序算法、最短路径等都是相对传统的算法(注:传统是指科班出身的产品都会接触过)。但对于推荐算法,多数产品对着网上搜到的资源,都会无从下手。特别当某些推荐算法 和 “AI”扯上关系后,更是加大了理解的难度。 但,不了解推荐算法,就无法做推荐系

hdu1254(嵌套bfs,两次bfs)

/*第一次做这种题感觉很有压力,思路还是有点混乱,总是wa,改了好多次才ac的思路:把箱子的移动当做第一层bfs,队列节点要用到当前箱子坐标(x,y),走的次数step,当前人的weizhi(man_x,man_y),要判断人能否将箱子推到某点时要嵌套第二层bfs(人的移动);代码如下:

康拓展开(hash算法中会用到)

康拓展开是一个全排列到一个自然数的双射(也就是某个全排列与某个自然数一一对应) 公式: X=a[n]*(n-1)!+a[n-1]*(n-2)!+...+a[i]*(i-1)!+...+a[1]*0! 其中,a[i]为整数,并且0<=a[i]<i,1<=i<=n。(a[i]在不同应用中的含义不同); 典型应用: 计算当前排列在所有由小到大全排列中的顺序,也就是说求当前排列是第

csu 1446 Problem J Modified LCS (扩展欧几里得算法的简单应用)

这是一道扩展欧几里得算法的简单应用题,这题是在湖南多校训练赛中队友ac的一道题,在比赛之后请教了队友,然后自己把它a掉 这也是自己独自做扩展欧几里得算法的题目 题意:把题意转变下就变成了:求d1*x - d2*y = f2 - f1的解,很明显用exgcd来解 下面介绍一下exgcd的一些知识点:求ax + by = c的解 一、首先求ax + by = gcd(a,b)的解 这个

综合安防管理平台LntonAIServer视频监控汇聚抖动检测算法优势

LntonAIServer视频质量诊断功能中的抖动检测是一个专门针对视频稳定性进行分析的功能。抖动通常是指视频帧之间的不必要运动,这种运动可能是由于摄像机的移动、传输中的错误或编解码问题导致的。抖动检测对于确保视频内容的平滑性和观看体验至关重要。 优势 1. 提高图像质量 - 清晰度提升:减少抖动,提高图像的清晰度和细节表现力,使得监控画面更加真实可信。 - 细节增强:在低光条件下,抖

【数据结构】——原来排序算法搞懂这些就行,轻松拿捏

前言:快速排序的实现最重要的是找基准值,下面让我们来了解如何实现找基准值 基准值的注释:在快排的过程中,每一次我们要取一个元素作为枢纽值,以这个数字来将序列划分为两部分。 在此我们采用三数取中法,也就是取左端、中间、右端三个数,然后进行排序,将中间数作为枢纽值。 快速排序实现主框架: //快速排序 void QuickSort(int* arr, int left, int rig

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s