本文主要是介绍HDU 1284 钱币兑换问题 母函数、DP,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目链接:HDU 1284 钱币兑换问题
钱币兑换问题
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5467 Accepted Submission(s): 3123
Problem Description
在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法。
Input
每行只有一个正整数N,N小于32768。
Output
对应每个输入,输出兑换方法数。
Sample Input
2934 12553
Sample Output
718831 13137761
Author
SmallBeer(CML)
Source
杭电ACM集训队训练赛(VII)
Recommend
lcy | We have carefully selected several similar problems for you: 2159 1248 1203 1231 1249
思路1:母函数思想,求系数
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;#define maxn 32770
int n, c1[maxn], c2[maxn];
void Init()
{for(int i = 0; i <= maxn; i++){c1[i] = 1;c2[i] = 0;}for(int i = 2; i <= 3; i++){for(int j = 0; j <= maxn; j++)for(int k = 0; k+j <= maxn; k+=i)c2[j+k] += c1[j];for(int j = 0; j <= maxn; j++){c1[j] = c2[j];c2[j] = 0;}}
}
int main()
{Init();while(~scanf("%d", &n))printf("%d\n", c1[n]);return 0;
}
代码:
#include <iostream>
#include <cstdio>
using namespace std;#define maxn 32770
int n, dp[maxn];
void Init()
{dp[0] = 1;for(int i = 1; i <= 3; i++)for(int j = i; j <= maxn; j++)dp[j] += dp[j-i];
}
int main()
{Init();while(~scanf("%d", &n))printf("%d\n", dp[n]);return 0;
}
这篇关于HDU 1284 钱币兑换问题 母函数、DP的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!