本文主要是介绍还是最短路径(接前面最短路径),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
/*题目1162:I Wanna Go Home
题目描述:
The country is facing a terrible civil war----cities in the country are divided into two parts supporting different leaders. As a merchant, Mr. M does not pay attention to politics but he actually knows the severe situation, and your task is to help him reach home as soon as possible.
"For the sake of safety,", said Mr.M, "your route should contain at most 1 road which connects two cities of different camp."
Would you please tell Mr. M at least how long will it take to reach his sweet home?
输入:
The input contains multiple test cases.
The first line of each case is an integer N (2<=N<=600), representing the number of cities in the country.
The second line contains one integer M (0<=M<=10000), which is the number of roads.
The following M lines are the information of the roads. Each line contains three integers A, B and T, which means the road between city A and city B will cost time T. T is in the range of [1,500].
Next part contains N integers, which are either 1 or 2. The i-th integer shows the supporting leader of city i.
To simplify the problem, we assume that Mr. M starts from city 1 and his target is city 2. City 1 always supports leader 1 while city 2 is at the same side of leader 2.
Note that all roads are bidirectional and there is at most 1 road between two cities.
Input is ended with a case of N=0.
输出:
For each test case, output one integer representing the minimum time to reach home.
If it is impossible to reach home according to Mr. M's demands, output -1 instead.
样例输入:
2
1
1 2 100
1 2
3
3
1 2 100
1 3 40
2 3 50
1 2 1
5
5
3 1 200
5 3 150
2 5 160
4 3 170
4 2 170
1 2 2 2 1
0
样例输出:
100
90
540
*/
#include <stdio.h>
#include <vector>
using namespace std;
struct E{
int next;
int time;
};
vector<E> edge[601];
bool mark[601];
int dis[601];
int main(){
int n,m,i,j;
while(scanf("%d",&n)!=EOF&&n!=0){
scanf("%d",&m);
for(i=1;i<=n;i++) edge[i].clear();
while(m--){
int a,b,time;
scanf("%d%d%d",&a,&b,&time);
E tmp;
tmp.time =time;
tmp.next =b;
edge[a].push_back(tmp);
tmp.next =a;
edge[b].push_back(tmp);
}
int num[601];
for(i=1;i<=n;i++)
scanf("%d",&num[i]);
for(i=1;i<=n;i++){//改动部分
if(num[i]==2){
for(j=0;j<edge[i].size();j++){
if(num[edge[i][j].next]==1)
edge[i][j].time=0;
}
}
}
for(i=1;i<=n;i++){
dis[i]=-1;
mark[i]=false;
}
dis[1]=0;
mark[1]=true;
int newp=1;
for(i=1;i<n;i++){
for(j=0;j<edge[newp].size();j++){
int t=edge[newp][j].next;
int time=edge[newp][j].time;
if(mark[t]==true) continue;
if(time==0) continue;//改动部分
if(dis[t]==-1||dis[t]>dis[newp]+time)
dis[t]=dis[newp]+time;
}
int min=11111111;
for(j=1;j<=n;j++){
if(mark[j]==true) continue;
if(dis[j]==-1) continue;
if(dis[j]<min) {
min=dis[j];
newp=j;
}
}
mark[newp]=true;
}
printf("%d\n",dis[2]);
}
return 0;
}
这篇关于还是最短路径(接前面最短路径)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!