本文主要是介绍hdu 1018 big number (有个组合公式),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
因为有个组合公式 所以转了,再慢慢领悟。
因为有个组合公式 所以转了,再慢慢领悟。
Big Number
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6291 Accepted Submission(s): 2836
Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
2 10 20
Sample Output
7 19
题意就是求一个数阶乘的位数!
#include <stdio.h>
#include <math.h>
void main()
{int count,var,j;double sum;scanf("%d",&count);while(count--){sum=0;scanf("%d",&var);for(j=1;j<=var;j++)sum+=log10(j);printf("%d\n",(int)sum+1);}
}
这是最简单的方法,但是耗时长,406ms。
好吧!我们换个方法:
这需要组合数学的知识。log10(n!) = log10(sqrt(2 * pi * n)) + n * log10(n / e)
Problem ID: 1018
Problem Title:
Run result: Accept
Run time:0MS
Run memory:332KB
//System Comment End//
#include <iostream>
#include <cmath>
#define PI 3.14159265
int n;
int num,ans;
void solve()
{double t;int i;t = (num*log(num) - num + 0.5*log(2*num*PI))/log(10);ans = t+1;printf("%d\n",ans);
}
int main()
{while(scanf("%d",&n)!=EOF){while(n--){scanf("%d",&num);solve();}}return 0;
}
这篇关于hdu 1018 big number (有个组合公式)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!