本文主要是介绍How Many Maos Does the Guanxi Worth HDU - 5137(最短路),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
“Guanxi” is a very important word in Chinese. It kind of means “relationship” or “contact”. Guanxi can be based on friendship, but also can be built on money. So Chinese often say “I don’t have one mao (0.1 RMB) guanxi with you.” or “The guanxi between them is naked money guanxi.” It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.
Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu’s guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A “big money” means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net – it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help … If the request finally reaches the schoolmaster, Boss Liu’s kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.
You hate Boss Liu and you want to undermine Boss Liu’s plan. All you can do is to persuade ONE person in Boss Liu’s guanxi net to reject any request. This person can be any one, but can’t be Boss Liu or the schoolmaster. If you can’t make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
Input
There are several test cases.
For each test case:
The first line contains two integers N and M. N means that there are N people in Boss Liu’s guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu’s guanxi net. (3 <=N <= 30, 3 <= M <= 1000)
Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.
The input ends with N = 0 and M = 0.
It’s guaranteed that Boss Liu’s request can reach the schoolmaster if you do not try to undermine his plan.
Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print “Inf” instead.
Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0
Sample Output
50
In
每日一水~~
题意: 一张无向图。花费为起点到终点的最小路。求选择删掉一个点使得花费最大
思路: 数据范围30,直接floyd或者dij跑。
#include <cstdio>
#include <cstring>
#include <algorithm>using namespace std;typedef long long ll;const int maxn = 35;
const int INF = 0x3f3f3f3f;
int tmp[35];
int d[maxn][maxn],tmp_d[maxn][maxn];
int n,m;void cal(int x)
{for(int i = 1;i <= n;i++){tmp[i] = d[x][i];d[x][i] = d[i][x] = INF;}
}void recover(int x)
{for(int i = 1;i <= n;i++){d[x][i] = d[i][x] = tmp[i];}
}int floyd()
{memcpy(tmp_d,d,sizeof(d));for(int k = 1;k <= n;k++){for(int i = 1;i <= n;i++){for(int j = 1;j <= n;j++){tmp_d[i][j] = min(tmp_d[i][j],tmp_d[i][k] + tmp_d[k][j]);}}}return tmp_d[1][n];
}int main()
{while(~scanf("%d%d",&n,&m) && (n || m)){memset(d,INF,sizeof(d));for(int i = 1;i <= m;i++){int a,b,c;scanf("%d%d%d",&a,&b,&c);d[a][b] = d[b][a] = c;}int ans = 0;for(int i = 2;i < n;i++){cal(i);int tmp_ans = floyd();ans = max(ans,tmp_ans);recover(i);}if(ans < INF)printf("%d\n",ans);else printf("Inf\n");}return 0;
}
这篇关于How Many Maos Does the Guanxi Worth HDU - 5137(最短路)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!