2019CCPC湘潭邀请赛 Chika and Friendly Pairs(莫队+树状数组)

2024-04-16 01:18

本文主要是介绍2019CCPC湘潭邀请赛 Chika and Friendly Pairs(莫队+树状数组),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Problem Description
Chika gives you an integer sequence a1,a2,…,an and m tasks. For each task, you need to answer the number of “friendly pairs” in a given interval.

friendly pair: for two integers ai and aj, if i<j and the absolute value of ai−aj is no more than a given constant integer K, then (i,j) is called a “friendly pair”.A friendly pair (i,j) in a interval [L,R] should satisfy L≤i<j≤R.

Input
The first line contains 3 integers n (1≤n≤27000), m (1≤m≤27000) and K (1≤K≤109), representing the number of integers in the sequence a, the number of tasks and the given constant integer.
The second line contains n non-negative integers, representing the integers in the sequence a. Every integer of sequence a is no more than 109.
Then m lines follow, each of which contains two integers L, R (1≤L≤R≤n). The meaning is to ask the number of “friendly pairs” in the interval [L,R]。

Output
For each task, you need to print one line, including only one integer, representing the number of “friendly pairs” in the query interval.

Sample Input
7 5 3
2 5 7 5 1 5 6
6 6
1 3
4 6
2 4
3 4

Sample Output
0
2
1
3
1

Source
2019CCPC湖南全国邀请赛(广东省赛、江苏省赛)重现赛

题意: 询问某个区间内差值不大于k的数对数目。
思路:
莫队算法就是双指针加排序,通过分块,按块排序,块内排右指针。
由此在块的内部相邻左端点变化最大为 n \sqrt n n ,而右端点是单调的,可以不计。
那么m次询问均摊下来最大 m n m\sqrt n mn ,观察n和m的范围,越为3e4,莫队可行!

我们用双指针维护到当前询问区间,区间变化对答案的影响可以用树状数组记录。
这类似与逆序对,你求与x差距不大于k的数,就是 s u m ( x + k ) − s u m ( x − k − 1 ) sum(x + k) - sum(x - k - 1) sum(x+k)sum(xk1)
当然,数字很大,再离散化一遍就好了。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>using namespace std;const int maxn = 1e5 + 7;struct Query {int l,r,id;
}q[maxn];int a[maxn];
int t[maxn],tot,cnt,sqr;
int L,R,num,ans[maxn];
int mp[maxn][2];
int c[maxn];void init() {sort(t + 1,t + 1 + tot);cnt = unique(t + 1,t + 1 + tot) - t - 1;
}int Find(int x) {return lower_bound(t + 1,t + 1 + cnt,x) - t;
}int cmp(Query a,Query b) {return a.l / sqr == b.l / sqr ? a.r < b.r : a.l < b.l;
}void add(int x,int v) {while(x < maxn) {c[x] += v;x += x & (-x);}
}int sum(int x) {int res = 0;while(x) {res += c[x];x -= x & (-x);}return res;
}void Add(int x) {num += sum(mp[a[x]][1]) - sum(mp[a[x]][0]);add(a[x],1);
}void Del(int x) {add(a[x],-1);num -= sum(mp[a[x]][1]) - sum(mp[a[x]][0]);
}int main() {int n,m,k;scanf("%d%d%d",&n,&m,&k);for(int i = 1;i <= n;i++) {scanf("%d",&a[i]);t[++tot] = a[i];t[++tot] = a[i] - k - 1;t[++tot] = a[i] + k;}init();for(int i = 1;i <= m;i++) {scanf("%d%d",&q[i].l,&q[i].r);q[i].id = i;}for(int i = 1;i <= n;i++) {int now = Find(a[i]);mp[now][0] = Find(a[i] - k - 1);mp[now][1] = Find(a[i] + k);a[i] = now;}sqr = sqrt(n);sort(q + 1,q + 1 + m,cmp);L = 1,R = 0;for(int i = 1;i <= m;i++) {int l = q[i].l,r = q[i].r;int id = q[i].id;while(L < l) {Del(L++);}while(L > l) {Add(--L);}while(R < r) {Add(++R);}while(R > r) {Del(R--);}ans[id] = num;}for(int i = 1;i <= m;i++) {printf("%d\n",ans[i]);}return 0;
}

这篇关于2019CCPC湘潭邀请赛 Chika and Friendly Pairs(莫队+树状数组)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/907434

相关文章

C++原地删除有序数组重复项的N种方法

《C++原地删除有序数组重复项的N种方法》给定一个排序数组,你需要在原地删除重复出现的元素,使得每个元素只出现一次,返回移除后数组的新长度,不要使用额外的数组空间,你必须在原地修改输入数组并在使用O(... 目录一、问题二、问题分析三、算法实现四、问题变体:最多保留两次五、分析和代码实现5.1、问题分析5.

Java中数组转换为列表的两种实现方式(超简单)

《Java中数组转换为列表的两种实现方式(超简单)》本文介绍了在Java中将数组转换为列表的两种常见方法使用Arrays.asList和Java8的StreamAPI,Arrays.asList方法简... 目录1. 使用Java Collections框架(Arrays.asList)1.1 示例代码1.

C++一个数组赋值给另一个数组方式

《C++一个数组赋值给另一个数组方式》文章介绍了三种在C++中将一个数组赋值给另一个数组的方法:使用循环逐个元素赋值、使用标准库函数std::copy或std::memcpy以及使用标准库容器,每种方... 目录C++一个数组赋值给另一个数组循环遍历赋值使用标准库中的函数 std::copy 或 std::

C++初始化数组的几种常见方法(简单易懂)

《C++初始化数组的几种常见方法(简单易懂)》本文介绍了C++中数组的初始化方法,包括一维数组和二维数组的初始化,以及用new动态初始化数组,在C++11及以上版本中,还提供了使用std::array... 目录1、初始化一维数组1.1、使用列表初始化(推荐方式)1.2、初始化部分列表1.3、使用std::

C++ Primer 多维数组的使用

《C++Primer多维数组的使用》本文主要介绍了多维数组在C++语言中的定义、初始化、下标引用以及使用范围for语句处理多维数组的方法,具有一定的参考价值,感兴趣的可以了解一下... 目录多维数组多维数组的初始化多维数组的下标引用使用范围for语句处理多维数组指针和多维数组多维数组严格来说,C++语言没

Java 字符数组转字符串的常用方法

《Java字符数组转字符串的常用方法》文章总结了在Java中将字符数组转换为字符串的几种常用方法,包括使用String构造函数、String.valueOf()方法、StringBuilder以及A... 目录1. 使用String构造函数1.1 基本转换方法1.2 注意事项2. 使用String.valu

JAVA中整型数组、字符串数组、整型数和字符串 的创建与转换的方法

《JAVA中整型数组、字符串数组、整型数和字符串的创建与转换的方法》本文介绍了Java中字符串、字符数组和整型数组的创建方法,以及它们之间的转换方法,还详细讲解了字符串中的一些常用方法,如index... 目录一、字符串、字符数组和整型数组的创建1、字符串的创建方法1.1 通过引用字符数组来创建字符串1.2

vue如何监听对象或者数组某个属性的变化详解

《vue如何监听对象或者数组某个属性的变化详解》这篇文章主要给大家介绍了关于vue如何监听对象或者数组某个属性的变化,在Vue.js中可以通过watch监听属性变化并动态修改其他属性的值,watch通... 目录前言用watch监听深度监听使用计算属性watch和计算属性的区别在vue 3中使用watchE

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while