本文主要是介绍HDU - 2680 Choose the best route(Bellman-Ford),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2680
Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
Sample Input
5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1
Sample Output
1
-1
注意!该题的路径是单向的,要从终点开始找到各点的距离还需要把方向倒转一下。
Bellman-Ford算法可以不用判断重边直接使用即可
#include<cstdio>
#include<vector>
using namespace std;
typedef pair<int, int> PII;
const int inf = 0x3f3f3f3f;
const int maxm = 20000 + 5;
int n, m, s, dis[1005];
struct edge {int u, v, w;
}e[maxm];int main(void) {while (~scanf("%d %d %d", &n, &m, &s)) {int cnt = 0;while (m--) {int a, b, c;scanf("%d %d %d", &a, &b, &c);e[cnt].u = b, e[cnt].v = a, e[cnt++].w = c;}//Bellman-Fordfor (int i = 1; i <= n; i++)dis[i] = inf;dis[s] = 0;bool update = true;while (update) {update = false;for (int i = 0; i < cnt; i++) {int u = e[i].u, v = e[i].v;if (dis[v] > dis[u] + e[i].w) {update = true;dis[v] = dis[u] + e[i].w;}}}int Q, ans = inf;scanf("%d", &Q);while (Q--) {int t; scanf("%d", &t);if (dis[t] < ans)ans = dis[t];}if (ans == inf)printf("-1\n");else printf("%d\n", ans);}return 0;
}
这篇关于HDU - 2680 Choose the best route(Bellman-Ford)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!