【PAT】1072. Gas Station (30)【dijkstra算法】

2024-04-12 06:18

本文主要是介绍【PAT】1072. Gas Station (30)【dijkstra算法】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

翻译:一个加油站需要建在任何住宅都尽可能的远的地方。但是必须保证所有房子都在其服务范围内。
现在给你城市的地图和几个申请的加油站位置,你需要给出最佳推荐位置。如果有超过一个答案,则输出到所有房子平均距离最近的位置。如果这样的距离不一定唯一,输出编号最小的位置。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括4个正整数:N(<=10^3),房子的总数;M(<=10),加油站可能选择的位置数;K,(<=10^4),连接房子和加油站的道路数;和Ds,加油站的最远服务距离。假设所有房子都被编号为1-N,所有可能的选址位置被编号为G1到GM。
接着K行每行按照以下格式描述一条路:
P1 P2 Dist
P1和P2代表道路两端,可能是民居或是加油站位置;Distinct代表路的整数距离。

OUTPUT FORMAT

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

翻译:对于每组输入数据,输出一行最佳位置的编号。第二行输出民居最近距离和到所有民居的平均距离。一行内数字之间必须用空格隔开,并且保留1位小数。如果结果不存在,则输出“No Solution”即可。


Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3


Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution


解题思路

这道题是一道标准dijkstra模板题,主要就是模拟题目说明,把Gi转换成数字,我是让Gi在前面,民居在后面。注意这道题的条件为先取最近民居距离最远的,否则取平均距离最短的,否则取编号最小的,真的一不注意就会看错。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,M,K,Dot,Ds;
double Min=0.0,Sum=INF,Ave=0.0;
int Des=0; 
struct Edge{int length,to;Edge(int l,int t):length(l),to(t){}bool operator<(const Edge &a)const{return length>a.length;}
};
vector<Edge> v[1020];
priority_queue<Edge> q;
int Judge(char s[]){int length=strlen(s),num=0;for(int i=0;i<length;i++){if(s[i]=='G')continue;if(s[i]>='0'&&s[i]<='9'){num=num*10+s[i]-'0';    }}if(s[0]!='G')num+=M;return num;
}
int d[1020];
void dijkstra(int s){for(int i=0;i<=Dot;i++)d[i]=INF;d[s]=0;q.push(Edge(0,s));double sum=0,Lmin=INF;while(!q.empty()){Edge temp=q.top();q.pop();int t=temp.to;if(d[t]<temp.length)continue;if(t>M&&Lmin>temp.length)Lmin=temp.length;for(int i=0;i<v[t].size();i++){Edge e=v[t][i];if(d[e.to]>d[t]+e.length){d[e.to]=d[t]+e.length; q.push(Edge(d[e.to],e.to));}}}for(int i=M+1;i<=Dot;i++){if(d[i]>Ds)return ;else sum+=d[i];}if(Min<Lmin||(Min==Lmin&&Sum>sum)){Sum=sum;Ave=Sum*1.0/N;Des=s;Min=Lmin;}
}
int main(){scanf("%d%d%d%d",&N,&M,&K,&Ds);char a[5],b[5];int l;for(int i=0;i<K;i++){scanf("\n%s%s%d",a,b,&l);int n1=Judge(a);int n2=Judge(b);v[n1].push_back(Edge(l,n2));v[n2].push_back(Edge(l,n1)); }Dot=N+M;for(int i=1;i<=M;i++){dijkstra(i);}if(Des==0)printf("No Solution\n");else printf("G%d\n%.1lf %.1lf\n",Des,Min,Ave);return 0;
}

这篇关于【PAT】1072. Gas Station (30)【dijkstra算法】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/896330

相关文章

不懂推荐算法也能设计推荐系统

本文以商业化应用推荐为例,告诉我们不懂推荐算法的产品,也能从产品侧出发, 设计出一款不错的推荐系统。 相信很多新手产品,看到算法二字,多是懵圈的。 什么排序算法、最短路径等都是相对传统的算法(注:传统是指科班出身的产品都会接触过)。但对于推荐算法,多数产品对着网上搜到的资源,都会无从下手。特别当某些推荐算法 和 “AI”扯上关系后,更是加大了理解的难度。 但,不了解推荐算法,就无法做推荐系

康拓展开(hash算法中会用到)

康拓展开是一个全排列到一个自然数的双射(也就是某个全排列与某个自然数一一对应) 公式: X=a[n]*(n-1)!+a[n-1]*(n-2)!+...+a[i]*(i-1)!+...+a[1]*0! 其中,a[i]为整数,并且0<=a[i]<i,1<=i<=n。(a[i]在不同应用中的含义不同); 典型应用: 计算当前排列在所有由小到大全排列中的顺序,也就是说求当前排列是第

csu 1446 Problem J Modified LCS (扩展欧几里得算法的简单应用)

这是一道扩展欧几里得算法的简单应用题,这题是在湖南多校训练赛中队友ac的一道题,在比赛之后请教了队友,然后自己把它a掉 这也是自己独自做扩展欧几里得算法的题目 题意:把题意转变下就变成了:求d1*x - d2*y = f2 - f1的解,很明显用exgcd来解 下面介绍一下exgcd的一些知识点:求ax + by = c的解 一、首先求ax + by = gcd(a,b)的解 这个

综合安防管理平台LntonAIServer视频监控汇聚抖动检测算法优势

LntonAIServer视频质量诊断功能中的抖动检测是一个专门针对视频稳定性进行分析的功能。抖动通常是指视频帧之间的不必要运动,这种运动可能是由于摄像机的移动、传输中的错误或编解码问题导致的。抖动检测对于确保视频内容的平滑性和观看体验至关重要。 优势 1. 提高图像质量 - 清晰度提升:减少抖动,提高图像的清晰度和细节表现力,使得监控画面更加真实可信。 - 细节增强:在低光条件下,抖

【数据结构】——原来排序算法搞懂这些就行,轻松拿捏

前言:快速排序的实现最重要的是找基准值,下面让我们来了解如何实现找基准值 基准值的注释:在快排的过程中,每一次我们要取一个元素作为枢纽值,以这个数字来将序列划分为两部分。 在此我们采用三数取中法,也就是取左端、中间、右端三个数,然后进行排序,将中间数作为枢纽值。 快速排序实现主框架: //快速排序 void QuickSort(int* arr, int left, int rig

30常用 Maven 命令

Maven 是一个强大的项目管理和构建工具,它广泛用于 Java 项目的依赖管理、构建流程和插件集成。Maven 的命令行工具提供了大量的命令来帮助开发人员管理项目的生命周期、依赖和插件。以下是 常用 Maven 命令的使用场景及其详细解释。 1. mvn clean 使用场景:清理项目的生成目录,通常用于删除项目中自动生成的文件(如 target/ 目录)。共性规律:清理操作

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问

秋招最新大模型算法面试,熬夜都要肝完它

💥大家在面试大模型LLM这个板块的时候,不知道面试完会不会复盘、总结,做笔记的习惯,这份大模型算法岗面试八股笔记也帮助不少人拿到过offer ✨对于面试大模型算法工程师会有一定的帮助,都附有完整答案,熬夜也要看完,祝大家一臂之力 这份《大模型算法工程师面试题》已经上传CSDN,还有完整版的大模型 AI 学习资料,朋友们如果需要可以微信扫描下方CSDN官方认证二维码免费领取【保证100%免费

uva 10801(乘电梯dijkstra)

题意: 给几个电梯,电梯0 ~ n-1分别可以到达很多层楼。 换乘电梯需要60s时间。 问从0层到target层最小的时间。 解析: 将进入第0层的电梯60s也算上,最后减。 坑点是如果target为0输出0。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algori