【PAT】1109. Group Photo (25)【模拟】

2024-04-12 06:08
文章标签 模拟 25 pat group photo 1109

本文主要是介绍【PAT】1109. Group Photo (25)【模拟】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the
    nearest integer), with all the extra people (if any) standing in the
    last row;
  • All the people in the rear row must be no shorter than anyone
    standing in the front rows;
  • In each row, the tallest one stands at the central position (which is
    defined to be the position (m/2+1), where m is the total number of
    people in that row, and the division result must be rounded down to
    the nearest integer);

In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

翻译:在合影时,队形很重要。给定N人组成K行的规则如下:

  • 每一行的人数必须是N/K(四舍五入到最近的整数),所有多余的人(如果有)都站在最后一行。
  • 所有在后排的人不得矮于任何站在前排的人。
  • 在每一行,最高的一个人站在中央位置(即定义为位置(m/2+1),其中m是这一行的总人数,除法的结果必须四舍五入到最近的整数)。

在每一行,其他人必须按照各自高度降序排序,交替确定位置,先选择最高的右边,再是最高的左边,(例如五人的高度190,188,186,175,到170年,最后形成的是175 188 190 186 170。这里我们假设您正处在面临该队伍的一个中央位置,你的左手边是右边。)
有许多人拥有相同的高度时,他们必须在名字的字母顺序升序排序,并且数据保证没有重复的名字。
现在给定一组人的信息,您需要编写一个程序来输出他们的信息。

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10​4), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括两个正整数,分别为N(≤10​4),代表总人数;和K (≤10), 代表总行数。接下来N行,每行给出一个人的姓名(不超过8位英文字母,中间没有空格)和他/她的身高。(一个在 [30, 300]内的数字)

Output Specification:

For each case, print the formation – that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

翻译:对于每组输入数据,输出编队——即输出K行人们的姓名。姓名之间必须用一个空格隔开,但是行末尾不能有多余空格。注意:由于你正对队伍,最里面那行的人必须在前面行的人之前输出。


Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159


Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John


解题思路

新建一个People类型结构体并重载<符号,排序输出。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<map>
#include<queue> 
#include<algorithm>
#define INF 99999999
using namespace std;
int N,K; 
struct People{char name[20];int height;	bool operator <(const People a)const{return a.height == height ? strcmp(name,a.name)<0 : a.height < height;}
}p[10010];
vector<People> v; 
int main(){scanf("%d %d",&N,&K);for(int i=0;i<N;i++){scanf("%s %d",p[i].name,&p[i].height);	}sort(p,p+N);int pre=0,pro=0,tmp=N/K,temp=0;for(int j=0;j<K;j++){temp=tmp;if(j==0)temp+=N%K;pro=pre+temp;for(int i=pre;i<pro;i++){if((i-pre)%2==0)	v.push_back(p[i]);else 		v.insert(v.begin(),p[i]);}for(int i=0;i<v.size();i++){if(i==0)printf("%s",v[i].name);else printf(" %s",v[i].name);}printf("\n");v.clear();pre+=temp;}return 0;
}

这篇关于【PAT】1109. Group Photo (25)【模拟】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/896309

相关文章

【C++】_list常用方法解析及模拟实现

相信自己的力量,只要对自己始终保持信心,尽自己最大努力去完成任何事,就算事情最终结果是失败了,努力了也不留遗憾。💓💓💓 目录   ✨说在前面 🍋知识点一:什么是list? •🌰1.list的定义 •🌰2.list的基本特性 •🌰3.常用接口介绍 🍋知识点二:list常用接口 •🌰1.默认成员函数 🔥构造函数(⭐) 🔥析构函数 •🌰2.list对象

usaco 1.2 Transformations(模拟)

我的做法就是一个一个情况枚举出来 注意计算公式: ( 变换后的矩阵记为C) 顺时针旋转90°:C[i] [j]=A[n-j-1] [i] (旋转180°和270° 可以多转几个九十度来推) 对称:C[i] [n-j-1]=A[i] [j] 代码有点长 。。。 /*ID: who jayLANG: C++TASK: transform*/#include<

hdu4431麻将模拟

给13张牌。问增加哪些牌可以胡牌。 胡牌有以下几种情况: 1、一个对子 + 4组 3个相同的牌或者顺子。 2、7个不同的对子。 3、13幺 贪心的思想: 对于某张牌>=3个,先减去3个相同,再组合顺子。 import java.io.BufferedInputStream;import java.io.BufferedReader;import java.io.IOExcepti

【每日一题】LeetCode 2181.合并零之间的节点(链表、模拟)

【每日一题】LeetCode 2181.合并零之间的节点(链表、模拟) 题目描述 给定一个链表,链表中的每个节点代表一个整数。链表中的整数由 0 分隔开,表示不同的区间。链表的开始和结束节点的值都为 0。任务是将每两个相邻的 0 之间的所有节点合并成一个节点,新节点的值为原区间内所有节点值的和。合并后,需要移除所有的 0,并返回修改后的链表头节点。 思路分析 初始化:创建一个虚拟头节点

matlab读取NC文件(含group)

matlab读取NC文件(含group): NC文件数据结构: 代码: % 打开 NetCDF 文件filename = 'your_file.nc'; % 替换为你的文件名% 使用 netcdf.open 函数打开文件ncid = netcdf.open(filename, 'NC_NOWRITE');% 查看文件中的组% 假设我们想读取名为 "group1" 的组groupName

每日一题|牛客竞赛|四舍五入|字符串+贪心+模拟

每日一题|四舍五入 四舍五入 心有猛虎,细嗅蔷薇。你好朋友,这里是锅巴的C\C++学习笔记,常言道,不积跬步无以至千里,希望有朝一日我们积累的滴水可以击穿顽石。 四舍五入 题目: 牛牛发明了一种新的四舍五入应用于整数,对个位四舍五入,规则如下 12345->12350 12399->12400 输入描述: 输入一个整数n(0<=n<=109 ) 输出描述: 输出一个整数

【算法专场】模拟(下)

目录 前言 38. 外观数列 算法分析 算法思路 算法代码 1419. 数青蛙 算法分析 算法思路 算法代码  2671. 频率跟踪器 算法分析 算法思路 算法代码 前言 在前面我们已经讲解了什么是模拟算法,这篇主要是讲解在leetcode上遇到的一些模拟题目~ 38. 外观数列 算法分析 这道题其实就是要将连续且相同的字符替换成字符重复的次数+

模拟实现vector中的常见接口

insert void insert(iterator pos, const T& x){if (_finish == _endofstorage){int n = pos - _start;size_t newcapacity = capacity() == 0 ? 2 : capacity() * 2;reserve(newcapacity);pos = _start + n;//防止迭代

PHP实现二叉树遍历(非递归方式,栈模拟实现)

二叉树定义是这样的:一棵非空的二叉树由根结点及左、右子树这三个基本部分组成,根据节点的访问位置不同有三种遍历方式: ① NLR:前序遍历(PreorderTraversal亦称(先序遍历)) ——访问结点的操作发生在遍历其左右子树之前。 ② LNR:中序遍历(InorderTraversal) ——访问结点的操作发生在遍历其左右子树之中(间)。 ③ LRN:后序遍历(PostorderT

【JavaScript】LeetCode:21-25

文章目录 21 最大子数组和22 合并区间23 轮转数组24 除自身以外数组的乘积25 缺失的第一个正数 21 最大子数组和 贪心 / 动态规划贪心:连续和(count)< 0时,放弃当前起点的连续和,将下一个数作为新起点,这里提供使用贪心算法解决本题的代码。动态规划:dp[i]:以nums[i]为结尾的最长连续子序列(子数组)和。 dp[i] = max(dp[i - 1]