本文主要是介绍(甲)1042 Shuffling Machine (20 分),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目:
Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:
S1, S2, ..., S13,
H1, H2, ..., H13,
C1, C2, ..., C13,
D1, D2, ..., D13,
J1, J2
where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.
Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
题意:
就是让你模拟洗牌器,把扑克牌按照要求排序;
给你一个K,代表按照要求洗牌K次;
下面给出了54个数字;
洗牌:如果第i个位置的数字是j,则意味着将卡从位置i移动到位置j;
思路:
因为扑克牌是用字符串来表示的,在洗牌的时候交换不容易,所以我们直接先用数字来代表扑克牌,这样在洗牌交换时简单;
例如:
2
2 3 4 5 6 1
第一次洗牌后:1 2 3 4 5 6 (把第一位的2放到位置2,把第二位的3放到位置3..............);
第二次洗牌后:6 1 2 3 4 5
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;int k,n=54;char a[56][5]= {"S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13","H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13","C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13","D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13","J1","J2"} ;//存储扑克牌的最开始的顺序;
int s[56];//存储交换的顺序;
int b[56];//存储扑克牌的顺序;(用数字来代替扑克牌);
int c[56];//交换的时候用来暂时存储;int main()
{int i,j;scanf("%d",&k);for(i=1; i<=n; i++){scanf("%d",&s[i]);}for(i=1;i<=n;i++){b[i]=i;}while(k--){for(i=1;i<=n;i++){c[s[i]]=b[i];//把第i位置上的数字b[i],从位置i移动到位置b[i]上;}for(i=1;i<=n;i++){b[i]=c[i];}}for(i=1;i<n;i++)//输出扑克牌的顺序,注意输出格式;{printf("%s ",a[b[i]-1]);}printf("%s\n",a[b[n]-1]);return 0;
}
这篇关于(甲)1042 Shuffling Machine (20 分)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!