本文主要是介绍Hdu1233 step6.1.4还是畅通工程(克鲁斯卡尔),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Hdu1233 step6.1.4还是畅通工程
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22072 Accepted Submission(s): 9855
Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N (< 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
3
5
Hint
Hint
Huge input, scanf is recommended.
Source
浙大计算机研究生复试上机考试-2006年
题解:
克鲁斯卡尔求最小生成树,在现有条件下找到最短路径。
源代码:
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct Road
{
intc1,c2,value;
}rd[10050];
int node[105];
void init()
{
memset(node,-1,sizeof(node));
}
int find_set(int x)
{
if(node[x]== -1)
returnx;
returnnode[x] = find_set(node[x]);
}
bool merge(int x,int y)
{
intr1 = find_set(x);
intr2 = find_set(y);
if(r1== r2)
return0;
if(r1< r2)
node[r2] = r1;
else
node[r1] = r2;
return1;
}
bool mycmp(const Road &x,const Road &y)
{
if(x.value< y.value)
returntrue;
else
returnfalse;
}
int main()
{
intn;
while(scanf("%d",&n) && n)
{
init();
intm = n*(n-1)/2;
for(int i = 0;i < m;i++)
{
scanf("%d%d%d",&rd[i].c1,&rd[i].c2,&rd[i].value);
}
sort(rd,rd+m,mycmp);
intsum = 0,count = 0;
for(int i = 0;i < m;i++)
{
if(merge(rd[i].c1,rd[i].c2))
{
sum += rd[i].value;
count++;
}
if(count== n-1)
break;
}
printf("%d\n",sum);
}
return0;
}
这篇关于Hdu1233 step6.1.4还是畅通工程(克鲁斯卡尔)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!