poj 3268 Silver Cow Party(单源最短路径Dijkstra·最小环)

2024-03-27 23:32

本文主要是介绍poj 3268 Silver Cow Party(单源最短路径Dijkstra·最小环),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=11757

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

Submit Status

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X
Lines 2..  M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
终点给出,是一个定点。所有的牛犊都会到达该点并且由通过不同的道路回到原点。由此想到单源最短路径,把终点看作源点S,但是怎么回去呢?看了一个大神的博客,矩阵转置(第一次自己转置都写错了||-_-)。效果:(1,2) (2,7) (7,4)  --> (2,1) (7,2) (4,7) means (4,7) (7,2) (2,1)  起点和终点的地位互换!这样再一次用Dijkstra或者spfa等算法求出回家的最短路径就构成了环路。
关于矩阵转置举个例子:
for(int i=0;i<4;i++){
         for(int j=0;j<=i;j++){
             swap(a.m[i][j],a.m[j][i]);
         }
}
不是:
for(int i=0;i<4;i++){
         for(int j=0;j<4;j++){
             swap(a.m[i][j],a.m[j][i]);
         }
}
来看看效果:
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
struct matrie{int m[4][4];
};
matrie a={
1,2,3,4,
7,3,5,5,
6,6,6,6,
0,0,0,0
};
void show(){cout<<"show: \n";for(int i=0;i<4;i++){for(int j=0;j<4;j++){cout<<a.m[i][j]<<" ";}cout<<endl;}
}
void trans(){for(int i=0;i<4;i++){for(int j=0;j<=i;j++){swap(a.m[i][j],a.m[j][i]);cout<<i<<" "<<j<<": "<<endl;show();}}
}int main()
{trans();return 0;
}
0 0: 
show: 
1 2 3 4 
7 3 5 5 
6 6 6 6 
0 0 0 0 
1 0: 
show: 
1 7 3 4 
2 3 5 5 
6 6 6 6 
0 0 0 0 
1 1: 
show: 
1 7 3 4 
2 3 5 5 
6 6 6 6 
0 0 0 0 
2 0: 
show: 
1 7 6 4 
2 3 5 5 
3 6 6 6 
0 0 0 0 
2 1: 
show: 
1 7 6 4 
2 3 6 5 
3 5 6 6 
0 0 0 0 
2 2: 
show: 
1 7 6 4 
2 3 6 5 
3 5 6 6 
0 0 0 0 
3 0: 
show: 
1 7 6 0 
2 3 6 5 
3 5 6 6 
4 0 0 0 
3 1: 
show: 
1 7 6 0 
2 3 6 0 
3 5 6 6 
4 5 0 0 
3 2: 
show: 
1 7 6 0 
2 3 6 0 
3 5 6 0 
4 5 6 0 
3 3: 
show: 
1 7 6 0 
2 3 6 0 
3 5 6 0 
4 5 6 0 
是的,就是这样。
Dijkstra:基于贪心的思想。不足之处在于不能有负边,用于求解单源最短路径问题。这里没有负边问题,所以我就用它吧。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1005,INF=0x3f3f3f3f;
int dis1[maxn],dis2[maxn],map[maxn][maxn],pre[maxn];
int n,m,s;
bool p[maxn];
void Dijkstra(int dis[]){memset(p,0,sizeof(p));for(int i=1;i<=n;i++){if(i!=s){ dis[i]=map[s][i]; pre[i]=s; }else pre[i]=0;}dis[s]=0;p[s]=1;for(int i=1;i<n;i++){  //循环n-1次,求s到其他n-1个点的最短距离int minm=INF,k=0;for(int j=1;j<=n;j++){ //寻找最近的点if(p[j]==0&&dis[j]<minm){minm=dis[j];k=j;}}if(k==0) return;  //没有可以拓展的点p[k]=1;for(int j=1;j<=n;j++){  if(p[j]==0&&map[k][j]!=INF&&dis[j]>dis[k]+map[k][j]){ //利用最近的点更新其他点的距离dis[j]=dis[k]+map[k][j];pre[j]=k;}}}
}
void trans(){for(int i=1;i<=n;i++){for(int j=1;j<=i;j++){swap(map[i][j],map[j][i]);}}
}
int main()
{//freopen("cin.txt","r",stdin);while(cin>>n>>m>>s){int a,b,c;memset(map,0x3f,sizeof(map));for(int i=1;i<=n;i++) map[i][i]=0;while(m--){scanf("%d%d%d",&a,&b,&c);if(a!=b&&map[a][b]>c)map[a][b]=c;}Dijkstra(dis1);trans();Dijkstra(dis2);int ans=0;for(int i=1;i<=n;i++){if(i!=s)ans=max(ans,dis1[i]+dis2[i]);}printf("%d\n",ans);}return 0;
}


这篇关于poj 3268 Silver Cow Party(单源最短路径Dijkstra·最小环)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/853768

相关文章

python获取当前文件和目录路径的方法详解

《python获取当前文件和目录路径的方法详解》:本文主要介绍Python中获取当前文件路径和目录的方法,包括使用__file__关键字、os.path.abspath、os.path.realp... 目录1、获取当前文件路径2、获取当前文件所在目录3、os.path.abspath和os.path.re

hdu2544(单源最短路径)

模板题: //题意:求1到n的最短路径,模板题#include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<queue>#include<set>#include<map>#include<stdio.h>#include<stdlib.h>#include<ctype.h>#i

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问