本文主要是介绍poj 3268 Silver Cow Party(单源最短路径Dijkstra·最小环),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=11757
Time Limit: 2000MS | Memory Limit: 65536KB | 64bit IO Format: %I64d & %I64u |
Description
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Sample Input
4 8 2 1 2 4 1 3 2 1 4 7 2 1 1 2 3 5 3 1 2 3 4 4 4 2 3
Sample Output
10
Hint
关于矩阵转置举个例子:
for(int i=0;i<4;i++){
for(int j=0;j<=i;j++){
swap(a.m[i][j],a.m[j][i]);
}
}
不是:
for(int i=0;i<4;i++){
for(int j=0;j<4;j++){
swap(a.m[i][j],a.m[j][i]);
}
}
来看看效果:
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
struct matrie{int m[4][4];
};
matrie a={
1,2,3,4,
7,3,5,5,
6,6,6,6,
0,0,0,0
};
void show(){cout<<"show: \n";for(int i=0;i<4;i++){for(int j=0;j<4;j++){cout<<a.m[i][j]<<" ";}cout<<endl;}
}
void trans(){for(int i=0;i<4;i++){for(int j=0;j<=i;j++){swap(a.m[i][j],a.m[j][i]);cout<<i<<" "<<j<<": "<<endl;show();}}
}int main()
{trans();return 0;
}
0 0:
show:
1 2 3 4
7 3 5 5
6 6 6 6
0 0 0 0
1 0:
show:
1 7 3 4
2 3 5 5
6 6 6 6
0 0 0 0
1 1:
show:
1 7 3 4
2 3 5 5
6 6 6 6
0 0 0 0
2 0:
show:
1 7 6 4
2 3 5 5
3 6 6 6
0 0 0 0
2 1:
show:
1 7 6 4
2 3 6 5
3 5 6 6
0 0 0 0
2 2:
show:
1 7 6 4
2 3 6 5
3 5 6 6
0 0 0 0
3 0:
show:
1 7 6 0
2 3 6 5
3 5 6 6
4 0 0 0
3 1:
show:
1 7 6 0
2 3 6 0
3 5 6 6
4 5 0 0
3 2:
show:
1 7 6 0
2 3 6 0
3 5 6 0
4 5 6 0
3 3:
show:
1 7 6 0
2 3 6 0
3 5 6 0
4 5 6 0
是的,就是这样。
Dijkstra:基于贪心的思想。不足之处在于不能有负边,用于求解单源最短路径问题。这里没有负边问题,所以我就用它吧。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1005,INF=0x3f3f3f3f;
int dis1[maxn],dis2[maxn],map[maxn][maxn],pre[maxn];
int n,m,s;
bool p[maxn];
void Dijkstra(int dis[]){memset(p,0,sizeof(p));for(int i=1;i<=n;i++){if(i!=s){ dis[i]=map[s][i]; pre[i]=s; }else pre[i]=0;}dis[s]=0;p[s]=1;for(int i=1;i<n;i++){ //循环n-1次,求s到其他n-1个点的最短距离int minm=INF,k=0;for(int j=1;j<=n;j++){ //寻找最近的点if(p[j]==0&&dis[j]<minm){minm=dis[j];k=j;}}if(k==0) return; //没有可以拓展的点p[k]=1;for(int j=1;j<=n;j++){ if(p[j]==0&&map[k][j]!=INF&&dis[j]>dis[k]+map[k][j]){ //利用最近的点更新其他点的距离dis[j]=dis[k]+map[k][j];pre[j]=k;}}}
}
void trans(){for(int i=1;i<=n;i++){for(int j=1;j<=i;j++){swap(map[i][j],map[j][i]);}}
}
int main()
{//freopen("cin.txt","r",stdin);while(cin>>n>>m>>s){int a,b,c;memset(map,0x3f,sizeof(map));for(int i=1;i<=n;i++) map[i][i]=0;while(m--){scanf("%d%d%d",&a,&b,&c);if(a!=b&&map[a][b]>c)map[a][b]=c;}Dijkstra(dis1);trans();Dijkstra(dis2);int ans=0;for(int i=1;i<=n;i++){if(i!=s)ans=max(ans,dis1[i]+dis2[i]);}printf("%d\n",ans);}return 0;
}
这篇关于poj 3268 Silver Cow Party(单源最短路径Dijkstra·最小环)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!