本文主要是介绍uva 12563 Jin Ge Jin Qu hao,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
原题:
(If you smiled when you see the title, this problem is for you ^_^)
For those who don’t know KTV, see: http://en.wikipedia.org/wiki/Karaoke_box
There is one very popular song called Jin Ge Jin Qu(). It is a mix of 37 songs, and is extremely
long (11 minutes and 18 seconds) — I know that there are Jin Ge Jin Qu II and III, and some other
unofficial versions. But in this problem please forget about them.
Why is it popular? Suppose you have only 15 seconds left (until your time is up), then you should
select another song as soon as possible, because the KTV will not crudely stop a song before it ends
(people will get frustrated if it does so!). If you select a 2-minute song, you actually get 105 extra
seconds! ….and if you select Jin Ge Jin Qu, you’ll get 663 extra seconds!!!
Now that you still have some time, but you’d like to make a plan now. You should stick to the
following rules:
• Don’t sing a song more than once (including Jin Ge Jin Qu).
• For each song of length t, either sing it for exactly t seconds, or don’t sing it at all.
• When a song is finished, always immediately start a new song.
Your goal is simple: sing as many songs as possible, and leave KTV as late as possible (since we
have rule 3, this also maximizes the total lengths of all songs we sing) when there are ties.
Input
The first line contains the number of test cases T (T ≤ 100). Each test case begins with two positive
integers n, t (1 ≤ n ≤ 50, 1 ≤ t ≤ 109), the number of candidate songs (BESIDES Jin Ge Jin Qu)
and the time left (in seconds). The next line contains n positive integers, the lengths of each song, in
seconds. Each length will be less than 3 minutes — I know that most songs are longer than 3 minutes.
But don’t forget that we could manually “cut” the song after we feel satisfied, before the song ends.
So here “length” actually means “length of the part that we want to sing”.
It is guaranteed that the sum of lengths of all songs (including Jin Ge Jin Qu) will be strictly larger
than t.
Output
For each test case, print the maximum number of songs (including Jin Ge Jin Qu), and the total lengths
of songs that you’ll sing.
Explanation:
In the first example, the best we can do is to sing the third song (80 seconds), then Jin Ge Jin Qu
for another 678 seconds.
In the second example, we sing the first two (30+69=99 seconds). Then we still have one second
left, so we can sing Jin Ge Jin Qu for extra 678 seconds. However, if we sing the first and third song
instead (30+70=100 seconds), the time is already up (since we only have 100 seconds in total), so we
can’t sing Jin Ge Jin Qu anymore!
Sample Input
2
3 100
60 70 80
3 100
30 69 70
Sample Output
Case 1: 2 758
Case 2: 3 777
大意:
给你一个数n和一个数t分别表示有n首歌和t分钟以及题目中已经告诉你的一个劲歌金曲,现在问你在t时间内最多能唱多少歌,能唱多长时间。而且能把那首劲歌金曲带上,唱歌唱到半道不会停。
#include <bits/stdc++.h>
using namespace std;
//fstream in,out;
const int jgjq=678;
int sdp[9700];
int cdp[9700];
int song[51],t,n;
int main()
{ios::sync_with_stdio(false);int Case;cin>>Case;for(int k=1;k<=Case;k++){cin>>n>>t;int tot=0;memset(sdp,0,sizeof(sdp));memset(cdp,0,sizeof(cdp));for(int i=1;i<=n;i++){cin>>song[i];tot+=song[i];}if(tot<t){cout<<"Case "<<k<<": "<<n+1<<" "<<tot+jgjq<<endl;continue;}for(int i=1;i<=n;i++){for(int j=t-1;j>=song[i];--j){if(cdp[j]<cdp[j-song[i]]+1){cdp[j]=cdp[j-song[i]]+1;sdp[j]=sdp[j-song[i]]+song[i];}if(cdp[j]==cdp[j-song[i]]+1)sdp[j]=max(sdp[j],sdp[j-song[i]]+song[i]);}}cout<<"Case "<<k<<": "<<cdp[t-1]+1<<" "<<sdp[t-1]+jgjq<<endl;}return 0;
}
解答:
刘汝佳紫书的例题,差不多是裸的01背包加上01背包计数问题,转移方程也是01背包的转移方程。这里注意选取唱歌最多的时间是在得到唱歌最多的基础上的。
这篇关于uva 12563 Jin Ge Jin Qu hao的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!