uva 11168 Airport

2024-03-24 08:38
文章标签 uva airport 11168

本文主要是介绍uva 11168 Airport,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

原题:
There is a small town with n houses. The town needs an airport. An airport is basically a very
long, very straight road. Think of it as an infinite line. We need to build the airport such that the
average distance from each house to the airport is as small as possible. However, no one wants to walk across the runway, so all of the houses must be on the same side of the airport. (Some houses may be a distance of zero away from the runway, but that’s ok; we’ll give them some free ear plugs.) Where should we build the airport, and what will be the average distance?
Input
The first line of input gives the number of cases, N (≤ 65). N test cases follow. Each one is a
line containing n (0 < n ≤ 10000), followed by n lines giving the xy-coordinates of the houses. All
coordinates are integers with absolute value of at most 80,000.
Output
For each test case, output one line containing ‘Case #x:’ followed by the average distance from the airport to the houses, with 3 digits after the decimal point. No answer will be within 10 −5 of a round-off error case.
Sample Input
4
4
0 0
0 1
1 0
1 1
2
15035 39572
34582 39535
3
0 0
0 1
1 0
5
0 0
0 2
2 0
2 2
1 1
Sample Output
Case #1: 0.500
Case #2: 0.000
Case #3: 0.236
Case #4: 1.000

中文:
现在要建立一个机场,这个机场看成是一条无限长的直线。现在又n个居民点,所有居民点要在机场的一侧,而且居民点可以在机场的这条线上。现在问你,所有居民点到机场的距离的平均值最小能是多少?

#include <bits/stdc++.h>
#define Vector Point
using namespace std;
//fstream in,out;
const int maxn=10005;
const double PI=acos(-1);
double torad(double deg)
{return deg/180*PI;
}
struct Point
{double x,y;Point(double x=0,double y=0):x(x),y(y){}
};bool operator < (const Point &a,const Point &b)
{return a.x<b.x||(a.x==b.x&&a.y<b.y);
}
Vector operator +(Vector A,Vector B){return Vector(A.x+B.x,A.y+B.y);}
Vector operator -(Vector A,Vector B){return Vector(A.x-B.x,A.y-B.y);}
double Cross(Vector A,Vector B)
{return A.x*B.y-A.y*B.x;
}
int ConvexHull(Point *p,int n,Point *ch)
{sort(p,p+n);int m=0;for(int i=0;i<n;i++){while(m>1&&Cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0)m--;ch[m++]=p[i];}int k=m;for(int i=n-2;i>=0;i--){while(m>k&&Cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0)m--;ch[m++]=p[i];}if(n>1)m--;return m;
}
double Distance(Point a,Point b,double totx,double toty,int n)
{double A=b.y-a.y;double B=a.x-b.x;double C=a.y*b.x-b.y*a.x;double dis=fabs(totx*A+toty*B+n*C)/sqrt(A*A+B*B);return dis;
}
int main()
{ios::sync_with_stdio(false);int t,n,k=1;Point P[maxn],ch[maxn];cin>>t;while(t--){int pc=0;double ans=INT_MAX;cin>>n;double totx=0,toty=0;for(int i=0;i<n;i++){cin>>P[i].x>>P[i].y;totx+=P[i].x;toty+=P[i].y;}int m=ConvexHull(P,n,ch);cout<<"Case #"<<k++<<": ";if(m<=2){cout<<"0.000"<<endl;continue;}for(int i=1;i<m;i++)ans=min(ans,Distance(ch[i-1],ch[i],totx,toty,n));ans=min(ans,Distance(ch[m-1],ch[0],totx,toty,n));
//      cout<<ans<<endl;cout<<fixed<<setprecision(3)<<ans/(n*1.0)<<endl;}return 0;
}

解答:
很明显这条机场要建立在这些居民点形成的凸包的一条边上面,枚举凸包的每一条边。然后用距离公式求和即可。这里注意,由于所有居民点都在直线的同一侧,所以可以把所有局面点的x坐标值和y的坐标值累加,利用AX+By+C=0的点到直线方程直接求出来。两点式直线方程当中,设a点为(x1,y1),b点为(x2,y2)

k=y1y2x1x2
b=y2x1y1x2x1x2
想要换成标准式,求出A,B,C的值,把式子左右两侧乘以 x1x2 即可

(y2y1)x+(x1x2)y+y1x2y2x1=0
注意此题如果m=0的时候记得直接判定距离为0~

这篇关于uva 11168 Airport的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/841048

相关文章

uva 10055 uva 10071 uva 10300(水题两三道)

情歌两三首,水题两三道。 好久没敲代码了为暑假大作战热热身。 uva 10055 Hashmat the Brave Warrior 求俩数相减。 两个debug的地方,一个是longlong,一个是输入顺序。 代码: #include<stdio.h>int main(){long long a, b;//debugwhile(scanf("%lld%lld", &

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

uva 10387 Billiard(简单几何)

题意是一个球从矩形的中点出发,告诉你小球与矩形两条边的碰撞次数与小球回到原点的时间,求小球出发时的角度和小球的速度。 简单的几何问题,小球每与竖边碰撞一次,向右扩展一个相同的矩形;每与横边碰撞一次,向上扩展一个相同的矩形。 可以发现,扩展矩形的路径和在当前矩形中的每一段路径相同,当小球回到出发点时,一条直线的路径刚好经过最后一个扩展矩形的中心点。 最后扩展的路径和横边竖边恰好组成一个直

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一

uva 568 Just the Facts(n!打表递推)

题意是求n!的末尾第一个不为0的数字。 不用大数,特别的处理。 代码: #include <stdio.h>const int maxn = 10000 + 1;int f[maxn];int main(){#ifdef LOCALfreopen("in.txt", "r", stdin);#endif // LOCALf[0] = 1;for (int i = 1; i <=

uva 575 Skew Binary(位运算)

求第一个以(2^(k+1)-1)为进制的数。 数据不大,可以直接搞。 代码: #include <stdio.h>#include <string.h>const int maxn = 100 + 5;int main(){char num[maxn];while (scanf("%s", num) == 1){if (num[0] == '0')break;int len =

uva 10014 Simple calculations(数学推导)

直接按照题意来推导最后的结果就行了。 开始的时候只做到了第一个推导,第二次没有继续下去。 代码: #include<stdio.h>int main(){int T, n, i;double a, aa, sum, temp, ans;scanf("%d", &T);while(T--){scanf("%d", &n);scanf("%lf", &first);scanf

uva 10916 Factstone Benchmark(打表)

题意是求 k ! <= 2 ^ n ,的最小k。 由于n比较大,大到 2 ^ 20 次方,所以 2 ^ 2 ^ 20比较难算,所以做一些基础的数学变换。 对不等式两边同时取log2,得: log2(k ! ) <=  log2(2 ^ n)= n,即:log2(1) + log2(2) + log2 (3) + log2(4) + ... + log2(k) <= n ,其中 n 为 2 ^

uva 10025 The ? 1 ? 2 ? ... ? n = k problem(数学)

题意是    ?  1  ?  2  ?  ...  ?  n = k 式子中给k,? 处可以填 + 也可以填 - ,问最小满足条件的n。 e.g k = 12  - 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 with n = 7。 先给证明,令 S(n) = 1 + 2 + 3 + 4 + 5 + .... + n 暴搜n,搜出当 S(n) >=