本文主要是介绍uva 532 Dungeon Master,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
原题:
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. Is an escape possible? If yes, how long will it take?
Input
The input file consists of a number of dungeons. Each dungeon description starts with a line containing
three integers L, R and C (all limited to 30 in size). L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level. Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a’.’ Your starting position is indicated by ‘S’ and the exit by the letter ’E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S…
.###.
.##…
###.#
##.##
##…
#.###
####E
1 3 3
S##
#E#
0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
中文:
给你一个三维迷宫,起点标成S,终点标成E,能走的地方是’.’,不能走的地方是’#’,现在问你从S走到E如果能走通,最少要走多少步,如果不能走通,输出Trapped!
代码:
#include <bits/stdc++.h>using namespace std;
struct node
{int x,y,z;int cnt;node(){x=y=z=cnt=0;}node(int xx,int yy,int zz,int c){x=xx,y=yy,z=zz,cnt=c;}
};
int L,R,C;
char maze[31][31][31];
bool vis[31][31][31];
int Move[6][3]={{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};
bool edge(int x,int y,int z)
{if(x>=1&&x<=L&&y>=1&&y<=R&&z>=1&&z<=C)return true;return false;
}int bfs(node st,node en)
{memset(vis,0,sizeof(vis));queue<node> Q;Q.push(st);vis[st.x][st.y][st.z]=1;while(!Q.empty()){node tmp=Q.front();Q.pop();for(int i=0;i<6;i++){node res(tmp.x+Move[i][0],tmp.y+Move[i][1],tmp.z+Move[i][2],tmp.cnt+1);if(res.x==en.x&&res.y==en.y&&res.z==en.z)return res.cnt;if(edge(res.x,res.y,res.z)&&!vis[res.x][res.y][res.z]&&maze[res.x][res.y][res.z]=='.'){Q.push(res);vis[res.x][res.y][res.z]=1;}}}return -1;
}
int main()
{ios::sync_with_stdio(false);while(cin>>L>>R>>C,L+R+C){node st,en;for(int i=1;i<=L;i++){for(int j=1;j<=R;j++){for(int k=1;k<=C;k++){cin>>maze[i][j][k];if(maze[i][j][k]=='S'){st.x=i,st.y=j,st.z=k;}if(maze[i][j][k]=='E'){en.x=i,en.y=j,en.z=k;}}}}int ans=bfs(st,en);if(ans!=-1)cout<<"Escaped in "<<ans<<" minute(s)."<<endl;elsecout<<"Trapped!"<<endl;}return 0;
}
思路:
裸的广搜,没啥好说的~
这篇关于uva 532 Dungeon Master的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!